2019-12-08 14:24 CET

View Issue Details Jump to Notes ] Related Changesets ]
IDProjectCategoryView StatusLast Update
0004698Spring engineGfx driver issuespublic2015-06-25 21:00
ReporterAnarchid 
Assigned TojK 
PriorityhighSeverityblockReproducibilityalways
StatusresolvedResolutionfixed 
Product Version98.0.1+git 
Target VersionFixed in Version 
Summary0004698: 98.0.1-423 practically hangs rendering (linux/nvidia/primusrun)
DescriptionStarting any game with 98.0.1-423, the game is rendered at ~0 FPS.

This didn't happen in 98.0.1-403.

There is occasionally some tearing, but the game generally seems to run, albeit at super slow speed.

Infolog with DebugGLStacktraces, using old version of BA, quit via -9
http://paste.springfiles.com/view/35a4ca62

Infolog with DebugGLStacktraces, using git version of ZK, quit via ingame UI and patience
http://paste.springfiles.com/view/d19030f3


TagsNo tags attached.
Checked infolog.txt for Errors
Attached Files

-Relationships
duplicate of 0004701resolvedjK 98.0.1-423 practically hangs rendering (on linux/nvidia/primusrun) 
+Relationships

-Notes

~0014145

lamer (reporter)

2nd link is broken 404.
I guess the address is not fully copy-pasted, probably
http://paste.springfiles.com/view/d19030f3

~0014146

Anarchid (reporter)

Unfortunately mantis won't let me edit it now.

~0014147

Anarchid (reporter)

Last edited: 2015-03-11 23:58

View 2 revisions

Had time to try testing some intermediate versions.

98.0.1-420-g7ee497b: bad
98.0.1-413-gd120cae: bad

So it's between 409 and 412... will continue tomorrow.

Looking at commits, changes between 409 and 413 don't even touch GL? What.

~0014152

msafwan (reporter)

could it work if GlStacktrace disabled? I had hang too when I enable it when making report for https://springrts.com/mantis/view.php?id=4700

~0014156

Anarchid (reporter)

Last edited: 2015-03-12 23:12

View 3 revisions

The issue still happens with DebugGlStacktraces=0 and DebugGl=0; i only enabled those after encountering it.

I didn't turn it off during bisecting, so i'll redo the bisects. Though even with those still on, behaviour in self-compiled 408 looked good.

As requested by Abma in chat, here's infolog with debug symbols (using a rather dated but well working version of TechA):
http://paste.springfiles.com/view/1dc82cc2

~0014157

abma (administrator)

Last edited: 2015-03-12 23:11

View 2 revisions

with debug info:

http://paste.springfiles.com/view/1dc82cc2

[07] rts/Rendering/Shaders/GLSLCopyState.cpp:215 CopyShaderState_Uniforms
  <08> rts/Rendering/Shaders/GLSLCopyState.cpp:277 CopyShaderState_UniformBlocks
[08] rts/Rendering/Shaders/GLSLCopyState.cpp:428 Shader::GLSLCopyState(unsigned int, unsigned int, std::unordered_map<unsigned long, Shader::Un [...]
[09] rts/Rendering/Shaders/Shader.cpp:560 Shader::GLSLProgramObject::Reload(bool)
[10] rts/Rendering/Shaders/Shader.cpp:286 Shader::IProgramObject::RecompileIfNeeded()
[11] rts/Rendering/Shaders/Shader.cpp:435 Shader::GLSLProgramObject::Link()
[12] rts/Rendering/Env/Decals/GroundDecalHandler.cpp:166 CGroundDecalHandler::LoadDecalShaders()
[13] rts/Rendering/Env/Decals/GroundDecalHandler.cpp:87 (discriminator 1) CGroundDecalHandler::CGroundDecalHandler()
[14] rts/Rendering/Env/IGroundDecalDrawer.cpp:37 (discriminator 1) IGroundDecalDrawer::GetInstance()
[15] rts/Rendering/WorldDrawer.cpp:135 CWorldDrawer::Draw()
[16] rts/Game/Game.cpp:1333 CGame::Draw()
[17] rts/System/SpringApp.cpp:922 SpringApp::Update()
[18] rts/System/SpringApp.cpp:954 SpringApp::Run()
[19] rts/System/Main.cpp:48 Run(int, char**)
[20] rts/System/Main.cpp:108 main
[21] /build/buildd/eglibc-2.19/csu/libc-start.c:321 __libc_start_main
[22] ./spring() [0x58a2b9] _start

~0014158

abma (administrator)

before investigating engine more, imo these lua errors should be fixed first:

[f=0000000] Error in Shutdown()
[f=0000000] false
[f=0000000] Error in Shutdown(): [string "lups/lups.lua"]:1105: bad argument #1 to 'pairs' (table expected, got nil)
[f=0000000] Removed widget: Lups
[f=0000000] false
[f=0000000] Error in Initialize(): [string "lups/ParticleClasses/unitpiecelight.lua"]:356: bad argument #1 to 'CreateTexture' (Texture Size must be greater than zero!)
[f=0000000] Removed widget: Lups

~0014159

Anarchid (reporter)

The quoted error seems to be missing from the last paste, which would indicate that the lups error is not causal to this issue.

~0014160

abma (administrator)

especially "bad argument #1 to 'CreateTexture' (Texture Size must be greater than zero!)" is clearly an error

~0014161

Anarchid (reporter)

I don't think we're looking at the same data, then.

anarchid@wormbox:~$ wget http://paste.springfiles.com/view/raw/1dc82cc2 -o lastpaste.txt && grep -i "createtexture" ./lastpaste.txt | wc -l
0

~0014162

abma (administrator)

fixing this FIXME would give more useful info i guess:

//FIXME if (IsValid())

https://github.com/spring/spring/blob/develop/rts/Rendering/Shaders/Shader.cpp#L556

~0014705

jK (developer)

Fix 85071ebce97df864a5aa0ea02401e2be502f2ee9 committed to master branch: fix 0004698: I am pretty sure I commited that already ..., repo: spring changeset id: 5237
+Notes

+Related Changesets

-Issue History
Date Modified Username Field Change
2015-03-10 21:45 Anarchid New Issue
2015-03-10 22:31 lamer Note Added: 0014145
2015-03-10 22:39 Anarchid Note Added: 0014146
2015-03-11 23:42 Anarchid Note Added: 0014147
2015-03-11 23:58 Anarchid Note Edited: 0014147 View Revisions
2015-03-12 18:09 msafwan Note Added: 0014152
2015-03-12 23:08 Anarchid Note Added: 0014156
2015-03-12 23:08 Anarchid Note Edited: 0014156 View Revisions
2015-03-12 23:10 abma Note Added: 0014157
2015-03-12 23:11 abma Note Edited: 0014157 View Revisions
2015-03-12 23:12 Anarchid Note Edited: 0014156 View Revisions
2015-03-12 23:16 abma Note Added: 0014158
2015-03-12 23:30 Anarchid Note Added: 0014159
2015-03-12 23:31 abma Note Added: 0014160
2015-03-12 23:37 Anarchid Note Added: 0014161
2015-03-12 23:44 abma Note Added: 0014162
2015-03-12 23:45 abma Description Updated View Revisions
2015-03-12 23:47 abma Relationship added duplicate of 0004701
2015-03-12 23:47 abma Status new => closed
2015-03-12 23:47 abma Assigned To => abma
2015-03-12 23:47 abma Resolution open => duplicate
2015-06-25 21:00 jK Changeset attached => spring master 85071ebc
2015-06-25 21:00 jK Note Added: 0014705
2015-06-25 21:00 jK Assigned To abma => jK
2015-06-25 21:00 jK Status closed => resolved
2015-06-25 21:00 jK Resolution duplicate => fixed
+Issue History