[misc] enforcment of spring >= 104.0 for autohosts with botflag

[misc] enforcment of spring >= 104.0 for autohosts with botflag

Happenin' news on what is happening in the community. Content releases, new tutorials, other cool stuff.
abma
Spring Developer
Posts: 3560
Joined: 01 Jun 2009, 00:08

[misc] enforcment of spring >= 104.0 for autohosts with botflag

Post by abma » 25 Mar 2019, 22:23

as already announced earlier, on 8. April we will set the minimal required spring version to >=104.0 for hosting with a botflag.

viewtopic.php?f=64&p=589701

In short:

- using older spring versions blocks development
- older spring versions contain crash / DoS bugs
- we need to look forward: newer versions have more features / cleaner code / scale better / are more friendly to game devs.
- also its spring!

Yee-haw! :regret:

Side note: for commercial-like support, please donate: https://springrts.com/wiki/Donations :wink:
7 x

User avatar
PepeAmpere
Posts: 586
Joined: 03 Jun 2010, 01:28

Re: [misc] spring >= 104.0

Post by PepeAmpere » 31 Mar 2019, 18:12

Hi

In two days there is starting another round of the university AI course for 30-40 students which relies on lobbyserver accepting 103.0 as a hosting engine version. I spent last weeks and months by preparation of the course materials focusing on educational part. Once I noticed the enforcement announcement yesterday there is no real chance to manage the upgrade of all technical stuff of the students package. I do not want to focus now on how (again) the change was poorly communicated in advance. So lets just talk about the practical part of the problem:

Students will be able to develop the AI but not able to play easily against each other. This change may ruin the promotional part of the course (= hey, here you made the AI and now you can try it in multiplayer against real people or try other Spring games) which is loose not just for me but it is also lost potential for Spring.

In general I'm supportive to the enforcement of the new versions of the engine on the shared infrastructure. I just ask you if its possible to postpone the enforcement at the end of the courses (end of June 2019) at least for Spring 103.0. I can understand that some other projects (and Spring itself) may have the opposite motivation so I'm open to discuss the options - for this specific well-defined delay.
0 x

User avatar
Silentwings
Moderator
Posts: 3597
Joined: 25 Oct 2008, 00:23

Re: [misc] spring >= 104.0

Post by Silentwings » 31 Mar 2019, 18:19

It was announced months ago that all affected and wishing to use the server should update and/or be ready too, and Spring 104 is already years old (edit: 15 months) as the current major version.

Is there a reason why you would use botflagged battles for your project?
0 x

User avatar
PepeAmpere
Posts: 586
Joined: 03 Jun 2010, 01:28

Re: [misc] spring >= 104.0

Post by PepeAmpere » 31 Mar 2019, 19:26

Silentwings wrote:
31 Mar 2019, 18:19
It was announced months ago that all affected should update and/or be ready too.
Maybe we do not share the definition of "announced".
Silentwings wrote:
31 Mar 2019, 18:19
Spring 104 is already years old.
True. But new stable versions were not released for a long time which can be sign of bad quality of 104.0 or inability to build on top of that. If it is myth, maybe it should be communicated as well. I observe spring forum topics from time to time but it is very hard to track project roadmap while it is scattered just in some forum threads.
Silentwings wrote:
31 Mar 2019, 18:19
Is there a reason why you would use botflagged battles for your project?
Is the restriction only for battles of bots or do you mean by this term autohosts in general? My interest is generally in SPADS hosts hosting 103.0 engine games. If the restriction is not affecting the autohost hosting 103.0 driven games so players can still see them and join them, there is no problem then.
0 x

User avatar
Silentwings
Moderator
Posts: 3597
Joined: 25 Oct 2008, 00:23

Re: [misc] spring >= 104.0

Post by Silentwings » 31 Mar 2019, 19:35

You should read https://springrts.com/wiki/Botflags#Bat ... bby_server to discover what a botflag is. It is a property of the host, not of the players. After that, read the OP again - and I suspect that nothing here actually affects your student project.
stable versions were not released for a long time which can be sign of bad quality of 104.0 or inability to build on top of that. If it is myth, maybe it should be communicated as well.
Dispelling myths that afaict no one knew existed is not going to be possible. Spring 104 is fully fit for use, and anyone who actually asked / investigated about engine version in the past year is directed to it and its latest maintainence builds.
the definition of "announced".
The definition is a forum thread, in the revelant development forum, which is marked as an "announcement" (in this case, for >1 month, & linked on homepage).
0 x

User avatar
PepeAmpere
Posts: 586
Joined: 03 Jun 2010, 01:28

Re: [misc] spring >= 104.0

Post by PepeAmpere » 31 Mar 2019, 20:01

Silentwings wrote:
31 Mar 2019, 19:35
You should read https://springrts.com/wiki/Botflags#Bat ... bby_server to discover what a botflag is. It is a property of the host, not of the players.
Ok, this confirms my previous assumptions:

Next hosts:

notAspace001 ... notAspace050
s44notAhost001 ... s44notAhost020

are affected by the restriction, because they host 103.0 now.

If I understand right hosting without flag is possible with user accounts up to 8 players even with older version - but if I remember right it cannot be SPADS.
0 x

User avatar
Silentwings
Moderator
Posts: 3597
Joined: 25 Oct 2008, 00:23

Re: [misc] spring >= 104.0

Post by Silentwings » 31 Mar 2019, 20:10

If I understand right hosting without flag is possible with user accounts up to 8 players even with older version
That's correct.
- but if I remember right it cannot be SPADS.
That's not correct, the server doesn't care (or know) what client software is being used, and SPADS itself can work without a botflag - see its docs. You will need to set a battle size of <=8.
0 x

abma
Spring Developer
Posts: 3560
Joined: 01 Jun 2009, 00:08

Re: [misc] spring >= 104.0

Post by abma » 01 Apr 2019, 11:03

PepeAmpere wrote:
31 Mar 2019, 18:12
Hi

In two days there is starting another round of the university AI course for 30-40 students which relies on lobbyserver accepting 103.0 as a hosting engine version. I spent last weeks and months by preparation of the course materials focusing on educational part. Once I noticed the enforcement announcement yesterday there is no real chance to manage the upgrade of all technical stuff of the students package. I do not want to focus now on how (again) the change was poorly communicated in advance. So lets just talk about the practical part of the problem:

Students will be able to develop the AI but not able to play easily against each other. This change may ruin the promotional part of the course (= hey, here you made the AI and now you can try it in multiplayer against real people or try other Spring games) which is loose not just for me but it is also lost potential for Spring.

In general I'm supportive to the enforcement of the new versions of the engine on the shared infrastructure. I just ask you if its possible to postpone the enforcement at the end of the courses (end of June 2019) at least for Spring 103.0. I can understand that some other projects (and Spring itself) may have the opposite motivation so I'm open to discuss the options - for this specific well-defined delay.
is it still an issue with the additional information?
easiest "workarround" would be to remove the botflag and host with a battle size of <= 8 to host spring 103.0.
1 x

User avatar
PepeAmpere
Posts: 586
Joined: 03 Jun 2010, 01:28

Re: [misc] spring >= 104.0

Post by PepeAmpere » 01 Apr 2019, 22:53

abma wrote:
01 Apr 2019, 11:03
is it still an issue with the additional information?
easiest "workarround" would be to remove the botflag and host with a battle size of <= 8 to host spring 103.0.
I think it is not problem then.

I will register few temp accounts to host <=8 sized rooms before the other hosts are upgraded.

Thanks for coop.
1 x

abma
Spring Developer
Posts: 3560
Joined: 01 Jun 2009, 00:08

Re: [misc] spring >= 104.0

Post by abma » 08 Apr 2019, 01:08

spring 104.0 is set as minimum version for hosts with botflag.
2 x

User avatar
FabriceFABS
Posts: 345
Joined: 28 Jul 2010, 16:20

Re: [misc] spring >= 104.0

Post by FabriceFABS » 08 Apr 2019, 11:20

FYI, it seems that's a misconfig somewhere on Spring server.
It's not possible anymore to restart autohosts, on launching :

Code: Select all

NOTICE   - [SPADS] Initializing SPADS 0.12.5
Bizarre copy of UNKNOWN in scalar assignment at ./spads.pl line 13656.

And it's when spads.pl fetches for spring version :

Code: Select all

13656    $isSpringReleaseVersion=PerlUnitSync::IsSpringReleaseVersion();
Maybe UNKNOWN should be set/replaced by the/a previous value...
0 x

User avatar
FabriceFABS
Posts: 345
Joined: 28 Jul 2010, 16:20

Re: [misc] spring >= 104.0

Post by FabriceFABS » 08 Apr 2019, 11:42

<<Ooups it's on my side>>
Plz don't consider previous. You can delete it if you want.
0 x

User avatar
RickHustle
Posts: 44
Joined: 13 Sep 2012, 14:40

Re: [misc] spring >= 104.0

Post by RickHustle » 08 Apr 2019, 23:20

After installation spring 104.0 at spads and BA10.24 i got not working system. Spads is running perfect but when i try to run game i cannot choose place and cannot see other controls. I checked others spads server with 104.0 abd BA10.24 and there are no problem with it. I asked to check other users and they got the same as me. I deleted reinstalled spads from zero - nothing changed.
0 x

User avatar
RickHustle
Posts: 44
Joined: 13 Sep 2012, 14:40

Re: [misc] spring >= 104.0

Post by RickHustle » 08 Apr 2019, 23:22

0 x

User avatar
RickHustle
Posts: 44
Joined: 13 Sep 2012, 14:40

Re: [misc] spring >= 104.0

Post by RickHustle » 09 Apr 2019, 00:13

When i have Spring 103.0 and BA9.46 on it all was ok and good install "from the box".
0 x

MasterBel
Posts: 170
Joined: 18 Mar 2018, 07:48

Re: [misc] spring >= 104.0

Post by MasterBel » 09 Apr 2019, 13:34

RickHustle wrote:
08 Apr 2019, 23:20
I checked others spads server with 104.0 abd BA10.24 and there are no problem with it.
Unfortunately, I'm pretty sure you are mistaken. BA 10.24 requires a version newer than 104.0, any other hosts running that combination won't work. You need a maintenance build. Launching a game of 10.24 in singleplayer should display an error message telling you what the needed version is.
0 x

User avatar
RickHustle
Posts: 44
Joined: 13 Sep 2012, 14:40

Re: [misc] spring >= 104.0

Post by RickHustle » 09 Apr 2019, 13:45

MasterBel wrote:
09 Apr 2019, 13:34
Unfortunately, I'm pretty sure you are mistaken. BA 10.24 requires a version newer than 104.0, any other hosts running that combination won't work. You need a maintenance build. Launching a game of 10.24 in singleplayer should display an error message telling you what the needed version is.
I tried several developers version above 104.0. Nothing changes. What version of Spring i should install exactly for example?
0 x

User avatar
RickHustle
Posts: 44
Joined: 13 Sep 2012, 14:40

Re: [misc] spring >= 104.0

Post by RickHustle » 09 Apr 2019, 14:01

I solve the problem. Thanks for advice. The key of solution was that i should yo use maintenance version of Spring.
1 x

MasterBel
Posts: 170
Joined: 18 Mar 2018, 07:48

Re: [misc] spring >= 104.0

Post by MasterBel » 10 Apr 2019, 12:09

RickHustle wrote:
09 Apr 2019, 14:01
I solve the problem. Thanks for advice. The key of solution was that i should yo use maintenance version of Spring.
Awesome, glad you got it sorted out. :)
0 x

Flash
Posts: 32
Joined: 12 Dec 2010, 18:03

Re: [misc] spring >= 104.0

Post by Flash » 10 Apr 2019, 13:11

What a great idea to ban the most played mod. Now the server is empty and noone is playing anymore. So when will this be reverted or do you want spring to be dead?
2 x

Locked

Return to “Community Blog”

cron