2019-10-14 04:17 CEST

View Issue Details Jump to Notes ] Related Changesets ]
IDProjectCategoryView StatusLast Update
0005395Spring engineGeneralpublic2016-11-18 10:28
ReporterGoogle_Frog 
Assigned Tohokomoko 
PrioritynormalSeverityminorReproducibilityalways
StatusfeedbackResolutionreopened 
Product Version103.0 +git 
Target VersionFixed in Version 
Summary0005395: 103.0-290 Sea-coliding raytraces do not return if there is no land below the cursor.
DescriptionRaytraces which do not ignore water fail to return a position if the same water-ignoring raytrace would not return a position. This can be reproduced on maps with sea on their top edge (such as ScorpioBattleground) and a low camera angle. This bug has probably existed for a long time.

This can be reproduced with Spring.TraceScreenRay as well with attempts to give units orders to the top edge of the map.
TagsNo tags attached.
Checked infolog.txt for lua Errors
Attached Files

-Relationships
+Relationships

-Notes

~0016877

hokomoko (developer)

Fix 6121ea5d2d6a90ddf3db301001fd43a64ef3a569 committed to develop branch: Fix 0005394 0005395, repo: spring changeset id: 7589

~0016878

Google_Frog (reporter)

Structure placement was fixed. I can still see two issues:
 * Spring.TraceScreenRay is not fixed. This can be reproduced in 103-293 by trying to build Windgens on the top of a map. The blueprint is drawn but the grid circle is not.
 * Surface orders besides structure placement is not fixed. Move orders appear to raytrace to the sea floor or the water surface depending on whether the selected units float. Floating units cannot be moved to the top edge of the map at low camera angles.

~0016879

hokomoko (developer)

since changing TraceScreenRay and other orders is risky, I prefer to delay that for now.
+Notes

+Related Changesets

-Issue History
Date Modified Username Field Change
2016-11-17 04:43 Google_Frog New Issue
2016-11-17 22:15 hokomoko Changeset attached => spring develop 6121ea5d
2016-11-17 22:15 hokomoko Note Added: 0016877
2016-11-17 22:15 hokomoko Assigned To => hokomoko
2016-11-17 22:15 hokomoko Status new => resolved
2016-11-17 22:15 hokomoko Resolution open => fixed
2016-11-18 06:12 Google_Frog Status resolved => feedback
2016-11-18 06:12 Google_Frog Resolution fixed => reopened
2016-11-18 06:12 Google_Frog Note Added: 0016878
2016-11-18 10:28 hokomoko Note Added: 0016879
+Issue History