2019-08-24 00:53 CEST

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0005253Spring engineGeneralpublic2017-04-17 00:30
Reportersilentwings 
Assigned ToKloot 
PrioritynormalSeveritymajorReproducibilityalways
StatusresolvedResolutionduplicate 
Product Version101.0+git 
Target VersionFixed in Version103.0 +git 
Summary0005253: labs automatic waypoints can be palced on unreachable terrain
Descriptionlabs automatic waypoints can get placed on unreachable terrain, with the result that a unit might not exit its lab.

Steps To Reproducesee image, which is the result of building two identical units in two identical labs, side by side. two engines automatic waypoints of the two labs are marked with crosses.

the left lab places its waypoint on the top of the metal pillar below it - although there is plenty of space for its unit to exit to lab, it does not (the move order is cancelled as soon as the engine spots that it can't reach its move goal). the right lab has no such problem.
Additional Informationthere is a small amount of randomness when trying to reproduce it, presumably becaus the "can this unit reach its move goal check" is only done periodically.

this issues makes some maps unplayable (the image is of MetalHeck), but the problem can occur on any map with a cliff.
TagsNo tags attached.
Checked infolog.txt for lua Errors
Attached Files

-Relationships
duplicate of 0005252closedhokomoko labs automatic waypoints can be palced on unreachable terrain 
has duplicate 0005188resolved Lab stop producing units : Unit just produced got order on a non-reachable location 
+Relationships

-Notes

~0016977

Kloot (developer)

same story as 0005188
+Notes

-Issue History
Date Modified Username Field Change
2016-05-25 08:59 silentwings New Issue
2016-05-25 08:59 silentwings File Added: screen00833.jpg
2016-05-25 11:00 hokomoko Relationship added duplicate of 0005252
2016-12-17 18:02 Kloot Relationship added has duplicate 0005188
2016-12-17 18:02 Kloot Status new => closed
2016-12-17 18:02 Kloot Resolution open => duplicate
2016-12-17 18:02 Kloot Note Added: 0016977
2017-04-17 00:30 Kloot Assigned To => Kloot
2017-04-17 00:30 Kloot Status closed => resolved
2017-04-17 00:30 Kloot Fixed in Version => 103.0 +git
+Issue History