unable to use libunitsync (104.0)

unable to use libunitsync (104.0)

Discuss your problems with the latest release of the engine here. Problems with games, maps or other utilities belong in their respective forums.

Moderator: Moderators

Post Reply
SirMaverick
Posts: 834
Joined: 19 May 2009, 21:10

unable to use libunitsync (104.0)

Post by SirMaverick » 13 Oct 2017, 20:18

I can join 103.0 games without problems. I use flobby and compiled spring myself under Debian jessie (32 bit).
Running spring 104.0 directly and watching a demo works.
Trying to join a 104.0 game freezes flobby (showing dialog box with no text).

When starting Flobby a dialog box opens saying:
"problem loading unitsync: dlopen failed: <path to libunitsync>"
(this comes from src/model/UnitSync.cpp line 26)

Using springlobby I get a segmentation fault right after start:

Code: Select all

[...]
Program received signal SIGSEGV, Segmentation fault.
GetSpringVersion ()
    at /spring/spring/spring-git/tools/unitsync/unitsync.cpp:299
299     {
(gdb) bt
#0  GetSpringVersion ()
    at /spring/spring/spring-git/tools/unitsync/unitsync.cpp:299
#1  0x0846b4de in LSL::SpringBundle::GetBundleVersion (this=0xbfffef24)
    at /spring/springlobby/springlobby-git/src/downloader/lib/src/lsl/lslunitsync/springbundle.cpp:37
#2  0x0846b677 in LSL::SpringBundle::IsValid (this=0xbfffef24)
    at /spring/springlobby/springlobby-git/src/downloader/lib/src/lsl/lslunitsync/springbundle.cpp:56
#3  0x0846bb76 in LSL::SpringBundle::AutoComplete (this=0xbfffef24, 
    searchpath="")
    at /spring/springlobby/springlobby-git/src/downloader/lib/src/lsl/lslunitsync/springbundle.cpp:113
Python Exception <type 'exceptions.ValueError'> Cannot find type const std::list<LSL::SpringBundle, std::allocator<LSL::SpringBundle> >::_Node: 
#4  0x0846ddae in LSL::SpringBundle::GetSpringVersionList (
    unitsync_paths=std::list)
    at /spring/springlobby/springlobby-git/src/downloader/lib/src/lsl/lslunitsync/springbundle.cpp:188
#5  0x08404dd7 in SlPaths::RefreshSpringVersionList(bool, LSL::SpringBundle const*) ()
#6  0x081cf6b1 in SpringLobbyApp::OnInit() ()
#7  0xb7083c96 in wxEntry(int&, wchar_t**) ()
   from /usr/lib/i386-linux-gnu/libwx_baseu-3.0.so.0
#8  0xb7083d33 in wxEntry(int&, char**) ()
   from /usr/lib/i386-linux-gnu/libwx_baseu-3.0.so.0
---Type <return> to continue, or q <return> to quit---
#9  0x080fb4ef in main ()
Problem looks like the following:
viewtopic.php?f=64&t=28000&start=20#p574915
viewtopic.php?f=12&t=34364&p=575529#p575529
But I don't gcc 5 . I have gcc 4.9.2.

Any ideas?
Last edited by SirMaverick on 14 Oct 2017, 09:01, edited 1 time in total.
0 x

abma
Spring Developer
Posts: 3554
Joined: 01 Jun 2009, 00:08

Re: unable to use libunitsync (104.0)

Post by abma » 14 Oct 2017, 00:55

are you mixing self compiled (103.0) and official builds (104.0)?

which version of unitsync does it try to load when it crashes?

springlobby loads all found unitsync at start.

also its not clear whats in the output of the backtrace. could be a breakpoint, too.
0 x

cleanrock
Former Engine Dev
Posts: 115
Joined: 21 Feb 2009, 07:42

Re: unable to use libunitsync (104.0)

Post by cleanrock » 14 Oct 2017, 05:48

Just curious why you use a self built spring and unitsync ?
Downloaded 104.0 spring and unitsync works good for me in flobby.
As a workaround you can config your 104.0 flobby spring profile to use your spring exe and the downloaded 104.0 unitsync.
0 x

SirMaverick
Posts: 834
Joined: 19 May 2009, 21:10

Re: unable to use libunitsync (104.0)

Post by SirMaverick » 14 Oct 2017, 09:03

abma wrote:are you mixing self compiled (103.0) and official builds (104.0)?
No. I setup a user that had only 104.0 installed.
which version of unitsync does it try to load when it crashes?
104.0
springlobby loads all found unitsync at start.

also its not clear whats in the output of the backtrace. could be a breakpoint, too.
springlobby gets a SIGSEGV. I updated the backtrace.
0 x

SirMaverick
Posts: 834
Joined: 19 May 2009, 21:10

Re: unable to use libunitsync (104.0)

Post by SirMaverick » 14 Oct 2017, 09:15

cleanrock wrote:Just curious why you use a self built spring and unitsync ?
I always did that. I used to debug the engine quite a lot.
Downloaded 104.0 spring and unitsync works good for me in flobby.
As a workaround you can config your 104.0 flobby spring profile to use your spring exe and the downloaded 104.0 unitsync.
Tried the spring 32bit static binaries. Same problem with unitsync.
I cant start spring because a I have newer version of libunwind (8 instead of 7). It's the only library that does not match.
0 x

abma
Spring Developer
Posts: 3554
Joined: 01 Jun 2009, 00:08

Re: unable to use libunitsync (104.0)

Post by abma » 16 Oct 2017, 22:44

thats a really weird error. is springlobby self-compiled? if so, did you upgrade your os? if so, did you try to recompile springlobby?
0 x

SirMaverick
Posts: 834
Joined: 19 May 2009, 21:10

Re: unable to use libunitsync (104.0)

Post by SirMaverick » 23 Oct 2017, 00:01

abma wrote:thats a really weird error. is springlobby self-compiled? if so, did you upgrade your os? if so, did you try to recompile springlobby?
Yes, self-compiled. Recompiled springlobby doesn't change anything.

I tried with a second PC with Debian 9 64 bit installation. No problem there.
0 x

Post Reply

Return to “Help & Bugs”