Boxes do not work, game wont start

Boxes do not work, game wont start

SpringRTS Perl Autohost for Dedicated Server

Moderators: Moderators, Lobby Developers, SPADS AutoHost

Post Reply
Shongjen
Posts: 4
Joined: 29 Sep 2017, 15:01

Boxes do not work, game wont start

Post by Shongjen » 11 Oct 2017, 17:42

Hi Guys,

I did a spads Autohost on a linux rootserver. The bot is working. Just when I want to start a game with boxes they do not work ingame. Its just looks like its not a game with boxes. also there its not possible to press the ready button.

I suppose its about some configuration stuff? I tried to solve the problem with searching a soloution on the spadswiki and in that big page of spads commands. But I didnt find anything working.

May someone can help me with it?

Greetings
Shongjen
0 x

User avatar
Silentwings
Moderator
Posts: 3584
Joined: 25 Oct 2008, 00:23

Re: Boxes do not work, game wont start

Post by Silentwings » 11 Oct 2017, 18:16

Post your infolog? And spads logfiles?
0 x

User avatar
Jools
XTA Developer
Posts: 2804
Joined: 23 Feb 2009, 16:29

Re: Boxes do not work, game wont start

Post by Jools » 12 Oct 2017, 10:30

What game? XTA does have this issue with engine 104, but it works with the other ones.
0 x

User avatar
Jools
XTA Developer
Posts: 2804
Joined: 23 Feb 2009, 16:29

Re: Boxes do not work, game wont start

Post by Jools » 12 Oct 2017, 12:31

Btw, you can start the game with the forcestart command: use !forcestart or !send /forcestart, or alt-f
0 x

Shongjen
Posts: 4
Joined: 29 Sep 2017, 15:01

Re: Boxes do not work, game wont start

Post by Shongjen » 19 Oct 2017, 17:02

you mean the serverlog file?

and its about balanced annihilation. but i did a spads update a few days ago just didnt had time to test it yet. I will write again when i did it
0 x

User avatar
Forboding Angel
Evolution RTS Developer
Posts: 14585
Joined: 17 Nov 2005, 02:43

Re: Boxes do not work, game wont start

Post by Forboding Angel » 20 Oct 2017, 18:26

Ba isn't working well with 104 yet. Try 103.
0 x

User avatar
Jools
XTA Developer
Posts: 2804
Joined: 23 Feb 2009, 16:29

Re: Boxes do not work, game wont start

Post by Jools » 21 Oct 2017, 12:12

It would be nice if a new engine would work well on most games before it is released, and not like it's now that lets release this engine so we get people to properly test it.

Ideally, there should be a engine test group that works close together with the engine developers. Why not try to assemble such a group?
0 x

User avatar
Silentwings
Moderator
Posts: 3584
Joined: 25 Oct 2008, 00:23

Re: Boxes do not work, game wont start

Post by Silentwings » 21 Oct 2017, 12:30

Well organized games already do it - ZK, and to a lesser extent also BA, both conduct large scale tests of new engines & interact with engine devs about them.

(As I understand it, BAs reasons for not currently releasing a new version are not caused by the engine.)
0 x

Kloot
Spring Developer
Posts: 1865
Joined: 08 Oct 2006, 16:58

Re: Boxes do not work, game wont start

Post by Kloot » 21 Oct 2017, 13:29

It would be nice if a new engine would work well on most games before it is released, and not like it's now that lets release this engine so we get people to properly test it.
1) The major games managed to transition smoothly, take some responsibility for your own?
2) It would be even nicer if people like you actually tested the THREE RELEASE CANDIDATES that were made available before 104.0 instead of grossly mischaracterizing our release process, because then both parties could get what they want here.

At some point lack of (sufficient) testing quite reasonably stops being our problem and starts being yours.
3 x

Post Reply

Return to “SPADS AutoHost”