SpringLobby 0.267 released! - Page 7

SpringLobby 0.267 released!

Moderators: Moderators, Lobby Developers

Post Reply
User avatar
albator
Posts: 866
Joined: 14 Jan 2009, 14:20

Re: SpringLobby 0.200 released!

Post by albator » 28 Sep 2014, 22:34

abma wrote:
CMake Error at CMakeLists.txt:3 (INCLUDE):

https://github.com/springlobby/springlo ... sts.txt#L3

uhm... did you edit CMakeLists.txt?
nope

Is not it jsut possible to update the version from the repo ?
0 x

abma
Spring Developer
Posts: 3552
Joined: 01 Jun 2009, 00:08

Re: SpringLobby 0.200 released!

Post by abma » 29 Sep 2014, 00:43

https://github.com/springlobby/springlo ... g_from_Git

for some reason your repo isn't the same as the downloaded tarball, the error message makes no sense. = please delete what you got and start from scratch with the instructions "Building from Git"

(this problem is continued here: http://springrts.com/phpbb/viewtopic.php?f=11&t=32573 )
0 x

dust
Posts: 47
Joined: 17 Feb 2008, 00:50

Re: SpringLobby 0.201 released!

Post by dust » 04 Oct 2014, 20:42

http://www.playdeb.net/app/SpringLobby

in ubuntu repo springlobby is old... please can you update the info where u refer at ubuntu install to the playdeb repo?
0 x

User avatar
albator
Posts: 866
Joined: 14 Jan 2009, 14:20

Re: SpringLobby 0.201 released!

Post by albator » 05 Oct 2014, 17:58

I just notice what I belive is a bug:


When launching the new 0.201 SL, the maps are downloaded here:

Code: Select all

~/.spring/maps/
While, when opening the data dir, it is done here.

Code: Select all

~/.config/spring
and of course there is a map folder as well (from previous spring). The question thus is which dir shoud be the default one, and where to put the config file to avoid the already discuss config problems...
0 x

User avatar
albator
Posts: 866
Joined: 14 Jan 2009, 14:20

Re: SpringLobby 0.201 released!

Post by albator » 05 Oct 2014, 18:02

I noticed SL complains about a missing lib under linux (mint17 x64), evne you can compile and launch it

libdumb.so.1

Installing libdumb1 removed the error message.
0 x

User avatar
albator
Posts: 866
Joined: 14 Jan 2009, 14:20

Re: SpringLobby 0.201 released!

Post by albator » 05 Oct 2014, 18:03

Finnally, some error msg I got, but that does not seems to affact anything:
(springlobby:15003): Gtk-CRITICAL **: IA__gtk_widget_get_direction: assertion 'GTK_IS_WIDGET (widget)' failed
0 x

abma
Spring Developer
Posts: 3552
Joined: 01 Jun 2009, 00:08

Re: SpringLobby 0.201 released!

Post by abma » 05 Oct 2014, 18:27

albator wrote:libdumb.so.1
hu? springlobby doesn't directly use this lib. i guess wxwidgets (or openal or some other direct dependant lib) uses it.

albator wrote:When launching the new 0.201 SL, the maps are downloaded here:

Code:
~/.spring/maps/
this is fine as long as spring 91.0 is used (imo). if you want to change it now, just change the downloaddir setting in ~/.springlobby/springlobby.conf.

about playdeb, atm i prefer the ppa, i'll try to update it, but will take a while as i don't have permissions to do so and never made a .deb.
0 x

MetalSucker
Posts: 98
Joined: 22 Sep 2014, 20:29

Re: SpringLobby 0.201 released!

Post by MetalSucker » 05 Oct 2014, 21:05

@abma, you can use 'checkinstall' for a quick'n'dirty way to do it, I use it to create packages from source code I get from the web since it allows for easy uninstall. It even supports dependencies. It's times like these that Gentoo's way is superior to other package managers...

Here's my .deb, built on 64 bit Ubuntu 14.04.1 LTS, Trusty Tahr, I'm sure it's not perfect - and it might break your system, give you nightmares and all that, I'm not responsible for anyone using it.

springlobby_0.201-1_amd64.deb

dpkg - i springlobby_0.201-1_amd64.deb


Warning: using unsigned binaries from random internet strangers is unwise.
0 x

dust
Posts: 47
Joined: 17 Feb 2008, 00:50

Re: SpringLobby 0.201 released!

Post by dust » 18 Oct 2014, 17:03

please can you add the info for ubuntu users that they need only add the http://www.playdeb.net repo and they get the newest springlobby version.

http://www.playdeb.net/game/SpringLobby

seems a lot of users use the old outdated one from the repo and have problems with that, to download the newer spring engine and mod versions.
0 x

abma
Spring Developer
Posts: 3552
Joined: 01 Jun 2009, 00:08

Re: SpringLobby 0.201 released!

Post by abma » 22 Oct 2014, 01:32

@dust:

can you please update the playdeb package of springlobby so it doesn't depend on spring?

http://springrts.com/phpbb/viewtopic.php?f=20&t=32666
0 x

User avatar
NTG
Posts: 22
Joined: 15 Nov 2008, 12:49

Re: SpringLobby 0.201 released!

Post by NTG » 22 Oct 2014, 23:17

abma wrote:can you please update the playdeb package of springlobby so it doesn't depend on spring?
Such update would be great and solve many issues... and well, SpringLobby doesn't need Spring engine installed in system since it can download proper engine when needed :)

@abma: thanks for posting it - I need to familiarize myself with forums - I haven't visited them for quite a long time :)

[Edit]
About link pointed by abma - basically SL is using /usr/lib/spring/ binaries ignoring ~/.spring/engines/$version/ if both points to the same version of Spring binaries... after updating configuration so it points to local (not system) binaries it works until restart... springlobby.conf points updated directories but SL ignores it. Problem is annoying because binaries for SL (Ubuntu repository, spring:ppa, GetDeb) requires local installation of Spring... and in spring:ppa Spring binaries doesn't sync with SPADS hosts.
More details as abma pointed: http://springrts.com/phpbb/viewtopic.php?f=20&t=32666 .
0 x

abma
Spring Developer
Posts: 3552
Joined: 01 Jun 2009, 00:08

Re: SpringLobby 0.210 released!

Post by abma » 02 Feb 2015, 02:02

released springlobby 0.210! (0.202 - 0.208 was skipped due build-errors.)


ChangeLog
0 x

User avatar
Floris
Balanced Annihilation Developer
Posts: 599
Joined: 04 Jan 2011, 20:00

Re: SpringLobby 0.210 released!

Post by Floris » 02 Feb 2015, 14:02

'Filter' now broke, is just empty when enabled
0 x

abma
Spring Developer
Posts: 3552
Joined: 01 Jun 2009, 00:08

Re: SpringLobby 0.210 released!

Post by abma » 02 Feb 2015, 14:04

very likely filter-config got reset, just uncheck all checkboxes to see games again (and adjust to your needs)
0 x

User avatar
Floris
Balanced Annihilation Developer
Posts: 599
Joined: 04 Jan 2011, 20:00

Re: SpringLobby 0.210 released!

Post by Floris » 02 Feb 2015, 14:09

yes this did work. But now the checkbox mean the inverse of it was before?
before it was inclusive, now its exclusive
0 x

abma
Spring Developer
Posts: 3552
Joined: 01 Jun 2009, 00:08

Re: SpringLobby 0.210 released!

Post by abma » 02 Feb 2015, 14:27

atm checkboxes are mostly mutal exclusive. as i usally don't use the filter:


what do you except / what do you want to filter here? which games do you want to see/at which states?


when looking at this, i.e. filtering for "full" games doesn't make sense, the inverse would make sense (games where space is left to join)
0 x

User avatar
Floris
Balanced Annihilation Developer
Posts: 599
Joined: 04 Jan 2011, 20:00

Re: SpringLobby 0.210 released!

Post by Floris » 02 Feb 2015, 14:50

it works for my purposes, but I thought I just noticed a change. I think...
0 x

User avatar
Usaga
Posts: 24
Joined: 18 Jan 2015, 04:09

Re: SpringLobby 0.210 released!

Post by Usaga » 03 Feb 2015, 09:25

Looks like my changes in filters made it work not the way users expected. Next release fixes this. Sorry guys...
0 x

User avatar
smoth
Posts: 22298
Joined: 13 Jan 2005, 00:46

Re: SpringLobby 0.210 released!

Post by smoth » 03 Feb 2015, 17:47

mistakes happen, fixing them is good, at least you tried!
0 x

abma
Spring Developer
Posts: 3552
Joined: 01 Jun 2009, 00:08

Re: SpringLobby 0.217 released!

Post by abma » 08 Apr 2015, 11:48

releases 0.217 which (hopefully) fixes A LOT of remaining issues. i hope now all new bugs due to the switch to wx 3.0 have been fixed. also the code was heavily cleaned up so its became better maintainable!
0 x

Post Reply

Return to “SpringLobby Client”

cron