Random WIP 2006-2011 - Page 286

Random WIP 2006-2011

Share and discuss visual creations and creation practices like texturing, modelling and musing on the meaning of life.

Moderators: MR.D, Moderators, MR.D, Moderators

MElvinVM
Posts: 114
Joined: 15 May 2010, 11:43

Re: Random WIP

Post by MElvinVM »

Hey guys little problem, my model keeps being black in-game even if Upspring shows the texture right! did I forget something?
0 x

User avatar
Beherith
Moderator
Posts: 4934
Joined: 26 Oct 2007, 16:21

Re: Random WIP

Post by Beherith »

Do you have a texture 1 and 2? Is the texture placed in unittextures right? Do you have the channels set up right for textures?
0 x

MElvinVM
Posts: 114
Joined: 15 May 2010, 11:43

Re: Random WIP

Post by MElvinVM »

the model seems to show up in teamcolors, but I dont really understand yet, what must be done with texture 2??

Also my "texture 1" has no white background, is that a problem?
0 x

User avatar
Wombat
Posts: 3379
Joined: 15 Dec 2008, 15:53

Re: Random WIP

Post by Wombat »

oh gawd melvin, now i know i have to learn texturing
0 x

User avatar
Beherith
Moderator
Posts: 4934
Joined: 26 Oct 2007, 16:21

Re: Random WIP

Post by Beherith »

The alpha channel of texture 2 should be completely white (255)
The alpha channel of texture 1 should be white where you want team color.

The red and green channels of texture 2 control glow and reflectivity.
0 x

MElvinVM
Posts: 114
Joined: 15 May 2010, 11:43

Re: Random WIP

Post by MElvinVM »

it shows ok in Upspring with my new texture 2, I use BA as template for my new mod but I need ot save as .3do, I do that, the buildpic changes and the unit builds but its still black, the missile and FX works well, but the unit is totally black!
0 x

User avatar
Guessmyname
Posts: 3301
Joined: 28 Apr 2005, 21:07

Re: Random WIP

Post by Guessmyname »

Wrong file format. Save it as an .s3o file; the .3do format is the old one used by all the old TA models.
0 x

MElvinVM
Posts: 114
Joined: 15 May 2010, 11:43

Re: Random WIP

Post by MElvinVM »

oh i see, I tried that too but it crashes when I try to build, in what file do I tell the mod to use a 3SO file instead of 3do?
0 x

User avatar
Wombat
Posts: 3379
Joined: 15 Dec 2008, 15:53

Re: Random WIP

Post by Wombat »

for what is this model for ?
0 x

MElvinVM
Posts: 114
Joined: 15 May 2010, 11:43

Re: Random WIP

Post by MElvinVM »

for a test im using it to replace the ARM T1 fighter, the model works and all, only its black!
0 x

j5mello
Posts: 1189
Joined: 26 Aug 2005, 05:40

Re: Random WIP

Post by j5mello »

nice model Mel, reminds me of mix between the old Taiidan and Kushan ships from Homeworld.
0 x

MElvinVM
Posts: 114
Joined: 15 May 2010, 11:43

Re: Random WIP

Post by MElvinVM »

I have even more but I want to know how to let the mod use a 3SO file since 3do is outdated!

Image
0 x

User avatar
Beherith
Moderator
Posts: 4934
Joined: 26 Oct 2007, 16:21

Re: Random WIP

Post by Beherith »

In the armfig.fbi file, add the line:

objectname=melvinsfighter.s3o;

Otherwise spring defaults to identically named .3do file (armfig.3do)
0 x

MElvinVM
Posts: 114
Joined: 15 May 2010, 11:43

Re: Random WIP

Post by MElvinVM »

now the model is invisible instead of black..
0 x

User avatar
bobthedinosaur
Blood & Steel Developer
Posts: 2695
Joined: 25 Aug 2004, 13:31

Re: Random WIP

Post by bobthedinosaur »

you need to make sure you have a hit sphere, if you have none than the LOD will think the unit is infinitely small and it wont render the model. Also check your alpha textures in your tex 2, those act as transparencies

when you add a hit sphere also, add a unit height that should be above the unit, about where you would want to see the health bar floating. And if your unit is seen after this, but is really dark that means you scaled it in upspring and have to fix the normals and import it at that scale ro do a sloppy quick fix and recalculate the normals in upspring.


nice models btw
0 x

User avatar
KaiserJ
Community Representative
Posts: 3113
Joined: 08 Sep 2008, 22:59

Re: Random WIP

Post by KaiserJ »

bob have you ever made a harrier jumpjet?

i really love that plane, i think it would look great in your modelling style; not to mention the VTOL being very suited to spring

just musing about it :mrgreen:
0 x

MElvinVM
Posts: 114
Joined: 15 May 2010, 11:43

Re: Random WIP

Post by MElvinVM »

thank you al!!! 8)
Image

engines still being worked on!
0 x

User avatar
Beherith
Moderator
Posts: 4934
Joined: 26 Oct 2007, 16:21

Re: Random WIP

Post by Beherith »

Very nice stuff melvin! Congrats for getting your stuff in so nicely, and we hope to see more of your great models :)
0 x

User avatar
AF
AI Developer
Posts: 20671
Joined: 14 Sep 2004, 11:32

Re: Random WIP

Post by AF »

I like the design of that unit

+1
0 x

User avatar
Beherith
Moderator
Posts: 4934
Joined: 26 Oct 2007, 16:21

Re: Random WIP

Post by Beherith »

Texturing is slow as hell :(
Image
0 x

Locked

Return to “Art & Modelling”

cron