Spring 95.0 released! - Page 3

Spring 95.0 released!

Discuss Spring news, such as fresh releases and press coverage, here.
User avatar
Licho
Zero-K Developer
Posts: 3803
Joined: 19 May 2006, 19:13

Re: Spring 95.0 released!

Post by Licho » 08 Nov 2013, 19:30

95.0 is always crashing for me on load. Suggest fixes don't work but there is no way to report back.
0 x

xyz
Posts: 152
Joined: 29 Nov 2008, 16:06

Re: Spring 95.0 released!

Post by xyz » 08 Nov 2013, 22:23

abma wrote:
@xyz:

did you try to change water mode? (/water in spring)
Spot on, it is the Dynamic water.
I was spectateing a game on DSD and everything was fine till the first commander exploded and then the corrupted rendering started. Switching to a different type of water fixed the issue.
0 x

floppy1356
Posts: 2
Joined: 08 Nov 2013, 23:00

Re: Spring 95.0 released!

Post by floppy1356 » 08 Nov 2013, 23:17

Besides some random crashes, the maps were completely white when playing. I just wanted to say that a "/advmapshading 0" fixes it for me.
0 x

varikonniemi
Posts: 447
Joined: 03 Jul 2011, 11:54

Re: Spring 95.0 released!

Post by varikonniemi » 09 Nov 2013, 00:33

Here is some weird graphical corruption that has now appeared twice after a comblast (not every time!)

http://imgur.com/tDJsv00
http://imgur.com/6Nornaj

Linux mint15/catalyst.

edit: The game freezed at load screen when using bump mapped water, now i have been using dynamic water. I will try if changing it to normal water helps as per xyz's observation.

edit2: yes, that is a picture of my desktop. I cannot get screen capture to work when using catalyst.
0 x

User avatar
KingRaptor
Zero-K Developer
Posts: 838
Joined: 14 Mar 2007, 03:44

Re: Spring 95.0 released!

Post by KingRaptor » 09 Nov 2013, 06:10

What do AllowDeferredMapRendering and AllowDeferredModelRendering do exactly? Can they be disabled (in configs provided by game dev) as a general rule for compatibility?
0 x

User avatar
AntiAllez
Posts: 105
Joined: 06 Mar 2012, 18:22

Re: Spring 95.0 released!

Post by AntiAllez » 09 Nov 2013, 07:17

sometimes my screen flickers if i select a con and pressing ctrl (mod ba7.84)

on same mod i lost my com on map Speedball after he moved over mapborder and stuck there between ground and space

and i prefer a new keylist/screen especially for german layout- you change much since v91.0 and it gets worse with every version. Cant find much keybindings and not all users spend their time exclusively with spring. No one can remember the keybindings for each game and need to check them time by time.

but hey, thx for all the time you spend on it and all the work you had done! I hope it will one day also concluded an arrangement with zerver.
0 x

User avatar
Silentwings
Moderator
Posts: 3592
Joined: 25 Oct 2008, 00:23

Re: Spring 95.0 released!

Post by Silentwings » 09 Nov 2013, 09:57

@AntiAllez, afaik keybinds should not have changed; check http://springrts.com/phpbb/viewtopic.php?f=11&t=31137.
0 x

User avatar
AntiAllez
Posts: 105
Joined: 06 Mar 2012, 18:22

Re: Spring 95.0 released!

Post by AntiAllez » 09 Nov 2013, 10:31

If keys like f4, shift+escape, [ and ] have no effect for you in Spring 95.0
these keys/combos working. i have the problems for some time, not nly on one os and on portable also. maybe its specially on german layout. furthermore, sometimes i miss the german keyboard assignment ingame and it switch to us. i would be grateful if you could leave me a actually overview about german keybindings.
0 x

User avatar
Silentwings
Moderator
Posts: 3592
Joined: 25 Oct 2008, 00:23

Re: Spring 95.0 released!

Post by Silentwings » 09 Nov 2013, 10:50

I don't know about German keyboards, but
BA keybinds are here http://springrts.com/phpbb/viewtopic.php?f=44&t=30173
Engine default binds are here http://springrts.com/wiki/Keyboard
0 x

User avatar
albator
Posts: 866
Joined: 14 Jan 2009, 14:20

Re: Spring 95.0 released!

Post by albator » 09 Nov 2013, 13:24

abma wrote: also the "default" spring executable has some multithreading.
"spring-multithreaded" binary used to be in the static linux builds (I can only use that, with my stable debian), and it is not anymore. As far as I know I always used that one but now it is not there anymore and you can really see the compete lose of performance after 20 min...

Is there anyway to enable spring-multithreaded by some option since I can only see spring binary in the static builds ?

Tell me if I am wrong: iirc springMT was zerver work, but what about spring-multithreaded ? Since it is not there anymore, I assume it is, right ?

About that:
abma wrote:
What happened to spring-multithreaded.exe though? I didnt come with the installer.
zerver (the only maintainer) refused to fix the problems it had.
He has been banned. How can it fix the problem ? Does that mean the ones who ban him are going to fix the multithread version ?


EDIT:

When looking at the replay on which I just played, I get a different ending. I use larger game speed (and get ~2fps ) while I use to have 25fps with other 94 (spring-multithead). Does that mean I can whatch replay ony with game speed to x1, or is it a know bug ?
I used !joinas command when I played

Replay is here:

http://replays.admin-box.com/replay/bd1 ... 54acf2779/
0 x

User avatar
jK
Spring Developer
Posts: 2299
Joined: 28 Jun 2007, 07:30

Re: Spring 95.0 released!

Post by jK » 09 Nov 2013, 14:10

and html versions of the manpages for users of the static build and/or windows users: http://springrts.com/dl/buildbot/defaul ... /manpages/
0 x

abma
Spring Developer
Posts: 3555
Joined: 01 Jun 2009, 00:08

Re: Spring 95.0 released!

Post by abma » 09 Nov 2013, 15:00

Is there anyway to enable spring-multithreaded by some option since I can only see spring binary in the static builds ?
atm its just disabled, but its also broken, it doesn't compile.
He has been banned. How can it fix the problem ? Does that mean the ones who ban him are going to fix the multithread version ?
send pull requests to springs github repository fixing his code. he violates gpl license for springlobby and spring, thats why he was banned. i don't want to discuss this in this thread, there are many threads about this topic in the forum, see http://springrts.com/phpbb/viewtopic.php?f=22&t=30162 for example.
When looking at the replay on which I just played, I get a different ending. I use larger game speed (and get ~2fps ) while I use to have 25fps with other 94 (spring-multithead). Does that mean I can whatch replay ony with game speed to x1, or is it a know bug ?
you can't run a 95.0 demo with spring 94.0, it will desync, thats why you see different endings.
0 x

abma
Spring Developer
Posts: 3555
Joined: 01 Jun 2009, 00:08

Re: Spring 95.0 released!

Post by abma » 09 Nov 2013, 15:03

Licho wrote:95.0 is always crashing for me on load. Suggest fixes don't work but there is no way to report back.
please report to mantis?!
0 x

User avatar
The Yak
Posts: 344
Joined: 20 May 2012, 05:36

Re: Spring 95.0 released!

Post by The Yak » 09 Nov 2013, 15:59

For all the people saying Spring 95 has no multithreading:

http://i.imgur.com/SxNJaAZ.jpg
0 x

Google_Frog
Moderator
Posts: 2440
Joined: 12 Oct 2007, 09:24

Re: Spring 95.0 released!

Post by Google_Frog » 09 Nov 2013, 16:26

Visually noticeable jitters occur frequently for many people, myself included. This engine looks unusable. The assert triggers frequently under reasonable load. Example:

Code: Select all

[f=0025275] Error: assert(CTO <= 1.0f) failed (SF=25275 : DF=2967 : CTO=1.324138 : WSF=0.031527 : DT=42.000000ms : NP=0)
[f=0025275] Error: assert(CTO <= 1.0f) failed (SF=25275 : DF=2968 : CTO=2.017734 : WSF=0.031527 : DT=64.000000ms : NP=0)
[f=0025275] Error: assert(CTO <= 1.0f) failed (SF=25275 : DF=2969 : CTO=2.837438 : WSF=0.031527 : DT=90.000000ms : NP=0)
[f=0025275] Error: assert(CTO <= 1.0f) failed (SF=25275 : DF=2970 : CTO=3.877832 : WSF=0.031527 : DT=123.000000ms : NP=0)
[f=0025275] Error: assert(CTO <= 1.0f) failed (SF=25275 : DF=2971 : CTO=4.729064 : WSF=0.031527 : DT=150.000000ms : NP=0)
[f=0025275] Error: assert(CTO <= 1.0f) failed (SF=25275 : DF=2972 : CTO=5.769458 : WSF=0.031527 : DT=183.000000ms : NP=0)
[f=0025275] Error: assert(CTO <= 1.0f) failed (SF=25275 : DF=2973 : CTO=6.620689 : WSF=0.031527 : DT=210.000000ms : NP=0)
[f=0025275] Error: assert(CTO <= 1.0f) failed (SF=25275 : DF=2974 : CTO=7.661083 : WSF=0.031527 : DT=243.000000ms : NP=0)
[f=0025275] Error: assert(CTO <= 1.0f) failed (SF=25275 : DF=2975 : CTO=8.512315 : WSF=0.031527 : DT=270.000000ms : NP=0)
[f=0025275] Error: assert(CTO <= 1.0f) failed (SF=25275 : DF=2976 : CTO=9.552709 : WSF=0.031527 : DT=303.000000ms : NP=0)
[f=0025275] Error: assert(CTO <= 1.0f) failed (SF=25275 : DF=2977 : CTO=10.403940 : WSF=0.031527 : DT=330.000000ms : NP=0)
[f=0025275] Error: assert(CTO <= 1.0f) failed (SF=25275 : DF=2978 : CTO=11.412807 : WSF=0.031527 : DT=362.000000ms : NP=0)
[f=0025275] Error: assert(CTO <= 1.0f) failed (SF=25275 : DF=2979 : CTO=12.295566 : WSF=0.031527 : DT=390.000000ms : NP=0)
[f=0025275] Error: assert(CTO <= 1.0f) failed (SF=25275 : DF=2980 : CTO=13.304432 : WSF=0.031527 : DT=422.000000ms : NP=0)
[f=0025275] Error: assert(CTO <= 1.0f) failed (SF=25275 : DF=2981 : CTO=14.155663 : WSF=0.031527 : DT=449.000000ms : NP=0)
[f=0025275] Error: assert(CTO <= 1.0f) failed (SF=25275 : DF=2982 : CTO=15.196057 : WSF=0.031527 : DT=482.000000ms : NP=0)
[f=0025275] Error: assert(CTO >= LTO) failed (SF=25275 : DF=2983 : CTO=0.000000 : LTO=15.196057 : WSF=0.031527 : DT=0.000000ms)
[f=0025352] Error: assert(CTO <= 1.0f) failed (SF=25352 : DF=3051 : CTO=1.472815 : WSF=0.035922 : DT=41.000000ms : NP=0)
[f=0025352] Error: assert(CTO <= 1.0f) failed (SF=25352 : DF=3052 : CTO=2.119417 : WSF=0.035922 : DT=59.000000ms : NP=0)
[f=0025352] Error: assert(CTO <= 1.0f) failed (SF=25352 : DF=3053 : CTO=3.268932 : WSF=0.035922 : DT=91.000000ms : NP=0)
[f=0025352] Error: assert(CTO <= 1.0f) failed (SF=25352 : DF=3054 : CTO=4.310679 : WSF=0.035922 : DT=120.000000ms : NP=0)
[f=0025352] Error: assert(CTO <= 1.0f) failed (SF=25352 : DF=3055 : CTO=5.496116 : WSF=0.035922 : DT=153.000000ms : NP=0)
What was the timing change actually for?

Also Spring frequently crashes on exit.
0 x


User avatar
jK
Spring Developer
Posts: 2299
Joined: 28 Jun 2007, 07:30

Re: Spring 95.0 released!

Post by jK » 09 Nov 2013, 17:29

Google_Frog wrote:[f=0025275] Error: assert(CTO <= 1.0f) failed (SF=25275 : DF=2967 : CTO=1.324138 : WSF=0.031527 : DT=42.000000ms : NP=0)
....
those have zero to do with timer change: you are running out of netpackets -> your connection has problems.
0 x

abma
Spring Developer
Posts: 3555
Joined: 01 Jun 2009, 00:08

Re: Spring 95.0 released!

Post by abma » 09 Nov 2013, 17:35

@Licho, GoogleFrog:

infolog.txt about the crashes? without a stacktrace it can't be fixed.
0 x

klapmongool
Posts: 843
Joined: 13 Aug 2007, 13:19

Re: Spring 95.0 released!

Post by klapmongool » 09 Nov 2013, 17:43

abma wrote:
What happened to spring-multithreaded.exe though? I didnt come with the installer.
zerver (the only maintainer) refused to fix the problems it had. maybe see http://springrts.com/phpbb/viewtopic.php?f=22&t=30162 and the bugtracker for some of the details. there are much more threads related to it.
also the "default" spring executable has some multithreading.
I don´t care about the bickering between devs. I do care about spring being able to run properly on modern day hardware. It doesn´t do that anymore. Late game has become shit, with practically all settings on lowest.

I hope all Spring devs find a way, together, to improve the situation.
0 x

Google_Frog
Moderator
Posts: 2440
Joined: 12 Oct 2007, 09:24

Re: Spring 95.0 released!

Post by Google_Frog » 09 Nov 2013, 17:56

@Licho, GoogleFrog:

infolog.txt about the crashes? without a stacktrace it can't be fixed.
http://springrts.com/mantis/view.php?id=4053
0 x

Post Reply

Return to “News”