Adding visual studio compiler to buildbot. - Page 2

Adding visual studio compiler to buildbot.

Discuss the source code and development of Spring Engine in general from a technical point of view. Patches go here too.

Moderator: Moderators

abma
Spring Developer
Posts: 3704
Joined: 01 Jun 2009, 00:08

Re: Adding visual studio compiler to buildbot.

Post by abma »

ideally don't touch it atm, else fixing will be difficult for me.
abma
Spring Developer
Posts: 3704
Joined: 01 Jun 2009, 00:08

Re: Adding visual studio compiler to buildbot.

Post by abma »

now i need your help as i can't easily test this:

how do i compile spring from console?

it seems to basicly work, but idk how to compile it on the console:

do i need to use nmake, msbuild, ...?

if so, what parameter is needed for cmake -G ... ?

can ninja be used to compile? if so, how to invoke cmake correctly?

do i have to run vcvars.bat?
Super Mario
Posts: 820
Joined: 21 Oct 2008, 02:54

Re: Adding visual studio compiler to buildbot.

Post by Super Mario »

Try it again. I had restart it with running the vcvarsall.bat file. You should have access to nmake and msbuild now.
Try configure cmake for nmake, or type "msbuild (name of solution) " in order for it to run.
Last edited by Super Mario on 14 Sep 2015, 01:47, edited 1 time in total.
abma
Spring Developer
Posts: 3704
Joined: 01 Jun 2009, 00:08

Re: Adding visual studio compiler to buildbot.

Post by abma »

Super Mario wrote:Try it again. I had restart it with running the vcvarsall.bat file. You should have access to nmake and msbuild now.
ok, thanks, that helped. i prefer ninja for compile and it seems to basicly work now.

do you get the same errors when compiling with the gui?

http://buildbot.springrts.com/builders/ ... logs/stdio
Super Mario
Posts: 820
Joined: 21 Oct 2008, 02:54

Re: Adding visual studio compiler to buildbot.

Post by Super Mario »

Check to see if that's a gcc extension.
abma
Spring Developer
Posts: 3704
Joined: 01 Jun 2009, 00:08

Re: Adding visual studio compiler to buildbot.

Post by abma »

Super Mario wrote:Check to see if that's a gcc extension.
that doesn't answer my question. i only want to know if i'm using the correct compiler (leading to the same errors) :)
Super Mario
Posts: 820
Joined: 21 Oct 2008, 02:54

Re: Adding visual studio compiler to buildbot.

Post by Super Mario »

abma wrote:
Super Mario wrote:Check to see if that's a gcc extension.
that doesn't answer my question. i only want to know if i'm using the correct compiler (leading to the same errors) :)
I'm pretty sure that you are. Judging from the cmake cache.
Super Mario
Posts: 820
Joined: 21 Oct 2008, 02:54

Re: Adding visual studio compiler to buildbot.

Post by Super Mario »

Is there any thing else you want me to do? I need to turn off the build slave, before I went to sleep as I'm using my personal computer for this.
abma
Spring Developer
Posts: 3704
Joined: 01 Jun 2009, 00:08

Re: Adding visual studio compiler to buildbot.

Post by abma »

Super Mario wrote:Is there any thing else you want me to do?

basicly no, help fixing errors maybe? :)
Super Mario
Posts: 820
Joined: 21 Oct 2008, 02:54

Re: Adding visual studio compiler to buildbot.

Post by Super Mario »

abma wrote:
Super Mario wrote:Is there any thing else you want me to do?

basicly no, help fixing errors maybe? :)
See pull request.
abma
Spring Developer
Posts: 3704
Joined: 01 Jun 2009, 00:08

Re: Adding visual studio compiler to buildbot.

Post by abma »

hu? now i'm getting "strnlen is missing". an idea whats wrong?
Super Mario
Posts: 820
Joined: 21 Oct 2008, 02:54

Re: Adding visual studio compiler to buildbot.

Post by Super Mario »

I'm going to restart it.
Here a documentation for it on vc just in case.
https://msdn.microsoft.com/en-us/library/z50ty2zh.aspx
abma
Spring Developer
Posts: 3704
Joined: 01 Jun 2009, 00:08

Re: Adding visual studio compiler to buildbot.

Post by abma »

oh, i think i got it. it seems the buildbot wasn't started with vcvars.bat run before its start. can you please restart the buildslave after vcvars.bat was run?

and yes, this is a must. env has always be the same or the build will randomly fail.
Super Mario
Posts: 820
Joined: 21 Oct 2008, 02:54

Re: Adding visual studio compiler to buildbot.

Post by Super Mario »

I'm pretty sure that the env is the same now. Can you regenerate the ninja build with cmake? It not finding it currently, as it isn't there. In the build/default I mean.
abma
Spring Developer
Posts: 3704
Joined: 01 Jun 2009, 00:08

Re: Adding visual studio compiler to buildbot.

Post by abma »

no, env is still different:
http://buildbot.springrts.com/builders/ ... logs/stdio
vs
http://buildbot.springrts.com/builders/ ... logs/stdio

i.e. INCLUDE is missing (which is set by vcvars.bat)

http://stackoverflow.com/questions/8440 ... mmand-line

when its troublesome to start this before buildslave start, i can try to add it to the buildbot master config?
Super Mario
Posts: 820
Joined: 21 Oct 2008, 02:54

Re: Adding visual studio compiler to buildbot.

Post by Super Mario »

I have create a working short cut for the vars. It should work now.
Super Mario
Posts: 820
Joined: 21 Oct 2008, 02:54

Re: Adding visual studio compiler to buildbot.

Post by Super Mario »

Code: Select all

[360/1393] Building C object rts\lib\headlessStubs\CMakeFiles\headlessStubs.dir\glustub.c.obj
FAILED: C:\PROGRA~2\MICROS~3.0\VC\bin\cl.exe   /nologo /DWINDOWS /D_CRT_SECURE_NO_WARNINGS /wd4244 /wd4018 /wd4800 /wd4305 /DWIN32 /D_WINDOWS /W3 /MD /Zi /O2 /Ob1 /D NDEBUG -I..\..\vclibs\include -I..\..\rts -I..\..\vclibs\include\SDL2 /showIncludes -DAVI_CAPTURING -DBOOST_ALL_NO_LIB -DNOMINMAX -DSPRING_DATADIR=\"\" -DSTREFLOP_SSE -DSYNCCHECK -DUSE_LIBSQUISH -D_GLIBCXX_USE_NANOSLEEP -D_RANDOM_TCC -D_SILENCE_STDEXT_HASH_DEPRECATION_WARNINGS -D_WIN32_WINNT=0x502 /Forts\lib\headlessStubs\CMakeFiles\headlessStubs.dir\glustub.c.obj /Fdrts\lib\headlessStubs\CMakeFiles\headlessStubs.dir\ /FS -c ..\..\rts\lib\headlessStubs\glustub.c
C:\Program Files (x86)\Windows Kits\8.1\include\um\GL/gl.h(1157): error C2054: expected '(' to follow 'WINGDIAPI'
C:\Program Files (x86)\Windows Kits\8.1\include\um\GL/gl.h(1157): error C2085: 'APIENTRY': not in formal parameter list
Internal Compiler Error in C:\PROGRA~2\MICROS~3.0\VC\bin\cl.exe.  You will be prompted to send an error report to Microsoft later.
INTERNAL COMPILER ERROR in 'C:\PROGRA~2\MICROS~3.0\VC\bin\cl.exe'
You need to include windows.h file before the gl.h. I have tried doing this on my end before, and I still got a errors even though I have greatly reduce the amount of errors.
https://www.opengl.org/archives/resourc ... tarted.htm
abma
Spring Developer
Posts: 3704
Joined: 01 Jun 2009, 00:08

Re: Adding visual studio compiler to buildbot.

Post by abma »

FYI: with the most recent changes i'm done for a longer time with trying to fix msvc compile as i have several other stuff to do which are imo more important. i hope you or someone else can pick this up and continue fixing msvc compile. idk how far away a working msvc compile is, thats not predictable atm imo. but i think the fixes you and me did are already a big step forward.
Post Reply

Return to “Engine”