2019-12-15 03:22 CET

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0000958Spring engineGeneralpublic2008-06-18 19:49
ReporterPosts 
Assigned ToAuswaschbar 
PrioritynormalSeveritytweakReproducibilityalways
StatusresolvedResolutionfixed 
Product Version0.76b1 
Target VersionFixed in Version 
Summary0000958: setmaxspeed / 0 speed
Descriptionif you use the "setmaxspeed" command with no parameters it will set the max speed to 0(?) and it will set the game speed to 0. i was expecting it to tell me the value or do nothing.

At 0 speed with CA mod, my commander ceases to render. 0 speed is not the same thing as pause.

in single player mode this seemed reversible and ok but in multiplayer...

A host with multiple clients tried the setmaxspeed command with no parameters in the middle of a game, he either crashed or thought he crashed due to unusual nature of 0 speed.
TagsNo tags attached.
Checked infolog.txt for Errors
Attached Files

-Relationships
+Relationships

-Notes

~0002344

Posts (reporter)

small correction: "At 0 speed with CA mod" -> "At 0 speed with any mod"

~0002345

KDR_11k (reporter)

Probably causes a divide by zero error.

~0002348

Auswaschbar (reporter)

Made patch:
setmaxspeed must be higher than 0.2 or it will get ignored.
+Notes

-Issue History
Date Modified Username Field Change
2008-06-18 10:35 Posts New Issue
2008-06-18 11:06 Posts Note Added: 0002344
2008-06-18 11:43 KDR_11k Note Added: 0002345
2008-06-18 19:49 Auswaschbar Status new => resolved
2008-06-18 19:49 Auswaschbar Resolution open => fixed
2008-06-18 19:49 Auswaschbar Assigned To => Auswaschbar
2008-06-18 19:49 Auswaschbar Note Added: 0002348
+Issue History