2020-07-13 13:07 CEST

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0000820AIAIpublic2009-02-21 16:44
Reporterhoijui 
Assigned Totrepan 
PrioritynormalSeverityblockReproducibilityalways
StatusresolvedResolutionfixed 
Summary0000820: [Compile Error] LuaFBOs.cpp does not compile with mingw
Descriptioncompiling on WinXP with mingw, phyton 2.5, i got a compile error in LuaFBOs.cpp.

for the line 346:
glDrawBuffersARB(buffers.size(), buffers.data());
i got an erro stating that buffers has no member data. buffers is declared as follows:
vector<GLenum> buffers;

to let it compile, i changed the aqbove mentioned line to:
glDrawBuffersARB(buffers.size(), (GLenum*) buffers.front());

now it compiles, which is fine for me, though i have no idea if this will work ;-)
so someone pls check this.
thanks
Additional Informationthe patch file just does what i explained in the description
TagsNo tags attached.
Attached Files
  • diff file icon LuaFBOs.cpp.diff (358 bytes) 2008-01-19 20:25 -
    Index: rts/Lua/LuaFBOs.cpp
    ===================================================================
    --- rts/Lua/LuaFBOs.cpp	(revision 5343)
    +++ rts/Lua/LuaFBOs.cpp	(working copy)
    @@ -343,7 +343,7 @@
     		}
     		lua_pop(L, 1);
     
    -		glDrawBuffersARB(buffers.size(), buffers.data());
    +		glDrawBuffersARB(buffers.size(), (GLenum*) buffers.front());
     
     		return true;
     	}
    
    diff file icon LuaFBOs.cpp.diff (358 bytes) 2008-01-19 20:25 +

-Relationships
+Relationships

-Notes

~0001870

trepan (reporter)

mingw32 compiler version?

~0001871

hoijui (reporter)

gcc --version
gcc (GCC) 3.4.2 (mingw-special)

(simply installed the latest Dev-Cpp 5 (Beta), more specific: 4.9.9.2)

~0001873

trepan (reporter)

Looks like vector.data() is an extension.
I'll revert to the previous version that
created a GLenum array (and no, your patch
is not the right way to do it ;-)

~0003308

hoijui (reporter)

a problem wiht mantis?
this still appeared under unassigned issues.
+Notes

-Issue History
Date Modified Username Field Change
2008-01-19 20:25 hoijui New Issue
2008-01-19 20:25 hoijui File Added: LuaFBOs.cpp.diff
2008-01-19 22:21 trepan Note Added: 0001870
2008-01-19 22:22 trepan Status new => feedback
2008-01-20 16:37 hoijui Note Added: 0001871
2008-01-20 17:51 trepan Note Added: 0001873
2008-01-20 17:51 trepan Status feedback => resolved
2008-01-20 17:51 trepan Resolution open => fixed
2009-02-21 16:43 hoijui Assigned To => hoijui
2009-02-21 16:43 hoijui Note Added: 0003308
2009-02-21 16:43 hoijui Status resolved => feedback
2009-02-21 16:43 hoijui Resolution fixed => reopened
2009-02-21 16:43 hoijui Status feedback => assigned
2009-02-21 16:43 hoijui Assigned To hoijui => trepan
2009-02-21 16:44 hoijui Status assigned => resolved
2009-02-21 16:44 hoijui Resolution reopened => fixed
+Issue History