2020-06-03 20:53 CEST

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0000075Spring engineGeneralpublic2008-01-14 21:59
Reportermother 
Assigned Totvo 
PrioritynormalSeveritycrashReproducibilityalways
StatusclosedResolutionunable to reproduce 
Product Version 
Target VersionFixed in Version 
Summary0000075: Changing focus away from Spring is permanent
DescriptionIf you alt-tab away from Spring, you're done with that game.
Additional InformationIn one instance it happened while spring was still in the background, the second time it occured when I attempted to switch back to spring.

Official .70b1 release on XPSp2
TagsNo tags attached.
Checked infolog.txt for Errors
Attached Files

-Relationships
related to 0000084closed Graphics Bug. White boxes 
+Relationships

-Notes

~0000064

mother (reporter)

Last edited: 2006-02-25 06:17

Fullscreen mode FWIW

In testing by hosting a solo game (aka with Game Over dialogue box up) it is hit or miss, and not 100%. It however always crashes when tested while participating/spectating in an actual game and alt-tab.

w2k user reported that they do not have trouble alt-tabbing.

~0000083

tvo (reporter)

seems that the SDL patch included with 0.70b2 already fixed the problem magically

~0000163

tvo (reporter)

reopened, it still occurs

according to NOiZE it only happens on ATI cards.

~0000164

tvo (reporter)

This bug really ought to be fixed before a next beta. Or at least a simple solution based on handling window activation message and disabling the rendering code if the window is not active should be tried. If that doesn't help the bug can be lowered to 'crash' level again.

~0001239

tvo (reporter)

reducing to 'crash' for aforementioned reason

~0001240

tvo (reporter)

Does this actually still happen in Spring 0.75b2 or later?

~0001835

tvo (reporter)

Assuming it's fixed or went away some other way, because I can't reproduce it (never could tho) and I've heard nothing about this bug for quite some time now.
+Notes

-Issue History
Date Modified Username Field Change
2006-02-25 05:13 mother New Issue
2006-02-25 05:48 mother Note Added: 0000064
2006-02-25 06:17 mother Note Edited: 0000064
2006-02-27 12:22 tvo Relationship added related to 0000084
2006-03-01 10:33 tvo Status new => closed
2006-03-01 10:33 tvo Note Added: 0000083
2006-03-01 10:33 tvo Resolution open => won't fix
2006-04-17 20:33 tvo Note Added: 0000163
2006-04-17 20:33 tvo Status closed => new
2006-04-17 20:34 tvo Status new => assigned
2006-04-17 20:34 tvo Assigned To => tvo
2006-04-17 20:37 tvo Note Added: 0000164
2006-04-17 20:37 tvo Severity crash => block
2006-04-17 20:37 tvo Resolution won't fix => reopened
2007-09-11 12:29 tvo Note Added: 0001239
2007-09-11 12:29 tvo Severity block => crash
2007-09-11 12:30 tvo Note Added: 0001240
2007-09-11 12:30 tvo Status assigned => feedback
2008-01-14 21:59 tvo Status feedback => closed
2008-01-14 21:59 tvo Note Added: 0001835
2008-01-14 21:59 tvo Resolution reopened => unable to reproduce
+Issue History