2019-08-23 15:39 CEST

View Issue Details Jump to Notes ] Related Changesets ]
IDProjectCategoryView StatusLast Update
0006012Spring engineGeneralpublic2018-07-16 23:17
ReporterDoo 
Assigned ToKloot 
PrioritynormalSeverityminorReproducibilityhave not tried
StatusresolvedResolutionfixed 
Product Version104.0 +git 
Target VersionFixed in Version 
Summary0006012: Air Transports not unloading properly - taking time to unload
DescriptionIn this game (BA 10.10, spring engine 104.0.1 maintenance 567), you can see a player's air transport attempting to unload a commander.
The first unload worked fine (the commander was unloaded as soon as the transport reached the place), the second unload failed for about half a second, causing the transport to get killed.

This happens "randomly" upon unloading with air transports. Sometimes it will just much more time (up to 10 seconds sometimes) to unload a unit, when the transport is roughly over the unload spot.
It doesn't seem to be linked to the spot being impassable to the loaded unit, as in the end the transport will unload in that spot.
Steps To Reproduce1) Spawn any kind of air transports (in numbers, since it doesn't happen all the time), "/give armatlas" or "armdfly" or "corseah" or "corvalk", and peewees.
2) Load peewees, and queue a line or area unload
3) Watch as *some* of the transports will take much more time to unload then other, while hovering over the designed location.

bis: To reproduce gunship aircrafts failing to land
1) Spawn armdfly/corseah/corcrw or other gunships
2) Make sure they are set to properly land when queue is empty
3) Give them a move command
4) Watch as they will sometime keep moving further than move goal and keep flying/hovering around spot for a long period, keeping the move command (showing in cur Queue) while actually not really performing any real movement towards goal (you can echo GetUnitVelocity(), it usually shows 0,0,0,0 as the unit doesn't really move iirc).
Additional InformationMaybe related, but there is still an issue with hovering aircrafts, i'm guessing this hasn't been fully patched perhaps? They sometime can take very high time to reach their waypoint (and therefor never land) while they already passed over it. Giving the exact same move command ("refreshing" the queue) seems to "fix" it for the current move command.

I'm thinking, maybe the transport never really reaches the unload command move goal and doesn't move on to do the proper unloading until the movegoal is somehow canceled, which can take place several seconds after?
TagsNo tags attached.
Checked infolog.txt for lua Errors
Attached Files

-Relationships
+Relationships

-Notes

~0019230

Kloot (developer)

Last edited: 2018-07-05 19:57

View 2 revisions

[Triton] "lets hope we can have one fucking decent engine version one day"

I no longer want to deal with this kind of disgusting ingrate sentiment, sorry. You can tell Triton he is welcome to submit a patch.

~0019231

tritonspring (reporter)

my bad, let me reword it : I hope we can have one decent STABLE engine version one day, I don't remember we had so much issues with engines in the past.
BA 10.** exists since 6 month and we used 30 differents engine versions, BA players dont wanna be beta testers for life, the way I told my frustration might be harsch, but its NOTHING compared to what players say to us.

I'll try to be more political correct, next time

~0019232

Kloot (developer)

Last edited: 2018-07-05 21:14

View 2 revisions

You want a "stable" version you can use until the end of time? No problem, I'll just quit all engine development so no new bugs can ever bother you again. Report closed, have fun.

~0019234

abma (administrator)

Last edited: 2018-07-06 14:05

View 2 revisions

> You want a "stable" version you can use until the end of time?

i would advice to use 104.0. are we at the point that the "maintenance" branch finally failed?

> No problem, I'll just quit all engine development so no new bugs can ever bother you again.

i hope thats sarcasm, would be boring without the common shitstorm on a new release.



reopened as it looks like a valid bug report.

~0019235

Doo (reporter)

Thank you!

Is there anything that is needed to complete this bugreport? Some infolog or replay or whatever?
Is there also anything that you'd want me to try perhaps?

~0019242

Kloot (developer)

Fix aa20328848c085b4daa43f30d1e8cedb0ca84ca0 committed to develop branch: fix 0006012
adding AllowUnitTransport{Load,Unload} callins officially
makes {un}loading no longer the engine's problem to solve, repo: spring changeset id: 10378

~0019245

Kloot (developer)

Fix b61144a6ab345b8a69c347db260e220b39c6390e committed to maintenance branch: fix 0006012
adding AllowUnitTransport{Load,Unload} callins officially
makes {un}loading no longer the engine's problem to solve, repo: spring changeset id: 10383
+Notes

-Related Changesets
spring: develop aa203288
Timestamp: 2018-07-16 21:16:37
Author: Kloot
Details ] Diff ]
fix 0006012
adding AllowUnitTransport{Load,Unload} callins officially
makes {un}loading no longer the engine's problem to solve
mod - cont/base/springcontent/LuaGadgets/callins.lua Diff ] File ]
mod - cont/base/springcontent/LuaGadgets/gadgets.lua Diff ] File ]
mod - rts/Lua/LuaHandleSynced.cpp Diff ] File ]
mod - rts/Lua/LuaHandleSynced.h Diff ] File ]
mod - rts/Sim/Units/CommandAI/MobileCAI.cpp Diff ] File ]
mod - rts/System/EventClient.h Diff ] File ]
mod - rts/System/EventHandler.cpp Diff ] File ]
mod - rts/System/EventHandler.h Diff ] File ]
mod - rts/System/Events.def Diff ] File ]
spring: maintenance b61144a6
Timestamp: 2018-07-16 21:16:37
Author: Kloot
Details ] Diff ]
fix 0006012
adding AllowUnitTransport{Load,Unload} callins officially
makes {un}loading no longer the engine's problem to solve
mod - cont/base/springcontent/LuaGadgets/callins.lua Diff ] File ]
mod - cont/base/springcontent/LuaGadgets/gadgets.lua Diff ] File ]
mod - rts/Lua/LuaHandleSynced.cpp Diff ] File ]
mod - rts/Lua/LuaHandleSynced.h Diff ] File ]
mod - rts/Sim/Units/CommandAI/MobileCAI.cpp Diff ] File ]
mod - rts/System/EventClient.h Diff ] File ]
mod - rts/System/EventHandler.cpp Diff ] File ]
mod - rts/System/EventHandler.h Diff ] File ]
mod - rts/System/Events.def Diff ] File ]

+Related Changesets

-Issue History
Date Modified Username Field Change
2018-07-05 19:14 Doo New Issue
2018-07-05 19:14 Doo File Added: 20180705_185405_DeltaSiegeDry v8_104.0.1-567-gc484c10 maintenance.sdfz
2018-07-05 19:57 Kloot Note Added: 0019230
2018-07-05 19:57 Kloot Note Edited: 0019230 View Revisions
2018-07-05 20:58 tritonspring Note Added: 0019231
2018-07-05 21:14 Kloot Status new => closed
2018-07-05 21:14 Kloot Resolution open => won't fix
2018-07-05 21:14 Kloot Note Added: 0019232
2018-07-05 21:14 Kloot Note Edited: 0019232 View Revisions
2018-07-06 13:56 abma Status closed => new
2018-07-06 13:56 abma Resolution won't fix => reopened
2018-07-06 13:56 abma Note Added: 0019234
2018-07-06 14:05 abma Note Edited: 0019234 View Revisions
2018-07-06 14:05 abma Priority high => normal
2018-07-06 14:05 abma Severity major => minor
2018-07-08 13:48 Doo Note Added: 0019235
2018-07-16 23:08 Kloot Changeset attached => spring develop aa203288
2018-07-16 23:08 Kloot Note Added: 0019242
2018-07-16 23:08 Kloot Assigned To => Kloot
2018-07-16 23:08 Kloot Status new => resolved
2018-07-16 23:08 Kloot Resolution reopened => fixed
2018-07-16 23:17 Kloot Changeset attached => spring maintenance b61144a6
2018-07-16 23:17 Kloot Note Added: 0019245
+Issue History