2018-12-12 06:58 CET

View Issue Details Jump to Notes ] Related Changesets ]
IDProjectCategoryView StatusLast Update
0005999Spring engineGeneralpublic2018-11-25 22:53
Reportertulipe 
Assigned ToKloot 
PrioritynormalSeverityfeatureReproducibilityalways
StatusresolvedResolutionfixed 
Product Version104.0 
Target VersionFixed in Version104.0 +git 
Summary0005999: spring.exe --help return nothing on a console with WINDOWS 10
Descriptionspring.exe --help return nothing with, at least, WINDOWS 10 .
Steps To ReproduceWith WINDOWS, with cmd or powershell, try "spring.exe --help".
TagsNo tags attached.
Attached Files

-Relationships
+Relationships

-Notes

~0019175

Kloot (developer)

Last edited: 2018-06-06 01:58

View 2 revisions

Windows uses /param syntax for CL arguments, not --param

edit: this may actually be subverted by gflags, can't test

~0019176

hokomoko (developer)

Last edited: 2018-06-06 05:39

View 2 revisions

spring -help cannot return anything on the command line since spring is not a console application.
Try
spring -help > out.txt

~0019177

tulipe (reporter)

Less than an hour ago, I tried ""C:\Program Files (x86)\Spring\spring.exe /help"" and ""C:\Program Files (x86)\Spring\spring.exe" -help > out.txt" and it returned nothing in POWERSHELL console.

~0019178

hokomoko (developer)

Of course, because it puts the content in the file out.txt

~0019179

tulipe (reporter)

And where is this out.txt file? I didn't find it with a search from C:\.

"& '.\Program Files (x86)\Spring\spring.exe' /help" instead ""C:\Program Files (x86)\Spring\spring.exe /help"" with a POWERSHELL console.
and & '.\Program Files (x86)\Spring\spring.exe' -help > out.txt instead ""C:\Program Files (x86)\Spring\spring.exe" -help > out.txt".

~0019180

hokomoko (developer)

Last edited: 2018-06-06 09:39

View 2 revisions

in the folder you ran from, if you have permissions in this folder, that is.
If you want the file to appear in a specific location, put the entire path
C:\Program Files (x86)\Spring\spring.exe -help > C:\path\to\file.txt

~0019181

tulipe (reporter)

I tried "& '.\Program Files (x86)\Spring\spring.exe' -help > C:\out.txt" and I find "out.txt" in "C:\", but no text in out.txt.

~0019182

hokomoko (developer)

for some reason that doesn't work in powershell.
use cmd

~0019183

tulipe (reporter)

I tried too from cmd.exe. File "out.txt" was created but still empty.

~0019184

hokomoko (developer)

I'm outta ideas

~0019185

tulipe (reporter)

I remenber with at least one previous version of spring, it worked, some years ago.
Maybe with 0.80.5.2 but I don't find 0.80 version on https://springrts.com/dl/buildbot/default/maintenance/
One subject on springrts forum about commandline options : https://springrts.com/phpbb/viewtopic.php?p=586104#p586104.

~0019186

silentwings (reporter)

Fyi in my post there I used the Ubuntu app (-> linux subsystem) on Windows 10. I didn't try powershell or cmd, and I wonder if it's important to use --help instead of -help.

~0019187

tulipe (reporter)

In the "out.txt.." screenshots pictures I posted this subject 0005999, I didn't saw I captured my taskbar too. Could you delete theses "ou.txt..." pictures please? Sorry that 2 "out.txt" pictures were posted too, but I thinked none was sended cause I had a mantis message : you reached max number of messages, or a message like this, and I thinked pictures were not sended.
I didn't find an option to delete theses pictures from my account settings.
I tried send a message to no-reply@springrts.com but I had a message that my message was not send to no-reply@springrts.com.

~0019188

tulipe (reporter)

("I remenber with at least one previous version of spring, it worked, some years ago." This should have worked with LINUX and not with WINDOWS (and not spring.exe but executable for linux))

~0019189

FLOZi (reporter)

I updated the wiki page for 104.0 so it worked for me; https://springrts.com/wiki/Help:CommandLineArgs

~0019190

FLOZi (reporter)

Can't edit notes; I'm on Windows but still Win 7, not 10

~0019192

Kloot (developer)

Fix f89dac48dfda20e005f13a660be4ca1dd405488f committed to develop branch: maybe fix 0005999, repo: spring changeset id: 10340

~0019193

Kloot (developer)

Fix 1c78b4088dd7c295ed97f54bfe0afa416fa3db43 committed to maintenance branch: maybe fix 0005999, repo: spring changeset id: 10343

~0019194

Kloot (developer)

@tulipe please test https://springrts.com/dl/buildbot/default/maintenance/104.0.1-552-g1c78b40/win32/spring_{maintenance}104.0.1-552-g1c78b40_win32.exe

~0019195

tulipe (reporter)

I tested less than 2 hours ago "spring.exe -h > out.txt" with https://springrts.com/dl/buildbot/default/maintenance/104.0.1-552-g1c78b40/win32/spring_%7bmaintenance%7d104.0.1-552-g1c78b40_win32_portable.7z, and https://springrts.com/dl/buildbot/default/maintenance/104.0.1-552-g1c78b40/win32/spring_%7bmaintenance%7d104.0.1-552-g1c78b40_win32.exe.
out.txt was created but no text was readable in out.txt.

Less than a few days ago I tested with spring 103 and it worked. (text was readable in the txt file).

Since my declaration of 6 june 2018 "Maybe with 0.80.5.2 but I don't find 0.80 version on https://springrts.com/dl/buildbot/default/maintenance/" I found at least one older version of spring than those visible on page https://springrts.com/dl/buildbot/default/maintenance/. (I found on github and a SPRINGRTS forum page).

~0019579

Kloot (developer)

Last edited: 2018-11-25 22:53

View 2 revisions

^ will probably work again in 908-g5845552 (reopen if not)

+Notes

+Related Changesets

-Issue History
Date Modified Username Field Change
2018-06-06 01:05 tulipe New Issue
2018-06-06 01:05 tulipe File Added: spring --help with windows cmd.exe.png
2018-06-06 01:51 Kloot Note Added: 0019175
2018-06-06 01:58 Kloot Note Edited: 0019175 View Revisions
2018-06-06 05:39 hokomoko Note Added: 0019176
2018-06-06 05:39 hokomoko Assigned To => hokomoko
2018-06-06 05:39 hokomoko Status new => closed
2018-06-06 05:39 hokomoko Resolution open => no change required
2018-06-06 05:39 hokomoko Note Edited: 0019176 View Revisions
2018-06-06 09:07 tulipe Status closed => feedback
2018-06-06 09:07 tulipe Resolution no change required => reopened
2018-06-06 09:07 tulipe Note Added: 0019177
2018-06-06 09:13 hokomoko Note Added: 0019178
2018-06-06 09:13 hokomoko Status feedback => closed
2018-06-06 09:36 tulipe Status closed => feedback
2018-06-06 09:36 tulipe Note Added: 0019179
2018-06-06 09:38 hokomoko Note Added: 0019180
2018-06-06 09:39 hokomoko Note Edited: 0019180 View Revisions
2018-06-06 09:43 tulipe File Added: Spring help from POWERSHELL console returned nothing 06-06 2018 3.png
2018-06-06 09:43 tulipe Note Added: 0019181
2018-06-06 09:43 tulipe Status feedback => assigned
2018-06-06 09:46 hokomoko Note Added: 0019182
2018-06-06 09:53 tulipe File Added: Spring help from CMD console returned nothing 06-06-2018 2.png
2018-06-06 09:53 tulipe Note Added: 0019183
2018-06-06 09:55 hokomoko Note Added: 0019184
2018-06-06 10:12 tulipe Note Added: 0019185
2018-06-06 10:15 tulipe File Added: out.txt with ''''spring.exe'' -help'' from cmd.exe 06-06 2018.png
2018-06-06 10:17 tulipe File Added: out.txt with ''''spring.exe'' -help'' from cmd.exe 06-06-2018.png
2018-06-06 10:27 silentwings Note Added: 0019186
2018-06-06 10:44 tulipe Note Added: 0019187
2018-06-06 10:46 hokomoko File Deleted: out.txt with ''''spring.exe'' -help'' from cmd.exe 06-06-2018.png
2018-06-06 10:46 hokomoko File Deleted: out.txt with ''''spring.exe'' -help'' from cmd.exe 06-06 2018.png
2018-06-06 14:53 tulipe Note Added: 0019188
2018-06-06 20:17 FLOZi Note Added: 0019189
2018-06-06 20:22 FLOZi Note Added: 0019190
2018-06-06 21:22 Kloot Changeset attached => spring develop f89dac48
2018-06-06 21:22 Kloot Note Added: 0019192
2018-06-06 21:22 Kloot Assigned To hokomoko => Kloot
2018-06-06 21:22 Kloot Status assigned => resolved
2018-06-06 21:22 Kloot Resolution reopened => fixed
2018-06-06 21:25 Kloot Changeset attached => spring maintenance 1c78b408
2018-06-06 21:25 Kloot Note Added: 0019193
2018-06-07 15:33 Kloot Note Added: 0019194
2018-06-07 16:14 tulipe Status resolved => feedback
2018-06-07 16:14 tulipe Resolution fixed => reopened
2018-06-07 16:14 tulipe Note Added: 0019195
2018-11-25 22:52 Kloot Status feedback => resolved
2018-11-25 22:52 Kloot Resolution reopened => fixed
2018-11-25 22:52 Kloot Fixed in Version => 104.0 +git
2018-11-25 22:52 Kloot Note Added: 0019579
2018-11-25 22:53 Kloot Note Edited: 0019579 View Revisions
+Issue History