2020-08-09 18:40 CEST

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0005642Spring engineGeneralpublic2017-08-07 22:57
ReporterGoogle_Frog 
Assigned ToKloot 
PrioritynormalSeveritycrashReproducibilityhave not tried
StatusresolvedResolutionfixed 
Product Version103.0 +git 
Target VersionFixed in Version 
Summary0005642: 103.0.1-1169 Access violation
Descriptionhttps://github.com/ZeroK-RTS/CrashReports/issues/1491
TagsNo tags attached.
Checked infolog.txt for Errors
Attached Files

-Relationships
duplicate of 0005660resolvedKloot 103.0.1-1199 Access violation 
+Relationships

-Notes

~0018016

Kloot (developer)

Last edited: 2017-07-13 10:02

View 2 revisions

rts/Map/SMF/ROAM/Patch.cpp:286
rts/Map/SMF/ROAM/Patch.cpp:243
rts/Map/SMF/ROAM/Patch.cpp:243
rts/Map/SMF/ROAM/Patch.cpp:243
rts/Map/SMF/ROAM/Patch.cpp:243
rts/Map/SMF/ROAM/Patch.cpp:243
rts/Map/SMF/ROAM/Patch.cpp:243
rts/Map/SMF/ROAM/Patch.cpp:335
rts/Map/SMF/ROAM/Patch.cpp:340
rts/Map/SMF/ROAM/Patch.cpp:340
rts/Map/SMF/ROAM/Patch.cpp:340
rts/Map/SMF/ROAM/Patch.cpp:340
rts/Map/SMF/ROAM/Patch.cpp:340
rts/Map/SMF/ROAM/Patch.cpp:340
rts/Map/SMF/ROAM/Patch.cpp:340
rts/Map/SMF/ROAM/Patch.cpp:340
rts/Map/SMF/ROAM/Patch.cpp:340
rts/Map/SMF/ROAM/Patch.cpp:515
rts/Map/SMF/ROAM/RoamMeshDrawer.cpp:344
/opt/mxe/usr/lib/gcc/i686-w64-mingw32/4.8.1/include/c++/functional:2469
rts/System/Threading/ThreadPool.h:139
/opt/mxe/usr/lib/gcc/i686-w64-mingw32/4.8.1/include/c++/bits/shared_ptr_base.h:552
rts/Map/SMF/ROAM/RoamMeshDrawer.cpp:177
rts/Map/SMF/ROAM/RoamMeshDrawer.cpp:228
rts/Map/SMF/SMFGroundDrawer.cpp:483
rts/Rendering/ShadowHandler.cpp:402
rts/Rendering/ShadowHandler.cpp:614
rts/Game/Game.h:108
rts/Game/Game.cpp:1316
rts/System/SpringApp.cpp:796
rts/System/SpringApp.cpp:826
rts/System/Main.cpp:43
rts/System/Main.cpp:92

seen before as 0005529 and 0005608 / 1347; as yet unknown how to trigger this in debugging.

~0018188

Kloot (developer)

Fix 4005837009de6373bf85459ca0704b9295295646 committed to develop branch: fix 0005660 0005642

culprit was the micro-opt in f7a7e2a7 to avoid multiple GetThreadNum calls, repo: spring changeset id: 8584
+Notes

-Issue History
Date Modified Username Field Change
2017-07-13 01:46 Google_Frog New Issue
2017-07-13 09:56 Kloot Note Added: 0018016
2017-07-13 09:56 Kloot Status new => closed
2017-07-13 09:56 Kloot Resolution open => duplicate
2017-07-13 10:02 Kloot Note Edited: 0018016 View Revisions
2017-07-21 18:05 Kloot Relationship added duplicate of 0005660
2017-08-07 22:57 Kloot Changeset attached => spring develop 40058370
2017-08-07 22:57 Kloot Note Added: 0018188
2017-08-07 22:57 Kloot Assigned To => Kloot
2017-08-07 22:57 Kloot Status closed => resolved
2017-08-07 22:57 Kloot Resolution duplicate => fixed
+Issue History