2019-08-23 15:37 CEST

View Issue Details Jump to Notes ] Related Changesets ]
IDProjectCategoryView StatusLast Update
0005632Spring engineGeneralpublic2017-07-06 17:04
ReporterGoogle_Frog 
Assigned ToKloot 
PrioritynormalSeverityfeatureReproducibilityN/A
StatusresolvedResolutionfixed 
Product Version103.0 +git 
Target VersionFixed in Version103.0 +git 
Summary0005632: Spring should not look frozen while caching
DescriptionSpring will often look frozen, and be detected as frozen by windows, while generating archive cache and occasionally while launching a game. This makes people think Spring is broken. The will happily look at a static screen for a minute on the first launch as long as they think it is doing something useful.

My request is for some sort of reassuring screen to be shown while caching on startup. I would like the screen to display a configurable screenshot. Ideally it should move but this can be as little as the text "Caching..." with a varying number of trailing dots. The window needs to be responsive so the OS doesn't detect it as frozen.
TagsNo tags attached.
Checked infolog.txt for lua Errors
Attached Files

-Relationships
+Relationships

-Notes

~0017927

Kloot (developer)

Fix 7abc22e9b9927bd6f09c769577d32571b7026388 committed to develop branch: fix 0005632, repo: spring changeset id: 8458

~0017941

Google_Frog (reporter)

Thanks for the quick improvement, there are issues remaining but they are less urgent. I think there is still work to be done for this ticket because Spring still registers as unresponsive. In windowed mode it is unable to be dragged and is detected as as "Not Responding". I know that in windows 10 this will eventually cause windows to prompt the user to kill Spring.

~0017942

Kloot (developer)

just handling SDL events would probably satisfy the Windows process manager.

~0017943

Kloot (developer)

done in 24a9e97e.
+Notes

+Related Changesets

-Issue History
Date Modified Username Field Change
2017-07-03 04:40 Google_Frog New Issue
2017-07-03 11:30 Kloot Assigned To => Kloot
2017-07-03 11:30 Kloot Status new => assigned
2017-07-03 17:26 Kloot Changeset attached => spring develop 7abc22e9
2017-07-03 17:26 Kloot Note Added: 0017927
2017-07-03 17:26 Kloot Status assigned => resolved
2017-07-03 17:26 Kloot Resolution open => fixed
2017-07-06 14:17 Google_Frog Status resolved => feedback
2017-07-06 14:17 Google_Frog Resolution fixed => reopened
2017-07-06 14:17 Google_Frog Note Added: 0017941
2017-07-06 14:17 Google_Frog File Added: scanning.jpg
2017-07-06 14:17 Google_Frog File Added: scanning-2.jpg
2017-07-06 14:41 Kloot Note Added: 0017942
2017-07-06 17:04 Kloot Status feedback => resolved
2017-07-06 17:04 Kloot Resolution reopened => fixed
2017-07-06 17:04 Kloot Fixed in Version => 103.0 +git
2017-07-06 17:04 Kloot Note Added: 0017943
+Issue History