2019-12-10 08:53 CET

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0005542Spring engineGeneralpublic2017-05-07 02:07
ReporterDeinFreund 
Assigned ToKloot 
PrioritynormalSeveritycrashReproducibilitysometimes
StatusresolvedResolutionfixed 
Product Version103.0 +git 
Target VersionFixed in Version103.0 +git 
Summary0005542: Spring crashes when launching game via chobby
DescriptionSpring crashes nearly every time I join a Multiplayer match via Chobby. The infologs lack a meaningful stacktrace.
Steps To ReproducePlay a zk game with Chobby (First game works fine). Try to join a second game after the first one is finished -> Crash.
Additional Informationhttps://github.com/ZeroK-RTS/CrashReports/issues/919
https://github.com/ZeroK-RTS/CrashReports/issues/917
https://github.com/ZeroK-RTS/CrashReports/issues/910
TagsNo tags attached.
Checked infolog.txt for Errors
Attached Files

-Relationships
duplicate of 0005528resolvedKloot 103.0.1-764 crash on game launch 
+Relationships

-Notes

~0017557

hokomoko (developer)

Last edited: 2017-05-04 08:35

View 3 revisions

910 has a bunch of S3O errors and the other two don't. something is weird.
Ok, 910 uses zk 1.5.4.20 which was bugged while the other two use 1.5.4.22 which supposedly isn't

~0017558

Kloot (developer)

Last edited: 2017-05-07 02:02

View 2 revisions

only msvcrt, duplicate of 0005528/795 & co.

we *need* valid stacktraces to solve this. if you can consistently reproduce it (preferably in single-player), consider using a debugger with 764's *_dbg.7z symbol archive from https://springrts.com/dl/buildbot/default/develop/103.0.1-764-gae7487f/.

~0017561

Kloot (developer)

re-examining the context in which these crashes occurred, I'm reasonably convinced the sorting code in PlayerRoster was responsible for all of them.

ZK should update its engine ASAP.
+Notes

-Issue History
Date Modified Username Field Change
2017-05-03 13:00 DeinFreund New Issue
2017-05-04 08:33 hokomoko Note Added: 0017557
2017-05-04 08:33 hokomoko Note Edited: 0017557 View Revisions
2017-05-04 08:35 hokomoko Note Edited: 0017557 View Revisions
2017-05-05 12:24 Kloot Assigned To => Kloot
2017-05-05 12:24 Kloot Status new => closed
2017-05-05 12:24 Kloot Resolution open => duplicate
2017-05-05 12:24 Kloot Note Added: 0017558
2017-05-05 12:24 Kloot Relationship added duplicate of 0005528
2017-05-07 02:02 Kloot Note Edited: 0017558 View Revisions
2017-05-07 02:07 Kloot Status closed => resolved
2017-05-07 02:07 Kloot Resolution duplicate => fixed
2017-05-07 02:07 Kloot Fixed in Version => 103.0 +git
2017-05-07 02:07 Kloot Note Added: 0017561
+Issue History