2019-08-21 07:09 CEST

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0005494Spring engineGeneralpublic2017-04-24 17:17
ReporterGoogle_Frog 
Assigned ToKloot 
PrioritynormalSeveritycrashReproducibilityrandom
StatusresolvedResolutionduplicate 
Product Version103.0 +git 
Target VersionFixed in Version103.0 +git 
Summary0005494: 103.0.1-697-g918caba crash
DescriptionHere is a crash at game start. It seems to occur as the luamenu overlay is viewed: https://github.com/ZeroK-RTS/CrashReports/issues/317

Here is another crash with a similar stacktrace: https://github.com/ZeroK-RTS/CrashReports/issues/316
TagsNo tags attached.
Checked infolog.txt for lua Errors
Attached Files

-Relationships
related to 0005522resolvedKloot 103.0.1-747 "Error: VBO/PBO: out of memory" crash 
+Relationships

-Notes

~0017381

abma (administrator)

first stacktrace translated (Luke):

https://github.com/spring/spring/tree/103.0.1-697-g918caba

??:0
[f=-000001] Error: Exception: Access violation (0xc0000005)
[f=-000001] Error: Exception Address: 0x774243df

(mem corruption?, gfx driver crash, too?!) when reproduceable: disabling async opengl should lead to a useable stacktrace.


the second stacktrace (manero):

https://github.com/spring/spring/tree/103.0.1-697-g918caba

??:0
??:0
??:0
??:0
??:0
rts/Rendering/Textures/TextureAtlas.cpp:178
rts/Rendering/Textures/TextureAtlas.cpp:116
rts/Rendering/Env/BumpWater.cpp:813
rts/Rendering/Env/BumpWater.cpp:282
rts/Rendering/Env/IWater.cpp:136
rts/Rendering/WorldDrawer.cpp:131
rts/Game/Game.cpp:414
/opt/mxe/usr/lib/gcc/i686-w64-mingw32/4.8.1/include/c++/functional:2073
rts/System/OffscreenGLContext.cpp:311
/opt/mxe/usr/lib/gcc/i686-w64-mingw32/4.8.1/include/c++/functional:2029
??:0
??:0
??:0
??:0
??:0


[f=-000001] Error: This stack trace indicates a problem with your graphic card driver. Please try upgrading or downgrading it. Specifically recommended is the latest driver, and one that is as old as your graphic card. Make sure to use a driver removal utility, before installing other drivers.

~0017384

Kloot (developer)

Last edited: 2017-03-16 01:35

View 2 revisions

it's just ATI crash-season again, the TextureAtlas trace involves a perfectly innocuous glTexImage2D call and shows up in *many* ZK reports from users with old(er) cards because BumpWater was made the default mode.

~0017385

gajop (developer)

Are you OK with someone adding a System.graphicsDeviceVendor -> "ati"|"nvidia"|"intel"|"other" and other useful System info other engines have? (e.g. https://docs.unity3d.com/ScriptReference/SystemInfo.html)

PS: Maybe it's hidden somewhere but I've searched and couldn't find it.

~0017411

Kloot (developer)

316 belongs with 0005484 as another ATI driver bug.

317 is not a workable trace.
+Notes

-Issue History
Date Modified Username Field Change
2017-03-09 01:19 Google_Frog New Issue
2017-03-11 10:33 abma Note Added: 0017381
2017-03-16 00:58 abma Status new => feedback
2017-03-16 01:32 Kloot Note Added: 0017384
2017-03-16 01:35 Kloot Note Edited: 0017384 View Revisions
2017-03-16 07:34 gajop Note Added: 0017385
2017-04-03 12:54 Kloot Assigned To => Kloot
2017-04-03 12:54 Kloot Status feedback => closed
2017-04-03 12:54 Kloot Resolution open => duplicate
2017-04-03 12:54 Kloot Note Added: 0017411
2017-04-15 14:13 Kloot Relationship added related to 0005522
2017-04-24 17:17 Kloot Status closed => resolved
2017-04-24 17:17 Kloot Fixed in Version => 103.0 +git
+Issue History