2019-10-14 22:41 CEST

View Issue Details Jump to Notes ] Related Changesets ]
IDProjectCategoryView StatusLast Update
0005466Spring engineGeneralpublic2017-02-14 18:20
ReporterGoogle_Frog 
Assigned ToKloot 
PrioritynormalSeveritycrashReproducibilityhave not tried
StatusresolvedResolutionfixed 
Product Version103.0 +git 
Target VersionFixed in Version 
Summary0005466: 103.0.1-588-gab2f239 start of game crash
DescriptionCrash with stacktrace: https://github.com/ZeroK-RTS/CrashReports/issues/56
TagsNo tags attached.
Checked infolog.txt for lua Errors
Attached Files
  • txt file icon guiscript.txt (579 bytes) 2017-02-14 17:30 -
    [game]
    {
    [player0]
    {
    team=0;
    name=hokomoko;
    rank=0;
    isfromdemo=0;
    }
    [allyteam1]
    {
    numallies=0;
    }
    [team0]
    {
    rgbcolor=0.99609375 0.546875 0;
    allyteam=0;
    teamleader=0;
    }
    [modoptions]
    {
    }
    [team1]
    {
    rgbcolor=0.99609375 0.546875 0;
    allyteam=1;
    teamleader=0;
    }
    [allyteam0]
    {
    numallies=0;
    }
    [ai0]
    {
    team=1;
    name=CAI (1);
    host=0;
    isfromdemo=0;
    shortname=CAI;
    }
    myplayername=hokomoko;
    startpostype=2;
    nohelperais=0;
    hostip=127.0.0.1;
    hostport=0;
    mapname=Onyx Cauldron 1.7;
    gametype=Zero-K v1.5.2.20;
    ishost=1;
    numplayers=1;
    numusers=2;
    }
    
    txt file icon guiscript.txt (579 bytes) 2017-02-14 17:30 +

-Relationships
duplicate of 0005473closedabma 103.0.1-588-gab2f239 circuit AI interface crash 
has duplicate 0005474closedKloot 103.0.1-588-gab2f239 luaMenu load crash (with joystick?) 
has duplicate 0005479closedhokomoko 103.0.1-638-g6b1d325 synced vector::_M_range_check crash 
+Relationships

-Notes

~0017253

Kloot (developer)

SDL2.dll 0x000CB4DB ?? 0
SDL2.dll 0x000C00C4 ?? 0
spring.exe 0x0084EECF rts/System/SpringApp.cpp 860
spring.exe 0x008371BF rts/System/Main.cpp 48
spring.exe 0x00E57484 rts/System/Main.cpp 109

SwapBuffers crash, no apparent reason.

~0017254

Kloot (developer)

Last edited: 2017-02-09 13:29

View 2 revisions

driver bug unless I start seeing this from more people with versions other than 376.33

~0017288

Google_Frog (reporter)

Another crash in the same situation: https://github.com/ZeroK-RTS/CrashReports/issues/105

I can't see anything about driver 376.33 in the infolog.

~0017290

Google_Frog (reporter)

Another, slightly truncated stacktrace but perhaps not too truncated: https://github.com/ZeroK-RTS/CrashReports/issues/95

~0017291

Google_Frog (reporter)

For some reason Mantis automatically assigned the ticket after my last comment.

~0017294

Kloot (developer)

Last edited: 2017-02-13 13:20

View 2 revisions

You will need to update ZK test to a newer build because I'm reasonably certain that all of these actually relate to the SwapBuffers changes made for Chobby.

105 seems like an ordinary Intel driver crash and has "FBO-LUAOBJECTDRAWER-GBUFFER: error code 0x505" leading up to it, 95 lacks a trace.

~0017297

Google_Frog (reporter)

Ok, I will update ZK engine version. For completeness here are more logs:
https://github.com/ZeroK-RTS/CrashReports/issues/84
https://github.com/ZeroK-RTS/CrashReports/issues/80
https://github.com/ZeroK-RTS/CrashReports/issues/83
https://github.com/ZeroK-RTS/CrashReports/issues/79
https://github.com/ZeroK-RTS/CrashReports/issues/56

~0017301

Kloot (developer)

Last edited: 2017-02-13 22:34

View 3 revisions

56 is SwapBuffers

80 is an interrupted launch due to "Failed to load armorDefs
[f=-000001] Error: 2, gamedata/defs.lua, [string "gamedata/defs.lua"]:38: [string "gamedata/defs.lua"]:26: error = 2, gamedata/armorDefs.lua, [string "gamedata/armorDefs.lua"]:147: invalid call to Include() after execution", fixed as of e45be67ee3

79, 83, and 84 are all GuiHandler yet again:

rts/Game/UI/GuiHandler.cpp:2978
rts/Game/UI/GuiHandler.cpp:2585
rts/Game/Game.cpp:1310
rts/Game/Game.cpp:1270
rts/System/SpringApp.cpp:857
rts/System/Main.cpp:48
rts/System/Main.cpp:109

~0017330

hokomoko (developer)

I've uploaded a script that I can reproduce this crash with.
Crash happens if you hold "shift" during start countdown (as people would do when placing stuff)
+Notes

+Related Changesets

-Issue History
Date Modified Username Field Change
2017-02-09 01:18 Google_Frog New Issue
2017-02-09 02:09 Kloot Note Added: 0017253
2017-02-09 13:28 Kloot Assigned To => Kloot
2017-02-09 13:28 Kloot Status new => closed
2017-02-09 13:28 Kloot Resolution open => not fixable
2017-02-09 13:28 Kloot Note Added: 0017254
2017-02-09 13:29 Kloot Note Edited: 0017254 View Revisions
2017-02-13 12:49 Google_Frog Status closed => feedback
2017-02-13 12:49 Google_Frog Resolution not fixable => reopened
2017-02-13 12:49 Google_Frog Note Added: 0017288
2017-02-13 13:05 Google_Frog Note Added: 0017290
2017-02-13 13:05 Google_Frog Status feedback => assigned
2017-02-13 13:06 Google_Frog Note Added: 0017291
2017-02-13 13:13 Kloot Note Added: 0017294
2017-02-13 13:20 Kloot Note Edited: 0017294 View Revisions
2017-02-13 13:51 Google_Frog Note Added: 0017297
2017-02-13 14:06 Kloot Note Added: 0017301
2017-02-13 14:06 Kloot Note Edited: 0017301 View Revisions
2017-02-13 22:33 Kloot Relationship added has duplicate 0005474
2017-02-13 22:34 Kloot Note Edited: 0017301 View Revisions
2017-02-13 22:37 Kloot Relationship added duplicate of 0005473
2017-02-14 17:29 hokomoko Relationship added has duplicate 0005479
2017-02-14 17:30 hokomoko File Added: guiscript.txt
2017-02-14 17:31 hokomoko Note Added: 0017330
2017-02-14 17:33 hokomoko Assigned To Kloot => hokomoko
2017-02-14 18:20 hokomoko Assigned To hokomoko => Kloot
2017-02-14 18:20 hokomoko Status assigned => resolved
2017-02-14 18:20 hokomoko Resolution reopened => fixed
2017-02-14 18:20 hokomoko Changeset attached => spring develop 1fe4ebbc
+Issue History