2019-08-24 02:36 CEST

View Issue Details Jump to Notes ] Related Changesets ]
IDProjectCategoryView StatusLast Update
0005463Spring engineGeneralpublic2017-06-11 13:34
ReporterGoogle_Frog 
Assigned ToKloot 
PrioritynormalSeverityfeatureReproducibilityN/A
StatusresolvedResolutionfixed 
Product Version103.0 +git 
Target VersionFixed in Version103.0 +git 
Summary0005463: Failing to connect to battle should send user back to LuaMenu
DescriptionIf the game was started from LuaMenu and the user fails to connect (bad connection, wrong script password etc..) the game should reload back to LuaMenu instead of closing with an error about failing to connect to the game. A parameter could be added to the callin ActivateMenu which tells LuaMenu the circumstances of it's activation in the case of a failure to connect.
TagsNo tags attached.
Checked infolog.txt for lua Errors
Attached Files

-Relationships
+Relationships

-Notes

~0017357

Anonymous (viewer)

Fix b3f2c351d90f10cdded09ea6b1a4744d89d4230a committed to develop branch: fix 0005463, repo: spring changeset id: 7975

~0017358

hokomoko (developer)

Last edited: 2017-02-22 23:09

View 2 revisions

Additional changes are needed in
https://github.com/spring/spring/blob/b3f2c351d90f10cdded09ea6b1a4744d89d4230a/rts/Game/PreGame.cpp#L128
https://github.com/spring/spring/blob/b3f2c351d90f10cdded09ea6b1a4744d89d4230a/rts/Game/PreGame.cpp#L255
and half the places that throw exceptions in that file.
I'll have time to take care of this on Sunday

~0017359

Kloot (developer)

Last edited: 2017-02-23 00:26

View 2 revisions

"are needed", no. "would be nice to have", yes.

except for L255 I consider this FR resolved since all of the pregame exceptions indicate non-user logical errors far less common than rejected connections, but won't mind further polish either.

~0017826

Kloot (developer)

will add some code for the KeyPressed case, otherwise done.
+Notes

+Related Changesets

-Issue History
Date Modified Username Field Change
2017-02-08 08:47 Google_Frog New Issue
2017-02-22 17:50 Changeset attached => spring develop b3f2c351
2017-02-22 17:50 Anonymous Note Added: 0017357
2017-02-22 17:50 Anonymous Status new => resolved
2017-02-22 17:50 Anonymous Resolution open => fixed
2017-02-22 22:51 hokomoko Status resolved => feedback
2017-02-22 22:51 hokomoko Resolution fixed => reopened
2017-02-22 22:51 hokomoko Note Added: 0017358
2017-02-22 22:51 hokomoko Status feedback => new
2017-02-22 23:09 hokomoko Note Edited: 0017358 View Revisions
2017-02-23 00:15 Kloot Note Added: 0017359
2017-02-23 00:26 Kloot Note Edited: 0017359 View Revisions
2017-06-11 13:34 Kloot Assigned To => Kloot
2017-06-11 13:34 Kloot Status new => resolved
2017-06-11 13:34 Kloot Resolution reopened => fixed
2017-06-11 13:34 Kloot Fixed in Version => 103.0 +git
2017-06-11 13:34 Kloot Note Added: 0017826
+Issue History