2019-08-24 00:52 CEST

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0005386Spring engineGeneralpublic2016-11-06 18:18
ReporterGoogle_Frog 
Assigned To 
PrioritynormalSeveritymajorReproducibilityalways
StatusnewResolutionopen 
Product Version103.0 +git 
Target VersionFixed in Version 
Summary0005386: 103-134 Units stuck on structures
DescriptionConstructors occasionally become stuck while constructing buildings. All units could become stuck this way but it is less common. There are two different ways for them to become stuck.

The first method of becoming stuck is to produce a grid of structures with the gaps between buildings thinner than the footprint of the constructor. The constructors eventually back into an impassible area and become stuck in somewhere that they should never have been able to reach. This method is highly reproducible.

The other method of becoming stuck is to produce a grid of structures with gap sufficient to walk through. This can cause constructors to be stuck on the edge of impassible areas and occurs rarely. It is hard to reproduce with construction, however, the same bug can be reproduced reliably with many repeated move orders throughout a preexisting grid of structures. The move orders time out after a short time of being stuck (unlike construction orders) so some attention is required while reproducing.
Additional InformationZero-K v1.4.11.0
TagsNo tags attached.
Checked infolog.txt for lua Errors
Attached Files

-Relationships
+Relationships

-Notes

~0016857

Google_Frog (reporter)

constructionStuck.jpg shows a constructor being stuck in the hard to reproduce configuration. cosntructionApproach.jpg is what the constructor was doing just prior to being stuck. The constructor would sit stuck indefinitely, something moving its legs and sometimes standing still. It was unstuck by giving it a move order.

~0016858

Google_Frog (reporter)

thinStuck.jpg and moveStuck.jpg show the bugs as reproduced in the attached replay.

~0016859

abma (administrator)

just a guess
in /debug output very likely the updatequeue is far away from 0, then such things can happen.

~0016860

Google_Frog (reporter)

I highly doubt it. I have not noticed any sluggishness in pathmap updating since the update speed was last boosted. There is very little going on in both the real game (unfortunately run with a sdd) and the attached replay. This is not a new bug, I just noticed a failure case in a real game recently and took the time to report it.
+Notes

-Issue History
Date Modified Username Field Change
2016-11-06 14:40 Google_Frog New Issue
2016-11-06 14:40 Google_Frog File Added: 20161107_002635_TitanDuel_103.0.1-134-g819e5b4 develop.sdfz
2016-11-06 14:40 Google_Frog File Added: cosntructionApproach.jpg
2016-11-06 14:41 Google_Frog File Added: constructionStuck.jpg
2016-11-06 14:43 Google_Frog Note Added: 0016857
2016-11-06 14:43 Google_Frog File Added: moveStuck.jpg
2016-11-06 14:44 Google_Frog File Added: thinStuck.jpg
2016-11-06 14:45 Google_Frog Note Added: 0016858
2016-11-06 16:01 abma Note Added: 0016859
2016-11-06 18:18 Google_Frog Note Added: 0016860
+Issue History