2019-12-14 22:47 CET

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0005168Spring engineGeneralpublic2016-12-13 13:46
Reporterjamerlan 
Assigned TojK 
PrioritynormalSeveritymajorReproducibilityalways
StatusresolvedResolutionfixed 
Product Version101.0+git 
Target VersionFixed in Version 
Summary0005168: strange water rendering
Descriptionhttps://youtu.be/1ObLRLZM5e0

spring 101.0.1-139-ga146a0c/
Balanced Annihilation test-5206
TagsNo tags attached.
Checked infolog.txt for Errors
Attached Files

-Relationships
related to 0005223resolvedabma global-buffer-overflow in rts/Rendering/Env/IWater.cpp:96 
+Relationships

-Notes

~0016060

Kloot (developer)

no such issue with same build and springsettings copied from infolog in BA 9.35, so game bug.

reopen if this still happens after disabling luaui and luarules.

~0016061

jamerlan (reporter)

works good for spring 100 and spring 101 (release)

but not working for latest builds (I disabled luaui and luarules at the end of the video)

https://youtu.be/f99WuQy4YpE

~0016062

jamerlan (reporter)

this build have no such bug: https://springrts.com/dl/buildbot/default/develop/101.0.1-71-g4bb70d5/

this build have this bug: https://springrts.com/dl/buildbot/default/develop/101.0.1-73-g7f2de8c/linux64/

~0016063

Kloot (developer)

probably 101.0.1-72-gbb4a332 then, but I still can't reproduce it.

~0016064

jamerlan (reporter)

how can I help?

~0016065

Kloot (developer)

Does the glitch go away if you set 3DTrees=0 in springsettings?

~0016066

jamerlan (reporter)

no. I tried to restart spring after this - water is still buggy
https://youtu.be/ktMLG6eNpvU

~0016091

hokomoko (developer)

can't reproduce here either

~0016098

abma (administrator)

try DebugGL = 1 and check infolog.txt for gfx related errors

~0016103

jamerlan (reporter)

fixed in 101.0.1-140-g5f08624

~0016104

jamerlan (reporter)

ah.. not fixed! when I set water = 4 -> bug is still there

~0016105

jamerlan (reporter)

infolog with debug enabled
http://pastebin.com/r95wQqu3

BTW, when you renamed setting - you probably broke springsettings.exe (user friendly tool)

~0016162

jamerlan (reporter)

just tested with: "/home/revenant/Downloads/spring_{develop}101.0.1-231-g4479f7f_minimal-portable-linux64-static/spring"

still not fixed :-)

~0016247

abma (administrator)

multiple persons can't reproduce -> no release blocker

~0016250

jamerlan (reporter)

not a blocker ofc
but still not fixed (101.0.1-318-ge579234)

~0016959

Kloot (developer)

99% chance this was fixed by 76a36192
+Notes

-Issue History
Date Modified Username Field Change
2016-03-14 19:47 jamerlan New Issue
2016-03-14 19:47 jamerlan File Added: infolog.txt
2016-03-14 20:08 Kloot Note Added: 0016060
2016-03-14 20:08 Kloot Status new => closed
2016-03-14 20:08 Kloot Assigned To => Kloot
2016-03-14 20:08 Kloot Resolution open => unable to reproduce
2016-03-14 20:30 jamerlan Note Added: 0016061
2016-03-14 20:30 jamerlan Status closed => feedback
2016-03-14 20:30 jamerlan Resolution unable to reproduce => reopened
2016-03-14 20:41 jamerlan Note Added: 0016062
2016-03-14 20:41 jamerlan Status feedback => assigned
2016-03-14 20:49 Kloot Note Added: 0016063
2016-03-14 21:03 jamerlan Note Added: 0016064
2016-03-14 21:33 Kloot Note Added: 0016065
2016-03-14 21:42 jamerlan Note Added: 0016066
2016-03-16 17:16 hokomoko Target Version => 102.0
2016-03-16 17:20 hokomoko Note Added: 0016091
2016-03-16 19:35 abma Note Added: 0016098
2016-03-17 19:15 jamerlan Note Added: 0016103
2016-03-17 19:17 jamerlan Note Added: 0016104
2016-03-17 19:32 jamerlan Note Added: 0016105
2016-04-05 20:56 jamerlan Note Added: 0016162
2016-05-02 23:44 abma Relationship added related to 0005223
2016-05-03 00:40 abma Note Added: 0016247
2016-05-03 00:40 abma Target Version 102.0 =>
2016-05-03 11:50 jamerlan Note Added: 0016250
2016-12-13 13:46 Kloot Assigned To Kloot => jK
2016-12-13 13:46 Kloot Status assigned => resolved
2016-12-13 13:46 Kloot Resolution reopened => fixed
2016-12-13 13:46 Kloot Note Added: 0016959
+Issue History