2019-08-24 03:01 CEST

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0005023Spring engineGeneralpublic2016-01-12 00:28
Reporterhokomoko 
Assigned To 
PrioritynormalSeverityfeatureReproducibilityalways
StatusnewResolutionopen 
Product Version100.0+git 
Target VersionFixed in Version 
Summary0005023: Make enforcement of Java AI compilation optional
DescriptionAI_TYPES automatically defaults to all which makes cmake look for java.

If java isn't present, AI_TYPES should be set to NATIVE rather than failing compilation.
TagsNo tags attached.
Checked infolog.txt for lua Errors
Attached Files

-Relationships
+Relationships

-Notes

~0015443

abma (administrator)

Last edited: 2016-01-04 16:19

View 3 revisions

https://github.com/spring/spring/blob/develop/AI/Interfaces/Java/CMakeLists.txt#L245

how should the logic look like?

imo:

1. force java enabled (fails when no java is found)
2. force java disabled
3. autodetect = default (enable when java found, disabled when not found)


atm its 1. because detection of java failed sometimes and spring then was shipped without java interface

this change was introduced here, https://github.com/spring/spring/commit/77438b8c7acedc0cf2f858ad33b9d2729cfbaf8d

thats how it could look like:
with force enabled:
   AI_TYPES=JAVA NATIVE

autodetect:
   AI_TYPES=ALL

also no clue why AI_EXCLUDE_REGEX checks for the interface name:
https://github.com/spring/spring/blob/develop/AI/Interfaces/Java/CMakeLists.txt#L237

imo it should be used only for the ai's

+Notes

-Issue History
Date Modified Username Field Change
2016-01-04 11:44 hokomoko New Issue
2016-01-04 16:17 abma Note Added: 0015443
2016-01-04 16:17 abma Note Edited: 0015443 View Revisions
2016-01-04 16:19 abma Note Edited: 0015443 View Revisions
2016-01-11 23:58 hokomoko Status new => closed
2016-01-11 23:58 hokomoko Assigned To => hokomoko
2016-01-11 23:58 hokomoko Resolution open => no change required
2016-01-12 00:24 abma Severity major => feature
2016-01-12 00:24 abma Assigned To hokomoko =>
2016-01-12 00:24 abma Status closed => new
2016-01-12 00:24 abma Resolution no change required => open
2016-01-12 00:28 abma Summary Compilation fails without java => Make enforcement of Java AI compilation optional
+Issue History