2019-12-12 17:06 CET

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0000005Spring engineGeneralpublic2010-01-27 23:24
Reporterfnordia 
Assigned Totvo 
PrioritynormalSeveritycrashReproducibilityhave not tried
StatusclosedResolutionfixed 
Product Version 
Target VersionFixed in Version 
Summary0000005: Crash in CLosHandler::LosAddAir
DescriptionAccess violation (low address, possibly a null pointer?)

Call stack:

CLosHandler::LosAddAir 570
CLosHandler::LosAdd 162
CLosHandler::MoveUnit 151
CUnit::ChangeTeam 850
Additional InformationReport said: Trying to share selected units after the "you won the game" screen appeared
TagsNo tags attached.
Checked infolog.txt for Errors
Attached Files

-Relationships
has duplicate 0000497closed Random crash 
related to 0000657closed Crash with EE on Altair Crossing, 0.75b2 
+Relationships

-Notes

~0000818

tvo (reporter)

This isn't reproducable in 0.74b3. Also I remember I have fixed some crash bugs in CLosHandler in the past, so I assume this is fixed.

If it happens again, just reopen the issue.

~0000837

tvo (reporter)

Apparently this hasn't been fixed yet:

http://spring.clan-sy.com/phpbb/viewtopic.php?p=176709#176709

New stacktrace:

        CLosHandler::LosAddAir(LosInstance*)
        C:/taspring_trunk/rts/Sim/Misc/LosHandler.cpp:584

        CLosHandler::LosAdd(LosInstance*)
        C:/taspring_trunk/C:/mingw/lib/gcc/mingw32/4.1.1/include/c++/bits/stl_iterator.h:704

        CLosHandler::MoveUnit(CUnit*, bool)
        C:/taspring_trunk/rts/Sim/Misc/LosHandler.cpp:160

        CUnit::ChangeTeam(int, CUnit::ChangeType)
        C:/taspring_trunk/rts/Sim/Units/Unit.cpp:913

        CGame::ClientReadNet()
        C:/taspring_trunk/rts/Game/Game.cpp:2421

        CGame::Update()
        C:/taspring_trunk/rts/Game/Game.cpp:1470

        SpringApp::Update()
        C:/taspring_trunk/rts/System/Main.cpp:812

        SpringApp::Run(int, char**)
        C:/taspring_trunk/rts/System/Main.cpp:990

        Run(int, char**)
        C:/taspring_trunk/rts/System/Main.cpp:1047

        WinMain@16
        C:/taspring_trunk/rts/System/Main.cpp:1096

        main
        J:/MinGW/home/Sherpya/stage/mingw-runtime-3.10/main.c:78

        _mingw_CRTStartup
        J:/MinGW/home/Sherpya/stage/mingw-runtime-3.10/crt1.c:226

        WinMainCRTStartup
        J:/MinGW/home/Sherpya/stage/mingw-runtime-3.10/crt1.c:26

~0001233

tvo (reporter)

^^ that was 0.74b3, FYI.

~0004555

tvo (reporter)

Good chance this was caused by issue fixed in 0001750.

Otherwise this is too old to investigate again, need new traces and replays if it still happens.
+Notes

-Issue History
Date Modified Username Field Change
2005-11-03 22:18 fnordia New Issue
2005-11-03 22:18 fnordia Status new => assigned
2005-11-03 22:18 fnordia Assigned To => jcnossen
2005-11-03 22:18 fnordia File Added: spring.zip
2007-03-25 13:40 tvo Assigned To jcnossen => tvo
2007-03-25 13:41 tvo Status assigned => resolved
2007-03-25 13:41 tvo Resolution open => fixed
2007-03-25 13:41 tvo Note Added: 0000818
2007-03-27 08:53 tvo Note Added: 0000837
2007-03-27 08:53 tvo Status resolved => assigned
2007-08-27 15:44 tvo Relationship added has duplicate 0000497
2007-09-11 12:11 tvo Note Added: 0001233
2007-10-14 13:49 tvo Relationship added related to 0000657
2010-01-27 23:24 tvo Note Added: 0004555
2010-01-27 23:24 tvo Status assigned => closed
+Issue History