2019-12-13 09:39 CET

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0000496Spring engineGeneralpublic2007-11-17 19:30
ReporterKDR_11k 
Assigned ToKloot 
PrioritynormalSeveritymajorReproducibilityalways
StatusresolvedResolutionfixed 
Product Version 
Target VersionFixed in Version 
Summary0000496: Arced missile weapons don't compensate for height
DescriptionAny missile weapon with TrajectoryHeight=1 ignores height differences when guiding its missile along the arc. Additionally, values like 2 for TrajectoryHeight cause the missile to fall short.

This makes accurate rocket artillery useless when there are height differences involved. It also eliminates the higher position advantage artillery supposedly has bwecause, well, if you're in a higher position you don't hit jack.

Reproduction: Take a unit with arced, unguided missiles (with no wobble, preferrably), place it on a hill, make it shoot at the ground or a small unit below the hill. Observe the difference between the target position and the actual impact (the missile flies too far). Exchange the shooter and target positions (target on hill, shooter below), the missile falls short. Take a bunch of arced missile units, repeat the experiment. Notice that their missiles all travel through the target position at the height the shooting unit is at.
TagsNo tags attached.
Checked infolog.txt for Errors
Attached Files

-Relationships
+Relationships

-Notes

~0001357

tvo (reporter)

Which unit of which mod does have an an arced unguided missile without wobble?

(I don't know enough mods out of my head so giving real steps to reproduce would be useful.. ie. use mod X and do .give Y)

~0001358

KDR_11k (reporter)

Yeah, I have a hard time thinking of one right now, back in 74b3 the Gundam gtank was perfectly accurate. I'll upload a modified Kernel Panic, use the pointer unit. I like the NarrowValley map for demonstrating extreme height differences.

~0001363

Decimator (reporter)

Expand and Exterminate .23 uses unguided arcing missiles for URC LVL2 and 3 artillery.

These units have innaccurate weapons, but no wobble.

urcspider2g2 - The level 2 URC artillery
urcjaguarr2 - The level 3 URC artillery.

~0001439

Kloot (developer)

I've committed a fix for this in r4807,
but I'm not entirely pleased with the
results (it works reasonably well for
those EE units, but Arm Ravens in eg.
XTA seem a little worse off). Let me
know if this negatively affects mod
balance in any way.

~0001440

KDR_11k (reporter)

Nope, try it with the attached KP version, the shots are still off but now the same error appears in all shots, even shots without height difference (guess: the error seems to be equal to the offest of the launcher compared to the center or aim piece)

~0001441

Kloot (developer)

The overshoot in KP was being caused by the
greater speed of the Pointer's missiles, so
I've made the trajectory correction factor
speed-dependant. It still won't win a prize
for elegance though, I'll try to come up with
a smoother adjustment method.

~0001443

Kloot (developer)

Trajectory changes are now less obviously
linear, and I have not seen any remaining
cases of under- or overshooting in KP or
other mods with fast missiles. Marking this
as resolved again, but feel free to reopen
if you discover something unsavory.
+Notes

-Issue History
Date Modified Username Field Change
2007-03-24 09:28 KDR_11k New Issue
2007-10-21 09:52 tvo Note Added: 0001357
2007-10-21 11:26 KDR_11k Note Added: 0001358
2007-10-21 11:27 KDR_11k File Added: Kernel_Panic Mantis.sd7
2007-10-23 01:40 Decimator Note Added: 0001363
2007-11-17 14:00 Kloot Note Added: 0001439
2007-11-17 14:00 Kloot Status new => resolved
2007-11-17 14:00 Kloot Resolution open => fixed
2007-11-17 14:00 Kloot Assigned To => Kloot
2007-11-17 14:39 KDR_11k Status resolved => feedback
2007-11-17 14:39 KDR_11k Resolution fixed => reopened
2007-11-17 14:39 KDR_11k Note Added: 0001440
2007-11-17 15:13 Kloot Note Added: 0001441
2007-11-17 19:30 Kloot Note Added: 0001443
2007-11-17 19:30 Kloot Status feedback => resolved
2007-11-17 19:30 Kloot Resolution reopened => fixed
+Issue History