2019-08-23 16:12 CEST

View Issue Details Jump to Notes ] Related Changesets ]
IDProjectCategoryView StatusLast Update
0004911Spring engineGeneralpublic2016-06-09 16:47
Reporterlhog 
Assigned ToKloot 
PrioritynormalSeveritymajorReproducibilityalways
StatusresolvedResolutionfixed 
Product Version100.0 
Target VersionFixed in Version 
Summary0004911: pathfinding issues on IsIs Delta, probably on some others
DescriptionConstructor consistently chooses wrong path to approach construction site. Goes in endless loop.
Steps To Reproduce1) Watch the replay
2) Do same
TagsNo tags attached.
Checked infolog.txt for lua Errors
Attached Files

-Relationships
related to 0005272resolvedKloot Units can take highly inefficient path 
+Relationships

-Notes

~0015792

hokomoko (developer)

There are still issues on 100.0+git
I've uploaded a demo

~0015794

Kloot (developer)

I assume you mean the issue at 3:20, which is a very old design hack: the set of nodes allowed to be explored is limited by a circular constraint to keep CPU use under control in pathological cases when start and goal are within max-resolution search distance as the crow flies, but separated by half the map in path-space.

Fixing that under the current PFS design will be a bit hairy.

~0015802

Anonymous (viewer)

Fix 7e93dd876e5406d5851419139f8b7b14d6136147 committed to develop branch: fix 0004911 (CircularConstraint magically does not need to be active), repo: spring changeset id: 6624

~0015803

hokomoko (developer)

Apparently the original issue still exists, attaching a new demo

~0015804

Kloot (developer)

Hmm, there seem to be two things going on there:

1) cost flipflopping (very old problem)
2) paths crossing impassable cliffs (news to me, will see if I can find out why)

~0015805

hokomoko (developer)

Last edited: 2016-02-16 18:53

View 3 revisions

can it be that in a lower resolution the node is pathable while in a higher one it isn't?

(due to the cliff being narrow or something)

~0015806

Kloot (developer)

Last edited: 2016-02-16 20:15

View 3 revisions

That fortunately isn't possible (crossing edges have inf-cost) but the problem is more subtle, see screenshot:

start position maps to low-res block <3,2> (markers are block centers)
goal position maps to low-res block <7,3>
low-res path is {<3,2>, <4,2>, <5,3>, <6,3>, <7,3>}

So we get a seemingly valid path, but our goal is on the other side of the cliff running through <7,3> and we need to backtrack. To fix this, goal blocks should be rejected if entered from a direction s.t. a high-res path to the actual goal position does not exist.

e: looks like a relatively easy change, will test for a bit

~0015810

hokomoko (developer)

seems to be fixed by https://github.com/spring/spring/commit/7e6b6ee753aa94b7c65930313aa9f176348f345a

~0015812

Kloot (developer)

ok, closing since the original "endless loop" condition should now be much rarer and requires a major redesign to tackle fully.
+Notes

+Related Changesets

-Issue History
Date Modified Username Field Change
2015-07-20 16:06 lhog New Issue
2015-07-20 16:06 lhog File Added: 20150720_165853_IsisDelta_v02_100.sdf
2016-02-16 01:00 hokomoko File Added: 20160216_015957_IsisDelta_v02_100.0.1-1162-gefb8d7epathbug.sdf.gz
2016-02-16 01:00 hokomoko Note Added: 0015792
2016-02-16 02:13 Kloot Note Added: 0015794
2016-02-16 15:22 Kloot Assigned To => Kloot
2016-02-16 15:22 Kloot Status new => assigned
2016-02-16 18:11 Changeset attached => spring develop 7e93dd87
2016-02-16 18:11 Anonymous Note Added: 0015802
2016-02-16 18:11 Anonymous Status assigned => resolved
2016-02-16 18:11 Anonymous Resolution open => fixed
2016-02-16 18:24 hokomoko Note Added: 0015803
2016-02-16 18:24 hokomoko Status resolved => feedback
2016-02-16 18:24 hokomoko Resolution fixed => reopened
2016-02-16 18:24 hokomoko File Added: 20160216_192536_IsisDelta_v02_100.0.1-1164-g7e93dd8pathissue.sdf.gz
2016-02-16 18:46 Kloot Note Added: 0015804
2016-02-16 18:52 hokomoko Note Added: 0015805
2016-02-16 18:52 hokomoko Note Edited: 0015805 View Revisions
2016-02-16 18:53 hokomoko Note Edited: 0015805 View Revisions
2016-02-16 19:45 Kloot Note Added: 0015806
2016-02-16 19:45 Kloot File Added: mantis4911.jpg
2016-02-16 19:47 Kloot Note Edited: 0015806 View Revisions
2016-02-16 20:15 Kloot Note Edited: 0015806 View Revisions
2016-02-16 22:46 hokomoko Note Added: 0015810
2016-02-16 23:30 Kloot Note Added: 0015812
2016-02-16 23:30 Kloot Status feedback => resolved
2016-02-16 23:30 Kloot Resolution reopened => fixed
2016-06-09 16:47 hokomoko Relationship added related to 0005272
+Issue History