2020-04-05 16:31 CEST

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0004887Spring engineGeneralpublic2015-07-05 22:53
ReporterNemo 
Assigned Tohokomoko 
PrioritynormalSeveritycrashReproducibilityalways
StatusresolvedResolutionfixed 
Product Version99.0 
Target Version100.0Fixed in Version 
Summary0004887: segfault (reproducable in demo)
DescriptionPlaying S44 RC1 on Spring 99.0, JAL and I both crashed at the same time. It also occurs when playing back the demo: the crash is at frame 16603.

We're both on Linux.
Steps To Reproduceplay http://replays.springrts.com/replay/30839955a9c78d87141138fba21a159d/ using Spring 99.0.

map: http://springfiles.com/spring/spring-maps/1944-cooper-hill-v2-0
game: s44:stable rapid tag or http://s44.repo.springrts.com/builds/s44-v2.0-rc1.sdz
infolog: http://paste.springfiles.com/view/b649d1e2
TagsNo tags attached.
Checked infolog.txt for Errors
Attached Files

-Relationships
duplicate of 0004862resolvedhokomoko crashes on 99.0.1-20-gc999972 
+Relationships

-Notes

~0014903

Nemo (reporter)

argh, *reproducible

Damnit Jim, I'm a software developer, not an English teacher.

~0014904

hokomoko (developer)

Thanks for the report!

~0014905

abma (administrator)

for the reference, translated:

rts/System/Platform/Linux/CrashHandler.cpp:837
rts/System/Platform/Linux/CrashHandler.cpp:866
rts/Sim/Units/UnitHandler.cpp:295
rts/Game/Game.cpp:1578
rts/Net/NetCommands.cpp:513
rts/Game/Game.cpp:1024
rts/System/SpringApp.cpp:941
rts/System/SpringApp.cpp:975
rts/System/Main.cpp:48
rts/System/Main.cpp:108
+Notes

-Issue History
Date Modified Username Field Change
2015-07-05 21:48 Nemo New Issue
2015-07-05 21:50 Nemo Note Added: 0014903
2015-07-05 22:39 abma Target Version => 100.0
2015-07-05 22:43 hokomoko Relationship added duplicate of 0004862
2015-07-05 22:43 hokomoko Status new => resolved
2015-07-05 22:43 hokomoko Resolution open => fixed
2015-07-05 22:43 hokomoko Assigned To => hokomoko
2015-07-05 22:47 hokomoko Status resolved => feedback
2015-07-05 22:47 hokomoko Resolution fixed => reopened
2015-07-05 22:47 hokomoko Note Added: 0014904
2015-07-05 22:47 hokomoko Status feedback => resolved
2015-07-05 22:47 hokomoko Resolution reopened => fixed
2015-07-05 22:53 abma Note Added: 0014905
+Issue History