2019-12-06 14:00 CET

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0004863Spring engineGeneralpublic2015-06-30 15:35
ReporterKlon 
Assigned TojK 
PrioritynormalSeverityfeatureReproducibilityalways
StatusfeedbackResolutionreopened 
Product Version99.0 
Target VersionFixed in Version 
Summary0004863: 3d sounds always audible at high zoom levels
Descriptionrefering to this old report: https://springrts.com/mantis/view.php?id=2623

current behaviour is that sounditems that are being played at a certain location with a given rolloff distance will only fade out correctly when not fully zoomed out, at which point they are always fully audible again.

it is my understanding that this behaviour is wanted as a default, however, there is no way to circumvent it. i made a ambient sound widget that uses sound emitters at certain locations on the map, however, it is impossible to make the sounds fade out at maximum zoom-out. which would be the intended behaviour for this application.

TL;DR: add an option to make particular sounds fade off entirely at high zoom-out levels.

ways to go about this:
- add a parameter to the playsound function that disables the default hebaviour
- add a flag to the sounditem structure that controls this behaviour. there already is a in3d tag but it does the opposite, it makes sounds audible everywhere even at medium zoom levels
- add a sound channel ("ambient", for example) in which sounds will fully fade out
TagsNo tags attached.
Checked infolog.txt for Errors
Attached Files

-Relationships
+Relationships

-Notes

~0014801

jK (developer)

1. intentional
2. there is a config tag

~0014802

Klon (reporter)

that makes no sense. i know the behaviour is intentional, im asking for a way to override it for -particular- sounds.

this implies that i do not want to change my or other peoples game config.
+Notes

-Issue History
Date Modified Username Field Change
2015-06-30 15:03 Klon New Issue
2015-06-30 15:19 jK Note Added: 0014801
2015-06-30 15:19 jK Status new => closed
2015-06-30 15:19 jK Assigned To => jK
2015-06-30 15:19 jK Resolution open => no change required
2015-06-30 15:35 Klon Note Added: 0014802
2015-06-30 15:35 Klon Status closed => feedback
2015-06-30 15:35 Klon Resolution no change required => reopened
+Issue History