2019-12-14 23:02 CET

View Issue Details Jump to Notes ] Related Changesets ]
IDProjectCategoryView StatusLast Update
0004847Spring engineGeneralpublic2015-06-27 11:20
ReporterGoogle_Frog 
Assigned Tohokomoko 
PrioritynormalSeverityminorReproducibilityalways
StatusresolvedResolutionfixed 
Product Version99.0+git 
Target VersionFixed in Version 
Summary0004847: 99.0.1-17 Ghosted structures are missing
DescriptionGhosted structures are not being drawn. Their ground decals are drawn (as shown in the screenshot).
TagsNo tags attached.
Checked infolog.txt for Errors
Attached Files

-Relationships
+Relationships

-Notes

~0014717

Google_Frog (reporter)

Works in 98.0.1-848-g3f9edd0
Broken in 98.0.1-857-gfdb9ac1

My guess would be this commit: https://github.com/spring/spring/commit/20417ec914a673ffbae714ff3e60e8c31ef76c3d

The current behaviour is backwards. The structure is supposed to be drawn semi-transparent and the ground decal should not be drawn. The ground decal should not be drawn because see through units with AO on the ground decal look stupid (and many games put AO on the ground decal).

~0014726

hokomoko (developer)

Fix c999972782457101af899b6c663f603990658b3a committed to develop branch: Fix 0004847, repo: spring changeset id: 5258

~0014727

hokomoko (developer)

Ground decals should be drawn and were drawn, beneath the ghosted buildings.
It's just easier to notice them when the ghost is missing.
+Notes

+Related Changesets

-Issue History
Date Modified Username Field Change
2015-06-27 05:09 Google_Frog New Issue
2015-06-27 05:09 Google_Frog File Added: screen00035.jpg
2015-06-27 05:38 Google_Frog Note Added: 0014717
2015-06-27 11:16 hokomoko Changeset attached => spring develop c9999727
2015-06-27 11:16 hokomoko Note Added: 0014726
2015-06-27 11:16 hokomoko Assigned To => hokomoko
2015-06-27 11:16 hokomoko Status new => resolved
2015-06-27 11:16 hokomoko Resolution open => fixed
2015-06-27 11:20 hokomoko Note Added: 0014727
2015-06-27 11:20 hokomoko Status resolved => feedback
2015-06-27 11:20 hokomoko Resolution fixed => reopened
2015-06-27 11:20 hokomoko Status feedback => resolved
2015-06-27 11:20 hokomoko Resolution reopened => fixed
+Issue History