2019-08-23 15:42 CEST

View Issue Details Jump to Notes ] Related Changesets ]
IDProjectCategoryView StatusLast Update
0004413Spring engineLuapublic2017-09-24 19:12
Reportermsafwan 
Assigned Tocleanrock 
PrioritynormalSeverityminorReproducibilityalways
StatusresolvedResolutionfixed 
Product Version97.0.1+git 
Target Version98.0Fixed in Version98.0 
Summary0004413: widget:GameProgress() was no longer called for rejoining player
DescriptionTry this widget, and rejoin a running game.

It seem to give no Echo at all. It suppose to show current serverFrame while we are rejoining.

For comparison: In spring 91 it was called every 10 second.
TagsNo tags attached.
Checked infolog.txt for lua Errors
Attached Files

-Relationships
+Relationships

-Notes

~0013192

msafwan (reporter)

update: it did call if you spectate the game from start, but it call at irregular interval.

here is example game: http://zero-k.info/Battles/Detail/265736
here is the frame which it call:
[f=0001499] 1500
[f=0001795] 1800
[f=0002097] 2100
[f=0004199] 4200
[f=0004494] 4500
[f=0008694] 8700
[f=0010498] 10500
[f=0011995] 12000
[f=0013197] 13200
[f=0013493] 13500
[f=0015297] 15300
[f=0017094] 17100
[f=0018258] 18300
[f=0018270] Game Over:

The game is 10 minute long, and it only call 13 time!

~0013193

msafwan (reporter)

Last edited: 2014-06-04 00:35

View 4 revisions

update2:
okay, sorry I didn't thoroughly research this before reporting.

It turn out that widget:GameProgress() did call for late-rejoiner (more frequently than spectating from start), but was lagged by the same amount of the game, so the frame-number is useless... its same as Spring.GetGameFrame()!

In spring 91 it skip the lag and tell the rejoiner directly the frame for the server, so we can calculate how much to catch-up.

~0013216

abma (administrator)

seems to be broken in 96.0 already

~0013217

abma (administrator)

Last edited: 2014-06-06 12:40

View 2 revisions

works for me with:
UseNetMessageSmoothingBuffer = 0
it seems

@msafwan:
does it work with that setting for you, too?

i couldn't test it in a online game with 96.0 yet.

~0013219

abma (administrator)

https://github.com/spring/spring/commit/eceb7fa13645a2e701e6421663ae456783b94dff

~0013226

abma (administrator)

reopening, because the fix caused unitstuttering (many NP=0 messages)

if someone needs/wants to reproduce: just join springie host, add 2 CAI players, start game and type /debug

tail -f infolog.txt because ZK's console filters messages.

~0013227

Kloot (developer)

No, THIS --> http://code.google.com/p/zero-k/source/detail?r=13740 <-- did.

~0013228

abma (administrator)

ouch, thx and sorry!
+Notes

+Related Changesets

-Issue History
Date Modified Username Field Change
2014-06-03 23:15 msafwan New Issue
2014-06-03 23:15 msafwan File Added: dbg_rejoin_tester.lua
2014-06-03 23:15 msafwan Tag Attached: callins
2014-06-03 23:49 msafwan Note Added: 0013192
2014-06-04 00:30 msafwan Note Added: 0013193
2014-06-04 00:34 msafwan Note Edited: 0013193 View Revisions
2014-06-04 00:35 msafwan Note Edited: 0013193 View Revisions
2014-06-04 00:35 msafwan Note Edited: 0013193 View Revisions
2014-06-04 14:52 abma Target Version => 97.0.1+git
2014-06-04 14:52 abma Target Version 97.0.1+git => 98.0
2014-06-06 11:40 abma Note Added: 0013216
2014-06-06 12:13 abma Note Added: 0013217
2014-06-06 12:37 abma Priority low => normal
2014-06-06 12:40 abma Note Edited: 0013217 View Revisions
2014-06-06 17:51 abma Note Added: 0013219
2014-06-06 17:51 abma Status new => resolved
2014-06-06 17:51 abma Fixed in Version => 98.0
2014-06-06 17:51 abma Resolution open => fixed
2014-06-06 17:51 abma Assigned To => Kloot
2014-06-07 12:09 abma Note Added: 0013226
2014-06-07 12:09 abma Status resolved => new
2014-06-07 12:28 Kloot Note Added: 0013227
2014-06-07 12:29 Kloot Status new => closed
2014-06-07 12:34 abma Note Added: 0013228
2014-06-22 13:47 cleanrock Changeset attached => spring develop 05e4f29f
2014-06-22 13:47 cleanrock Assigned To Kloot => cleanrock
2014-06-22 13:47 cleanrock Status closed => resolved
2017-09-24 19:12 Kloot Tag Detached: callins
+Issue History