2022-05-23 16:04 CEST

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0004292Spring engineLuapublic2014-01-25 19:58
Reportersilentwings 
Assigned TojK 
PrioritynormalSeveritymajorReproducibilityalways
StatusresolvedResolutionreopened 
Product Version96.0.1+git 
Target VersionFixed in Version 
Summary0004292: -199 returns wrong error msg about callins with wrong return types
DescriptionRun BA 7.91 with -199, use ota camera mode, have the SmoothScroll widget on and try to mid-click scroll the camera. It will spam errors:

[f=0021792] Warning: Got wrong type for return argument #1 in "LuaUI::MouseMove" (boolean expected, got nil)

The error message is wrong because camera_smooth_move does not contain an instance of the MouseMove callin (only MousePress MouseRelease and MouseWheel).

Additional InformationThe error message is not very helpful - please return either the line number/name of the widget involved.
TagsNo tags attached.
Checked infolog.txt for Errors
Attached Files

-Relationships
+Relationships

-Notes

~0012759

jK (developer)

1. it's impossible from engine to give the name of the causing widget
2. no one says it is caused SmoothScroll
3. grep the code for wrong MouseMoves

~0012766

cleanrock (reporter)

This is actually a bug in widgetHandler:MouseMove, it fails to return a bool if widget dont have MouseMove.

Also, i guess the gadgetHandler:MouseMove also need to always return a bool, atm it looks like this in springcontent:
function gadgetHandler:MouseMove(x, y, dx, dy, button)
  local mo = self.mouseOwner
  if (mo and mo.MouseMove) then
    return mo:MouseMove(x, y, dx, dy, button)
  end
end
I guess a
return false
before last end is good if my assumption is correct.

Btw, many widgets in BA dont return bool for MouseMove so they should be looked at by BA devs.
+Notes

-Issue History
Date Modified Username Field Change
2014-01-24 19:27 silentwings New Issue
2014-01-25 01:41 jK Note Added: 0012759
2014-01-25 01:41 jK Status new => closed
2014-01-25 01:41 jK Assigned To => jK
2014-01-25 01:41 jK Resolution open => not fixable
2014-01-25 19:36 cleanrock Note Added: 0012766
2014-01-25 19:36 cleanrock Status closed => feedback
2014-01-25 19:36 cleanrock Resolution not fixable => reopened
2014-01-25 19:58 jK Changeset attached => spring develop 13fe1ede
2014-01-25 19:58 jK Status feedback => resolved
+Issue History