2020-02-16 20:02 CET

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0003552Spring engineGeneralpublic2013-10-26 18:49
ReporterCarRepairer 
Assigned To 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionnot fixable 
Product Version93.1 
Target VersionFixed in Version 
Summary0003552: Y and Z axes are swapped for assimp
DescriptionPossibly related to the recent change where assimp models are no longer rotated 90 degrees, the Y and Z axes are swapped in LUS. When spinning a piece on the y_axis I expect the axis to be pointing to the sky, but it's not. Instead, the z_axis points to the sky. My previous animations are now wrong.
Steps To ReproduceFor an assimp model, rotate or spin a piece on y axis and it will spin on z, and vice versa.
TagsNo tags attached.
Checked infolog.txt for Errors
Attached Files

-Relationships
has duplicate 0003756closedKloot EmitSfx(piece,2048+x) !? (assimp .dae) 
related to 0003530resolvedjK When active command is to build a non-factory unit, image is rotated 90 degrees. 
+Relationships

-Notes

~0010041

smoth (reporter)

Last edited: 2013-08-12 04:29

View 3 revisions

sorry but I have no released game at the moment. To reproduce my shot grab:
https://venture2.projectlocker.com/GundamRTSdevs/RTSCore/svn
username: tester
Password: rageflame

you will need rtscore.sdd and testgame.sdd
the game should show up test project

demi2a_1 is the s3o version
demidaetest1 is the dae file


VERSION: 256

they are very close to identical, only changes being that I had to make the right left and the left right(x-), the origins are probably not 1:1 and that I goofed a back gun(inverted) on the dae. They use the same scripts and textures, the dae unit is set to different colors to make it obviously different from the s3o version.

~0010049

emmanuel (reporter)

since blender2.65 use Z axis for the TOP than its evrything else assimp_springrts0.93.1 who are buged : assimp fixed the OTAism
(still the ghosted ennemy and ghosted building use Y for top)

~0010135

jK (developer)

https://github.com/spring/spring/commit/d94909e784d1354059b07e15b1adb342c8d0b6ce

~0010403

CarRepairer (reporter)

The issue is not fixed for me in 94.1.

~0010412

jK (developer)

Last edited: 2013-04-08 08:56

View 2 revisions

Don't mimic googlefrog please ...
You know how a proper error report looks like. Neither your annoying chat messages nor this reopening fulfills the rules.

~0010804

smoth (reporter)

Last edited: 2013-06-01 23:19

View 2 revisions

JK, testing with the svn files, do the units listed in my post display properly for you or not? if so, what build are you using. If not, are these not good enough to test the issue?

~0011144

FLOZi (reporter)

Last edited: 2013-08-02 19:00

View 3 revisions

Still present in current develop. Not sure what you are complaining about; smoth supplied examples?

If you prefer I can supply BTL svn or just the files used?


BTL examples are further complicated by the fact that Spiked uses max which is z=up though, not sure if the 'y up' export on dae will fix all issues.

~0011266

Kloot (developer)

tested a bit with revision 310.

demi2a_1 and demi2daetest1 do not appear to be the same mech-type, models look very different. there is no s3o equivalent of demi2daetest1 afaics.

of the three working DAE variants (demi2daetest1, demi2daetest1y, and demi2daetest2) demi2daetest1y seems to have correct barrel animations, 1 and 2 do not.

which s3o and dae models need to be compared?

~0011276

smoth (reporter)

poop, I had replaced them. I can try and go back and restore them to before I did all my hacky fixes if you would like.

~0011277

smoth (reporter)

actually I may have not replaced them sorry I was half awake and didn't realize you grabbed 310. I will check the models maybe I typed the wrong one. Sorry. I will look into this tomorrow as soon as I can

~0011292

smoth (reporter)

Last edited: 2013-08-13 00:45

View 2 revisions

ok I am back from where I was. grab version 256 of both rts core and testgame.

~0011339

Kloot (developer)

Sorry, but closing this.

The root cause of all these issues is creating a model in a (tool using a) coordinate system that differs from Spring's, and since there are many tools with equally many coor-sys conventions it is impossible for Spring (with or without assimp) to guess the proper axis remapping beforehand for all model formats. See also 0003940.

As a bandaid it will be possible to PARTIALLY correct wrong mappings in 95.0 by providing extra metadata, but the preferred solution is always to remodel / reexport (as was presumably done for demi2daetest1y versus demi2daetest1).
+Notes

-Issue History
Date Modified Username Field Change
2013-03-13 05:47 CarRepairer New Issue
2013-03-13 17:47 abma Severity minor => major
2013-03-13 22:52 smoth File Added: screen00702.jpg
2013-03-13 22:56 smoth Note Added: 0010041
2013-03-13 22:57 smoth Note Edited: 0010041 View Revisions
2013-03-14 09:15 emmanuel Note Added: 0010049
2013-03-14 19:12 Kloot Relationship added related to 0003530
2013-03-20 19:35 jK Note Added: 0010135
2013-03-20 19:35 jK Status new => resolved
2013-03-20 19:35 jK Resolution open => fixed
2013-03-20 19:35 jK Assigned To => jK
2013-04-07 18:54 CarRepairer Note Added: 0010403
2013-04-07 18:54 CarRepairer Status resolved => feedback
2013-04-07 18:54 CarRepairer Resolution fixed => reopened
2013-04-08 08:56 jK Note Added: 0010412
2013-04-08 08:56 jK Note Edited: 0010412 View Revisions
2013-06-01 23:19 smoth Note Added: 0010804
2013-06-01 23:19 smoth Note Edited: 0010804 View Revisions
2013-08-02 18:56 FLOZi Note Added: 0011144
2013-08-02 18:59 FLOZi Note Edited: 0011144 View Revisions
2013-08-02 19:00 FLOZi Note Edited: 0011144 View Revisions
2013-08-10 23:28 Kloot Note Added: 0011266
2013-08-11 03:18 smoth Note Added: 0011276
2013-08-11 06:15 smoth Note Added: 0011277
2013-08-12 04:25 smoth Note Added: 0011292
2013-08-12 04:29 smoth Note Edited: 0010041 View Revisions
2013-08-13 00:45 smoth Note Edited: 0011292 View Revisions
2013-08-20 02:38 Kloot Note Added: 0011339
2013-08-20 02:38 Kloot Status feedback => closed
2013-08-20 02:38 Kloot Assigned To jK =>
2013-08-20 02:38 Kloot Resolution reopened => not fixable
2013-10-26 18:49 Kloot Relationship added has duplicate 0003756
+Issue History