2019-12-09 10:16 CET

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0003215Spring engineAIpublic2012-07-20 22:16
ReporterAF 
Assigned Toabma 
PriorityurgentSeveritycrashReproducibilityalways
StatusresolvedResolutionno change required 
Product Version89.0 
Target VersionFixed in Version 
Summary0003215: Broken Shard included in Installer
DescriptionI was persuaded to allow inclusion of Shard in the v89 installer.

I said okay under 2 premises:

 - That the build of Shard works
 - That if it breaks it be removed

Now that v89 has been released:

 - The build of Shard included does not work
 - It has broken and is not being removed

The response so far has been 'do it yourself'. I do not know how, there is no documentation explaining how, and I don't have the time to learn, time that would be better spent fixing the bug itself or putting food on the table, especially when I'm at the beck and whim of others anyway with not having the access to single-handedly release and announce a new installer.

According to Github Shard is still being included, and is set to be included again in v90 despite still being broken.
Steps To ReproduceInclude a Shard AI in a game using the mingw32 build
Additional InformationThe bug itself has a Github issue here:

https://github.com/Tarendai/Shard/issues/8

Tobi and abma have been of help in attempting to debug this, but until it's fixed I'd much appreciate the immediate removal of Shard from the installer. It reflects badly on both me and everyone involved in the engine that there is such an easy and obvious way of crashing a game with no warnings or indications to downloaders.
TagsNo tags attached.
Checked infolog.txt for Errors
Attached Files

-Relationships
related to 0002923closedabma ValidAIs.lua so lobbies can only show compatible AIs 
+Relationships

-Notes

~0009064

abma (administrator)

i added it because you said me, that the mingw build works for you. "can't reproduce"

now you say, it doesn't work? weird.

removing shard is a bunch of work that is imo useless as shard has to be fixed anyway. upgrading existing installers will make much more problems as it solves. so, please spent your time in fixing shard...

next week i hopefully find the time to fix it, as the part of code where something goes wrong should be small, see the bug report.

~0009065

abma (administrator)

for the reference:

https://github.com/Tarendai/Shard/issues/8#issuecomment-5181467
its the same build as shipped now with the installer (afaik just a few fixes are added)

~0009066

abma (administrator)

additon:

because of you coulnd't reproduce the bug it seems like some other guy has to fix it. if shard wouldn't be in the installer, nobody else will test it / possible fix it or at least give some feedback. without feedback its much more harder to fix it, as you've to try out all on your own. (like, is it platform/cpu/gfx/os specific...)

and: because it was included, tobi tested it too and gave some great hints that possible will help to fix it...

i hope you'll see at some point how important feedback is...

~0009068

AF (reporter)

While I'm glad that feedback is there, I'm mindful that there's a black hole of infinite loop'ness' that anyone can fall into quite easily with no warning signs around.

As the creator of Shard I'm putting forward a piece of software, as such it's expected of me that it work, and it's irresponsible to distribute utterly broken unusable software. While there are advantages as a developer of having the broken build there for myself, it's not the responsible thing to do for the end user and so my only course of action is requesting its removal.

If removal is not an option then at the very least a warning so new users don't think "ooo spring, Ill play offline before I go multiplayer, let me pick map A, game B, and AI Shard, oh dear its frozen this thing is rubbish"

~0009070

abma (administrator)

this is currently a problem in general with spring & broken ai's, removal of shard won't fix it, see:
http://springrts.com/mantis/view.php?id=2923

in short: other ai's are horrible broken, too...
+Notes

-Issue History
Date Modified Username Field Change
2012-07-20 20:31 AF New Issue
2012-07-20 21:04 abma Note Added: 0009064
2012-07-20 21:04 abma Status new => resolved
2012-07-20 21:04 abma Resolution open => no change required
2012-07-20 21:04 abma Assigned To => abma
2012-07-20 21:12 abma Note Added: 0009065
2012-07-20 21:21 abma Note Added: 0009066
2012-07-20 21:31 AF Note Added: 0009068
2012-07-20 21:31 AF Status resolved => feedback
2012-07-20 21:31 AF Resolution no change required => reopened
2012-07-20 21:36 abma Note Added: 0009070
2012-07-20 21:41 abma Status feedback => resolved
2012-07-20 21:41 abma Resolution reopened => no change required
2012-07-20 22:16 abma Relationship added related to 0002923
+Issue History