2019-10-15 01:11 CEST

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0000113Spring engineGeneralpublic2006-03-10 19:42
Reportercolorblind 
Assigned Totvo 
PrioritynormalSeverityminorReproducibilityalways
StatusresolvedResolutionfixed 
Product Version 
Target VersionFixed in Version 
Summary0000113: Units do not report when they're under attack
DescriptionUnits do not report when they are under attack; in previous releases (pre 0.7x) they did.
TagsNo tags attached.
Checked infolog.txt for lua Errors
Attached Files

-Relationships
has duplicate 0000089resolvedtvo Off-screen attack klaxon no longer works unless spectating 
+Relationships

-Notes

~0000104

colorblind (reporter)

I just noticed that when viewing a replay, units DO report that they're under attack.

~0000107

el_matarife (reporter)

Does the attack warning work while spectating? This and the base attack warning sound / klaxon bug may be related or cause by the same problem. The base attack warning sound doesn't work while playing, but works while spectating, and I'd assume replays but haven't tested yet.

~0000109

colorblind (reporter)

Yes, when you're viewing a replay you are a spectator, so it works. I guess you're talking about the same thing, as bases are made up of units :P.

~0000110

el_matarife (reporter)

I think I found the bug on line 583 of the unit.cpp file, the if statement on that line has && gu->spectating in it which I believe should be a || logical OR operator rather than a && logical AND, meaning the if statement won't be tripped unless you are spectating. I found this in the latest source code download on the download page which is I believe just the regular .70b2 code.

~0000113

colorblind (reporter)

The old windows branch (0.67b3 on sourceforge CVS) has "&& !gu->spectating" instead of "|| gu->spectating". The former (i.e. the AND NOT) seems more desirable to me.

~0000114

tvo (reporter)

Changed it to 0.67b3 code. Also separated the commander timer and the normal timer better, so your commander message won't be discarded because there was a normal attack notification a frame earlier.
+Notes

-Issue History
Date Modified Username Field Change
2006-03-05 17:50 colorblind New Issue
2006-03-09 14:57 colorblind Note Added: 0000104
2006-03-09 20:06 el_matarife Note Added: 0000107
2006-03-09 20:46 colorblind Note Added: 0000109
2006-03-09 21:21 el_matarife Note Added: 0000110
2006-03-09 21:26 tvo Status new => assigned
2006-03-09 21:26 tvo Assigned To => tvo
2006-03-09 22:30 tvo Status assigned => resolved
2006-03-09 22:30 tvo Resolution open => fixed
2006-03-09 22:38 tvo Relationship added has duplicate 0000089
2006-03-10 13:27 colorblind Status resolved => feedback
2006-03-10 13:27 colorblind Resolution fixed => reopened
2006-03-10 13:27 colorblind Note Added: 0000113
2006-03-10 19:42 tvo Status feedback => resolved
2006-03-10 19:42 tvo Resolution reopened => fixed
2006-03-10 19:42 tvo Note Added: 0000114
+Issue History