[misc] upgrading to phpbb 3.3.1 aka the upgrade hell

[misc] upgrading to phpbb 3.3.1 aka the upgrade hell

Happenin' news on what is happening in the community. Content releases, new tutorials, other cool stuff.
Post Reply
abma
Spring Developer
Posts: 3655
Joined: 01 Jun 2009, 00:08

[misc] upgrading to phpbb 3.3.1 aka the upgrade hell

Post by abma »

today i wanted to upgrade phpbb to the current version as it closes some security related issues.

I downloaded the update file and expanded it to the webserver. Then i opened the installer but it failed with "php 7.0 is not supported..."... fu..!

As the debian system which springrts.com runs is quiet old, i decided to upgrade it from version 9 (stretch) to version 10 (buster) so i could easily install php7.3, too:

edit /etc/apt/sources.list, replace "stretch" with "buster", run apt update && apt upgrade and wait a long time, answer some questions with "yes, please automatically restart the service", "yes, please overwrite the custom config file with the default version": done!

to finally update phpbb i had to install php7.3 and the required modules and restart apache.

then the update of phpbb finally worked, i logged in to the admin page and then:

syntax error in "phpbb/ext/anavaro/postlove/config/services.yml"...

shh...! i tried to fix it manually and: success it seems to work: https://github.com/spring/spring-websit ... 5c64fbf5d9

so, success!

as its to late i have to stop at this stage, but there possible is a lot of stuff left:

- manual data migration from postgresl 9.6 to postgres 11
- apt dist-upgrade
- restart services and see which one broke:
- buildbot master
- lobby server
- matrix servers + services
- rapid services: recompile pr-downloader / RapidTools used for repos.springrts.com
- wsgi services for replays.springrts.com
- mumble

and finally reboot server (up 673 days, 21:43)!

so, if you found some problem already, please post and i try to fix this asap!

thanks for reading! :-)
abma
Spring Developer
Posts: 3655
Joined: 01 Jun 2009, 00:08

Re: [misc] upgrading to phpbb 3.3.1 aka the upgrade hell

Post by abma »

sadly the phpBB extension postlove seems not compatible to phpBB any more: i had disabled it.
User avatar
FLOZi
MC: Legacy & Spring 1944 Developer
Posts: 6194
Joined: 29 Apr 2005, 01:14

Re: [misc] upgrading to phpbb 3.3.1 aka the upgrade hell

Post by FLOZi »

Upgrading phpbb is a nightmare indeed. tbh I think this is true for all bb software.
MasterBel
Posts: 214
Joined: 18 Mar 2018, 07:48

Re: [misc] upgrading to phpbb 3.3.1 aka the upgrade hell

Post by MasterBel »

Hey, thanks for the upgrade but also it would be really nice if we have warning for things like this. ATM, suddenly something breaks, then we all try to work out how to fix it, until it comes back online and "Btw that was all planned, you can stop panicking now".

TLDR; please give us at least vague warning of when upgrades like this are gonna happen
User avatar
Silentwings
Moderator
Posts: 3668
Joined: 25 Oct 2008, 00:23

Re: [misc] upgrading to phpbb 3.3.1 aka the upgrade hell

Post by Silentwings »

- restart services and see which one broke:
- lobby server
Seems OK, systemctl restart worked. (Also, lobbyserver uptime was 112 days, longest for a long while.)
abma
Spring Developer
Posts: 3655
Joined: 01 Jun 2009, 00:08

Re: [misc] upgrading to phpbb 3.3.1 aka the upgrade hell

Post by abma »

MasterBel wrote: 10 Sep 2020, 04:49 Hey, thanks for the upgrade but also it would be really nice if we have warning for things like this. ATM, suddenly something breaks, then we all try to work out how to fix it, until it comes back online and "Btw that was all planned, you can stop panicking now".

TLDR; please give us at least vague warning of when upgrades like this are gonna happen
What suddenly broke in this case? Theoretically only the website wasn't available for a short time which shouldn't lead to panic mode. All other stuff should have happened after this post.

Its really difficult to do such huge changes with the few time i have. I want to do stuff, not to write about stuff i maybe will do.

Also there is no possibility to contact all persons before such changes. Where should i inform all people? It would be sth. like "in two weeks there will be an update", but thats sadly not possible when you administrate stuff in your spare time with a full time job.
abma
Spring Developer
Posts: 3655
Joined: 01 Jun 2009, 00:08

Re: [misc] upgrading to phpbb 3.3.1 aka the upgrade hell

Post by abma »

Silentwings wrote: 10 Sep 2020, 05:36
- restart services and see which one broke:
- lobby server
Seems OK, systemctl restart worked. (Also, lobbyserver uptime was 112 days, longest for a long while.)
Nice + good work! 8)
MasterBel
Posts: 214
Joined: 18 Mar 2018, 07:48

Re: [misc] upgrading to phpbb 3.3.1 aka the upgrade hell

Post by MasterBel »

abma wrote: 10 Sep 2020, 22:47 Its really difficult to do such huge changes with the few time i have. I want to do stuff, not to write about stuff i maybe will do.
I'm thinking of something simple like "Sometime in the next month, I'm hoping to run an upgrade. If the server goes down, it's probably that. It should be up within a few hours of going down."

I don't mean to cause an inconvenience (but rather solve them), so whatever you feel most practical would be appreciated.
raaar
Metal Factions Developer
Posts: 874
Joined: 20 Feb 2010, 12:17

Re: [misc] upgrading to phpbb 3.3.1 aka the upgrade hell

Post by raaar »

although I understand Abma's point of view: time and willpower is limited and spending time explaining things and convincing others can be draining...I agree with Masterbel that there should be at least some kind of early warning.

It's been a recurring issue on the past year that changes broke important stuff like downloads, the ability of new players to get registered easily, or the replays site.

Springfiles still has broken image references after the changes it went through.
User avatar
ThinkSome
Posts: 346
Joined: 14 Jun 2015, 13:36

Re: [misc] upgrading to phpbb 3.3.1 aka the upgrade hell

Post by ThinkSome »

I think that Abma should find a successor for himself or at least someone who can do all that he can do, because this is not sustainable.
User avatar
Silentwings
Moderator
Posts: 3668
Joined: 25 Oct 2008, 00:23

Re: [misc] upgrading to phpbb 3.3.1 aka the upgrade hell

Post by Silentwings »

I suggest less thought about warning notifications and more thought about bus factors - which imo are dangerously low for the engine & its supporting infra. Sadly it's unreasonable to expect abma to "find" a successor for himself & also unlikely that any single person could manage so much stuff without at least a year or two of PRs/working themselves up to it. Harsh reality of dependencies: when time/numbers are short its down to the people who use the stuff to step in & learn some new stuff - or suffer the breakages.
abma
Spring Developer
Posts: 3655
Joined: 01 Jun 2009, 00:08

Re: [misc] upgrading to phpbb 3.3.1 aka the upgrade hell

Post by abma »

ThinkSome wrote: 13 Sep 2020, 15:37 I think that Abma should find a successor for himself or at least someone who can do all that he can do, because this is not sustainable.
viewtopic.php?f=38&t=33804
abma
Spring Developer
Posts: 3655
Joined: 01 Jun 2009, 00:08

Re: [misc] upgrading to phpbb 3.3.1 aka the upgrade hell

Post by abma »

viewtopic.php?t=41886

"reboot of springrts.com server tomorrow, Fri Sep. 18. 2020 at 10:30 GMT+2"
gajop
Moderator
Posts: 3040
Joined: 05 Aug 2009, 20:42

Re: [misc] upgrading to phpbb 3.3.1 aka the upgrade hell

Post by gajop »

abma wrote: 14 Sep 2020, 12:26
ThinkSome wrote: 13 Sep 2020, 15:37 I think that Abma should find a successor for himself or at least someone who can do all that he can do, because this is not sustainable.
viewtopic.php?f=38&t=33804
Can you provide some links to where the springfiles server code is? (both frontend and backend)

In particular I'm looking for whatever repository is in charge of things like:
1) registering and logging into springfiles accounts
2) backend for downloading rapid content via pr-downloader
3) backend for downloading engines, and if separate, the system that marks the appropriate OS for engine builds.

So far I think upq might be related to some of these parts but I don't think it's the full story.
abma
Spring Developer
Posts: 3655
Joined: 01 Jun 2009, 00:08

Re: [misc] upgrading to phpbb 3.3.1 aka the upgrade hell

Post by abma »

gajop wrote: 18 Sep 2020, 00:24 1) registering and logging into springfiles accounts
thats drupal 6 :? there is no code to show
gajop wrote: 18 Sep 2020, 00:24 2) backend for downloading rapid content via pr-downloader
basicly https://github.com/springfiles/upq/blob ... pidsync.py
gajop wrote: 18 Sep 2020, 00:24 3) backend for downloading engines, and if separate, the system that marks the appropriate OS for engine builds.
https://github.com/springfiles/upq/blob ... onfetch.py
+ https://github.com/spring/spring/blob/d ... t/list.php


i started to heavily simplify the code, but the "big purge" didn't start yet: https://github.com/springfiles/upq/blob ... sf_sync.py


when you want to continue on this, create some upload page, which checks lobby auth and calls download_and_add_file() with the uploaded file. the next step should be some nicer frontend for http://api.springfiles.com/ IMHO, a simple example exists: http://api.springfiles.com/newindex.html
User avatar
ivand
Posts: 197
Joined: 27 Jun 2007, 17:05

Re: [misc] upgrading to phpbb 3.3.1 aka the upgrade hell

Post by ivand »

Not that I care too much, but it seems like the "like" functionality is gone.

The amount of the new content on the forum is very scarce these days, the "likes" used to partially make up for the lack of activity.
User avatar
very_bad_soldier
Posts: 1387
Joined: 20 Feb 2007, 01:10

Re: [misc] upgrading to phpbb 3.3.1 aka the upgrade hell

Post by very_bad_soldier »

abma wrote: 09 Sep 2020, 09:48 sadly the phpBB extension postlove seems not compatible to phpBB any more: i had disabled it.
User avatar
ivand
Posts: 197
Joined: 27 Jun 2007, 17:05

Re: [misc] upgrading to phpbb 3.3.1 aka the upgrade hell

Post by ivand »

Indeed, sorry for being blind.
Sad then, one extra reason to stay on the evil (Discord) side.
User avatar
AF
AI Developer
Posts: 20679
Joined: 14 Sep 2004, 11:32

Re: [misc] upgrading to phpbb 3.3.1 aka the upgrade hell

Post by AF »

Notes:

- There's an apt package that puts apt update and upgrades in the background. For minor package updates this should save time
- PHP 8.0 is out later this year, and PHP 7.4 has been out for a while, given that 7.3 is EOL December 7th 2021 we might as well future-proof with PHP 7.4
- Did composer not report the PHP incompatibility? What about PHPCompat? There is a lot of tooling for this that's all automatic, if composer isn't being used then this should at least scan and tell you the compatibility issues: https://github.com/PHPCompatibility/PHPCompatibility
- I would advise using the Ondrej PHP packages for Debian and Ubuntu
Post Reply

Return to “Community Blog”