SpringLobby 0.270 released! - Page 15

SpringLobby 0.270 released!

Moderators: Moderators, Lobby Developers

abma
Spring Developer
Posts: 3598
Joined: 01 Jun 2009, 00:08

Re: SpringLobby 0.268 released!

Post by abma »

released 0.268
- add support for showing client versions per user
- remove cpu info support
- fix #894 (unhandled exception & other errors when typing LEAVE commands into the server window)
- fix #920 (fix start button logic)
- implement multi version support for relayhost
- lobby protocol updates
- update prdownloader: fix rapid caching check / fix rapid downloads with very small repos (<8 files)
- migrate website to https://springlobby.springrts.com/
2 x

abma
Spring Developer
Posts: 3598
Joined: 01 Jun 2009, 00:08

Re: SpringLobby 0.269 released!

Post by abma »

released 0.269:

- don't send deprecated compatibility flags to lobby server
- fix #936: missing file in archive
- update a lot of links to new homepage https://springlobby.springrts.com/
3 x

abma
Spring Developer
Posts: 3598
Joined: 01 Jun 2009, 00:08

Re: SpringLobby 0.270 released!

Post by abma »

released 0.270:
- add newbie (default) gui which hides a lot of advanced settings: edit->lobby preferences -> general -> gui user level
- improve error handling
- use https for rapid downloads
- use <filesystem> in several places, this requires gcc >= 8
- fix #922: fix logfile cannot be opened on fresh install
- fix #297: add "download engine" to replay context menu
- fix #284: rejoin last battle on reconnect
- fix #898: no engine found for some demos
- show infolog.txt on crash / offer to open bug report link
- convert dialogs to wxformbuilder: ConnectWindow, HostBattleDialog
- grey out empty battles in battlelist
- fix finished downloads not reporting 100% of state in download tab
- fix #940: connecting hangs to server when tls 1.3 is used
- grey out battles with no players in battle list
- convert some dialogs to wxformbuilder
3 x

User avatar
FLOZi
MC: Legacy & Spring 1944 Developer
Posts: 6180
Joined: 29 Apr 2005, 01:14

Re: SpringLobby 0.270 released!

Post by FLOZi »

https://i.imgur.com/riqVZ8C.png

Got one of these for each game I have (quite a few!) when S44 autohost updated to new version and I started download as prompted.

edit: a few hours later, tried to update again, same issue plus

https://i.imgur.com/pZaLNpN.png

and

https://i.imgur.com/t5qeycl.png
0 x

abma
Spring Developer
Posts: 3598
Joined: 01 Jun 2009, 00:08

Re: SpringLobby 0.270 released!

Post by abma »

thanks for reporting, both should be fixed by: https://github.com/spring/pr-downloader ... 6fff696c61
1 x

BratE9000
Posts: 4
Joined: 14 Apr 2020, 16:32

Re: SpringLobby 0.270 released!

Post by BratE9000 »

After completing update from .268 to .270, everything seemed to work fine. However, now I cannot connect to server. The "Connect to server" pop-up window says "Already logged in." Tried logging in and out, restart, etc.

Windows 10, used automatic install from SpringLobby prompt and downloaded and ran installer.

Any suggestions?

Thanks!
0 x

abma
Spring Developer
Posts: 3598
Joined: 01 Jun 2009, 00:08

Re: SpringLobby 0.270 released!

Post by abma »

BratE9000 wrote:
24 Jun 2020, 23:11
After completing update from .268 to .270, everything seemed to work fine. However, now I cannot connect to server. The "Connect to server" pop-up window says "Already logged in." Tried logging in and out, restart, etc.
this usually happens when there is an other springlobby session still open. did you check the taskmanager if there is a springlobby.exe process still running?
0 x

Post Reply

Return to “SpringLobby Client”