Segfault when loading unitsync (PerlUnitSync not regenerated)

Segfault when loading unitsync (PerlUnitSync not regenerated)

SpringRTS Perl Autohost for Dedicated Server

Moderators: Moderators, Lobby Developers, SPADS AutoHost

Post Reply
User avatar
Error323
AI Developer
Posts: 237
Joined: 28 Nov 2006, 16:46

Segfault when loading unitsync (PerlUnitSync not regenerated)

Post by Error323 » 20 Sep 2010, 12:29

Hey Bibim,

Just updated to the latest spads unstable release and I'm having problems with getDefaultModOptions.pl, giving me a segmentation fault. Spring itself is functioning normally.

Code: Select all

fhuizing@jarvis ~/programs/spads $ ./getDefaultModOptions.pl -o etc/battlePresets.conf 
LogOutput initialized.
Spring 0.82.5.1 (Headless Unitsync)
Build date/time: Sep 11 2010 21:57:15
Available log subsystems: ArchiveScanner, VFS-detail, VFS, unitsync
Enabled log subsystems: unitsync
Enable or disable log subsystems using the LogSubsystems configuration key
  or the SPRING_LOG_SUBSYSTEMS environment variable (both comma separated).
Using read-write data directory: /home/fhuizing/.spring/
Using read-only data directory: /usr/local/share/games/spring/
Scanning: /usr/local/share/games/spring/base
Scanning: /home/fhuizing/.spring/maps
Scanning: /home/fhuizing/.spring/mods
unitsync: loaded, 0.82.5.1 (Headless Unitsync)
Using read-write data directory: /home/fhuizing/.spring/
Using read-only data directory: /usr/local/share/games/spring/
Scanning: /usr/local/share/games/spring/base
Scanning: /home/fhuizing/.spring/maps
Scanning: /home/fhuizing/.spring/mods
unitsync: initialized, 0.82.5.1 (Headless Unitsync)
unitsync: joining
unitsync: removing all archives
Segmentation fault
Are there any problems? Plz help, thanks :)
0 x

User avatar
bibim
Lobby Developer
Posts: 901
Joined: 06 Dec 2007, 11:12

Re: SPADS AutoHost beta release

Post by bibim » 20 Sep 2010, 18:38

I recommend not using the "unstable" release of SPADS, because during testing periods it is unstable and may crash. However getDefaultModOptions should work so that doesn't explain your problem...

Also, if you plan to use the getDefaultModOptions output directly to build your battlePresets.conf configuration file, I recommend using the "-s" flag so that it will produce output directly compatible with SPADS (it automatically adds "description", "resetmodoptions", "disabledunits" and "startpostype" parameters).

Do you have write access to your Spring data directory (cf yuritch's problem, in your case it seems to be "/home/fhuizing/.spring/") ?
Does SPADS work anyway ?
Did you (re)generate the PerlUnitSync module for spring 0.82.5 ? ("./spadsInstaller.pl -g")
Can you check the unitsync library used by PerlUnitSync module: "ldd PerlUnitSync.so | grep unitsync" ?
It seems it is the unitsync library which is segfaulting. If it's not a filesystem access rights problem, maybe it is a specific mod or map which makes it crash ? Did you try keeping only 1 mod and 1 map to see if it still crashes ?
0 x

User avatar
Error323
AI Developer
Posts: 237
Joined: 28 Nov 2006, 16:46

Re: SPADS AutoHost beta release

Post by Error323 » 20 Sep 2010, 18:56

Oh forgot that regeneration is also required.
Thanks! Btw which release do you recommend?

now getting this error:
ERROR - [SPADS] Unable to retrieve hashcode of mod "XTA_9_641_beta"
0 x

User avatar
bibim
Lobby Developer
Posts: 901
Joined: 06 Dec 2007, 11:12

Re: SPADS AutoHost beta release

Post by bibim » 21 Sep 2010, 09:49

Error323 wrote:now getting this error:
ERROR - [SPADS] Unable to retrieve hashcode of mod "XTA_9_641_beta"
I guess you used string "XTA_9_641_beta" as modName in your hosting settings instead of "XTA 9.641 beta".
"XTA_9_641_beta" isn't a mod name, it's just the default name of the battle preset generated by getDefaultModOptions for mod "XTA 9.641 beta".
If you want to find real unitsync mod names which can be used for modName hosting setting, you can open your achive cache file (in the "cache" subdirectory of your data directory).
0 x

Garfonso
Posts: 4
Joined: 18 Feb 2014, 16:35

Re: SPADS AutoHost

Post by Garfonso » 22 May 2014, 19:12

SPADS segfaults on my when loading libunitsync after I upraded my system to Ubuntu Trusty (was Saucy before). Any ideas what could be wrong?

Spring itself still runs fine.

Perl version is:
This is perl 5, version 18, subversion 2 (v5.18.2) built for x86_64-linux-gnu-thread-multi
Is that the issue? Or any additional library I'm missing?

Spring Version is 0.96.

Hm.. Nevermind.. I searched a bit more and discovered PerlUnitSync.so which had to be regenerated using ./spadsInstaller.pl -g

Sorry for the fuss.
0 x

Post Reply

Return to “SPADS AutoHost”