My steam story

My steam story

Forboding Angel's vision of a flexible, story-driven universe drawing heavily from classic game design and modern artistic sensibilities.

Moderators: Moderators, Content Developer

Post Reply
User avatar
Jools
XTA Developer
Posts: 2771
Joined: 23 Feb 2009, 16:29

My steam story

Post by Jools » 10 Apr 2014, 13:44

I tried to install Evo the steam way, and see just what probvlems people run into. It turned out that we can hardly call thse people impatient. This is what happened:

1. Install from steam

Image

I decided to create a steam library on another hard drive than C, because C is a SSD drive. Fine, steams says also that "all files for this game will now be downloaded through steam". We know that's not quite so.

The problem is also the space requirements: 80 Mb is indeed what the size of my steam library will end up to be, but there is no mention of the 650 Mb that will end up in "My Documents/My Games/Spring" library on my T: hard drive. Also, when you remove evo from your steam library, it asks if you want to remove all local files from your computer. But these 650 Mb are not included there.

Also, why not put the springData files in the steam library? That's what was asked by the user, so I would expect things to go there.

2. Playing the game

It says use "create multiplayer game" instead of single player game. Fine, i do that.

Image

The default selection now is not Evolution RTS, it is Zero-K. I click "Show Advanced Options" and it shows the game to be zk:stable but with Spring engine 96.0. This will obviously not work.

(Btw, I looked also at the XTA defaults, the default is xta:latest, which spawns 9.728, but if you change it to xta:stable you get the most recent one).

I change to Evolution RTS and host a multiplayer game. This time it actually works, lobby says I'm synced and all, it's just a little hard to find the unspec button even for me, and before you add an AI you must add a team for it. But it downloads everything just fine, but when I try to launch the game it says map is not found, even if it was shown in battle room.

Also, my antivirus asks each time if I want to allow spring.exe, even if I choose to allow it permanently. Does the weblobby alter the executable somehow each time?

Last time I tried to launch spring from weblobby the antivirus window (I use FS-CS) got stuck under the spring's black screen-fill, before the game starts. It made the window inaccessible, and then windows 7 considers spring non-responsive and makes the black screen-fill grey. I could not even access taskmanager or process explorer, or command line to kill the task. Only solution was to reboot computer. The black filling of the screen appeared above every system window that you could use to take control of computer.

I wrote this to try to understand what steam users go through. It's not meant to be criticism of any spring software used, but I hope it helps to highlight some issues we have.
0 x

User avatar
Jools
XTA Developer
Posts: 2771
Joined: 23 Feb 2009, 16:29

Re: My steam story

Post by Jools » 10 Apr 2014, 15:31

Solutions:

* Would it be possible to write in the steam install that the install is just a lobby, and that additional files will be downloaded to play the game?

* Remove the black screen overlay which happens when unitsync is running and before game actually starst to load. It solves a lot of problems.

About weblobby: I don't know if that's the problem actually. Other lobbies have just as many problems. I also tried the nota-package, which downloads everything nicely, but I also had problems with it. The solution was to delete my cache, so yeah that's probably my fault. Maybe my setup is also more complicated than that of average users: i have moved "My Documents" away from the C: drive to save space on it.

But it is understandably confusing that you have to first download a lobby, and then download all other stuff. Would it not be possible to include in weblobby stuff like the 96.0 engine, like 5 maps, and the evolution RTS mod?
0 x

User avatar
SinbadEV
Posts: 6475
Joined: 02 May 2005, 03:56

Re: My steam story

Post by SinbadEV » 10 Apr 2014, 15:44

-I can't even run weblobby on one of my computers because the security software I have thinks the version of Java it's using is "unsafe".-

Clearly I'm a moron.
Last edited by SinbadEV on 10 Apr 2014, 16:28, edited 2 times in total.
0 x

User avatar
Anarchid
Posts: 1372
Joined: 30 Nov 2008, 04:31

Re: My steam story

Post by Anarchid » 10 Apr 2014, 16:24

You still run weblobby in a browser?
zk:stable but with Spring engine 96.0. This will obviously not work
Actually zk works with 96, though what zk:stable is doing in that box is a good question.
0 x

User avatar
zwzsg
Kernel Panic Co-Developer
Posts: 7003
Joined: 16 Nov 2004, 13:08

Re: My steam story

Post by zwzsg » 10 Apr 2014, 19:47

Jools wrote:Btw, I looked also at the XTA defaults, the default is xta:latest, which spawns 9.728, but if you change it to xta:stable you get the most recent one.
I am glad to hear Kernel Panic is not the only mod to suffer from the stable vs latest issue:
http://springrts.com/phpbb/viewtopic.ph ... 4&start=16
0 x

Post Reply

Return to “Evolution RTS”