Issues with latest spring development version

Issues with latest spring development version

Hearken back to the days of yore and enjoy the first major Spring module!

Moderators: Moderators, Content Developer

Post Reply
User avatar
Jools
XTA Developer
Posts: 2814
Joined: 23 Feb 2009, 16:29

Issues with latest spring development version

Post by Jools »

Here are some issues I have managed to isolate:

Gadgets:
- unit_disable_buildoptions: spams Warning: [ReturnNil] deprecated field when creating a lab

- unit_buildspeed: spams Warning: [ReturnFalse] deprecated field on load and prevents construction from progressing. Fixed to remove itself on error.

Widgets:
- DGun Stall assist: spams Warning: [ReturnFalse] deprecated field on firing a weapon
- Immobile Builder: spams Warning: [ReturnFalse] deprecated field on firing a weapon
- FactoryGuard XTA: spams Warning: [ReturnFalse] deprecated field on creating an unit from a lab

Other:

* Annihilator shoots before it has aimed. It shoots the first beam before the turret has focused on target, and the first beam goes to a random direction, sometimes it hits self.
- Also applies for penetrator
User avatar
Jools
XTA Developer
Posts: 2814
Joined: 23 Feb 2009, 16:29

Re: Issues with latest spring development version

Post by Jools »

List of deprecated fields:

Code: Select all

builder
canCrash
canDGun
canHover
drag
extractSquare
floater
isCommander
maxSlope
moveData
type
raaar
Metal Factions Developer
Posts: 943
Joined: 20 Feb 2010, 12:17

Re: Issues with latest spring development version

Post by raaar »

Jools wrote:Here are some issues I have managed to isolate:

* Annihilator shoots before it has aimed. It shoots the first beam before the turret has focused on target, and the first beam goes to a random direction, sometimes it hits self.
- Also applies for penetrator
shooting before having locked on target is probably due to sweepfire being enabled by default
User avatar
Deadnight Warrior
Posts: 183
Joined: 08 Jun 2009, 17:59

Re: Issues with latest spring development version

Post by Deadnight Warrior »

I'm already working on the warning spam with the dev version, but still can't clean them all. Every time you press "Stop" there's a warning that I can't pinpoint.
Jools wrote:- unit_buildspeed: spams Warning: [ReturnFalse] deprecated field on load and prevents construction from progressing. Fixed to remove itself on error.
That's not a fix, I have it fixed locally, just havent commited. What you did maybe let's you play, but you efectivly disabled the gadget, always.

About BeamLasers, yes the weirdeness about firing is due to sweepfire being enabled by default, which also has other issues, like beam pissing all over the place if the target is too far away from current aim. (Aim at max range, then just in front of unit)
User avatar
Jools
XTA Developer
Posts: 2814
Joined: 23 Feb 2009, 16:29

Re: Issues with latest spring development version

Post by Jools »

Just to update, all these issues are fixed in svn (except the anni thing, which wasn't a bug, it was a testing feature).
Post Reply

Return to “XTA”

cron