Error emerge on gentoo

Error emerge on gentoo

Discuss everything related to running Spring on your chosen distribution of Linux.

Moderator: Moderators

Post Reply
Yarra
Posts: 2
Joined: 12 Mar 2016, 09:41

Error emerge on gentoo

Post by Yarra » 12 Mar 2016, 09:48

I try install by manual.
But i have error:

Code: Select all

-- Found Java: /usr/bin/java (found version "1.7.0.95") 
CMake Error at /usr/share/cmake/Modules/FindPackageHandleStandardArgs.cmake:148 (message):
  Could NOT find JNI (missing: JAVA_AWT_LIBRARY JAVA_JVM_LIBRARY
  JAVA_INCLUDE_PATH JAVA_INCLUDE_PATH2 JAVA_AWT_INCLUDE_PATH)
Call Stack (most recent call first):
  /usr/share/cmake/Modules/FindPackageHandleStandardArgs.cmake:388 (_FPHSA_FAILURE_MESSAGE)
  /usr/share/cmake/Modules/FindJNI.cmake:287 (FIND_PACKAGE_HANDLE_STANDARD_ARGS)
  AI/Interfaces/Java/CMakeLists.txt:255 (FIND_PACKAGE)


-- Configuring incomplete, errors occurred!
How to fix it?
0 x

hokomoko
Spring Developer
Posts: 585
Joined: 02 Jun 2014, 00:46

Re: Error emerge on gentoo

Post by hokomoko » 12 Mar 2016, 10:02

in CMakeCache.txt set AI_TYPES to NATIVE or to NONE
0 x

Yarra
Posts: 2
Joined: 12 Mar 2016, 09:41

Re: Error emerge on gentoo

Post by Yarra » 12 Mar 2016, 10:08

how to do it, if i use emerge?

It's official ebuild from spring git
0 x

MetalSucker
Posts: 98
Joined: 22 Sep 2014, 20:29

Re: Error emerge on gentoo

Post by MetalSucker » 12 Mar 2016, 16:58

Edit: turns out there's a compile problem with springlobby too, class wxDir has no member Close, wxGTK 2.9.4.1-r1, it builds with 3.0, but docs call for 2.9+

Here's an ebuild that worked for me for the latest springlobby, didn't run it but it did build, I had to eselect wxwidgets to 3.0 before though, it's based on the latest available springlobby ebuilds but with wx explicitly requiring the 3.0 slot and without the patch in the old ones, save it to springlobby-0.243.ebuild in games-util/springlobby in whatever local repo you might have, and then "repoman manifest"

Code: Select all

# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $

EAPI=3

inherit cmake-utils eutils flag-o-matic games

DESCRIPTION="lobby client for spring rts engine"
HOMEPAGE="http://springlobby.info"
SRC_URI="http://www.springlobby.info/tarballs/${P}.tar.bz2"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
RESTRICT="nomirror"
IUSE="+sound debug libnotify gstreamer"


RDEPEND="
        dev-libs/boost
	x11-libs/wxGTK:3.0
	net-misc/curl
	libnotify? (    x11-libs/libnotify )
	sound? (
			media-libs/openal
			media-libs/libvorbis
			media-libs/flac
			media-sound/mpg123
			media-libs/alure
	)
	gstreamer? (    media-libs/gstreamer )
"

DEPEND="${RDEPEND}
	>=dev-util/cmake-2.6.0
"

src_unpack() {
	unpack ${A}
	cd ${S}
	#epatch "${FILESDIR}/${P}-wx-config.patch"
}

src_configure() {
	if ! use sound ; then
		mycmakeargs="${mycmakeargs} -DOPTION_SOUND=OFF"
	fi
	if use gstreamer ; then
		mycmakeargs="${mycmakeargs} -DGSTREAMER=ON"
	fi

	mycmakeargs="${mycmakeargs} -DAUX_VERSION=(Gentoo,$ARCH) -DCMAKE_INSTALL_PREFIX=/usr/games/"
	cmake-utils_src_configure
}

src_compile () {
	cmake-utils_src_compile
}

src_install() {
	cmake-utils_src_install
	prepgamesdirs
	# bad
	dodir /usr/share/games/icons/hicolor/scalable/apps/
	mv ${D}/usr/games/share/icons/hicolor/scalable/apps/springlobby.svg ${D}/usr/share/games/icons/hicolor/scalable/apps/springlobby.svg
	rm ${D}/usr/share/games/pixmaps/ -fr
	dodir /usr/share/games/applications/
	mv ${D}/usr/games/share/applications/springlobby.desktop ${D}/usr/share/games/applications/springlobby.desktop
	rm ${D}/usr/games/share/applications/ -fr
	dodir /etc/env.d/
	echo 'XDG_DATA_DIRS="/usr/share/games"' >> ${D}/etc/env.d/99games
}

----Earlier post:

Generally, you don't want to emerge spring, you want to emerge one of the lobbies. They, in turn, download the already compiled spring engine versions - there are several versions needed, no reason to compile them. (think firefox vs firefox-bin as far as emerge goes, but the lobby will handle the downloads, not portage)

https://gpo.zugaina.org/games-util/springlobby

https://github.com/springlobby/springlo ... all#Gentoo


It boils down to adding an ebuild in a local portage overlay, it's easy if you're familiar with gentoo, here's the official doc:

https://wiki.gentoo.org/wiki/Overlay/Local_overlay

If the versions in the overlays are not the current version of springlobby, just copy the latest ebuild and change the version name to 0.243, it will automagically download and compile the tarball from
http://springlobby.info/tarballs/spring ... 43.tar.bz2

I can't boot up my gentoo now and it's fairly outdated, but it just worked, the dependencies don't really change between versions.

You could also check out:
http://weblobby.springrts.com/
It's already compiled.


wx 2.9:

Code: Select all

/springlobby/springlobby-0.243/src/utils/slpaths.cpp:532:8: error: ‘class wxDir’ has no member named ‘Close’
  dirit.Close();
        ^
src/CMakeFiles/springlobby.dir/build.make:3475: recipe for target 'src/CMakeFiles/springlobby.dir/utils/slpaths.cpp.o' failed
make[2]: *** [src/CMakeFiles/springlobby.dir/utils/slpaths.cpp.o] Error 1
0 x

Post Reply

Return to “Linux”