[Watchdog] Hang detection triggered for Spring 89.0 (OMP).

[Watchdog] Hang detection triggered for Spring 89.0 (OMP).

Discuss everything related to running Spring on your chosen distribution of Linux.

Moderator: Moderators

Post Reply
User avatar
Pithikos
Posts: 146
Joined: 26 Dec 2008, 14:26

[Watchdog] Hang detection triggered for Spring 89.0 (OMP).

Post by Pithikos »

I can't play spring. I play for some minutes but then everything freezes and I get a bunch of errors like:

Code: Select all

Error: Stacktrace (main):
Error:   (Note: This stacktrace is not 100% accurate! It just gives an impression.)
Error:   Unable to create stacktrace
Error: Stacktrace (audio):
Error:   No Stacktraces for non-MainThread.
Warning: [Watchdog] Hang detection triggered for Spring 89.0 (OMP).
Warning:   (in thread: main)
Error: Stacktrace (main):
Error:   (Note: This stacktrace is not 100% accurate! It just gives an impression.)
This happens after I upgraded to 12.04 Ubuntu.
Attachments
infolog.txt
(52.11 KiB) Downloaded 32 times
User avatar
Pithikos
Posts: 146
Joined: 26 Dec 2008, 14:26

Re: [Watchdog] Hang detection triggered for Spring 89.0 (OMP

Post by Pithikos »

Lowering the "Maximum Simultaneously Sounds" to 40 at Spring Settings seems to solve this..
varikonniemi
Posts: 447
Joined: 03 Jul 2011, 11:54

Re: [Watchdog] Hang detection triggered for Spring 89.0 (OMP

Post by varikonniemi »

Search around the forums for how to disable eaxrevb which seems to be broken in current spring. Could be the same problem you are having and in that case i think your method just alleviates the problem, but does not tackle the root cause.
User avatar
Pithikos
Posts: 146
Joined: 26 Dec 2008, 14:26

Re: [Watchdog] Hang detection triggered for Spring 89.0 (OMP

Post by Pithikos »

varikonniemi wrote:Search around the forums for how to disable eaxrevb which seems to be broken in current spring. Could be the same problem you are having and in that case i think your method just alleviates the problem, but does not tackle the root cause.
I had already all effects disabled(for normal user). Not sure if I should disable them for root as well? :?
Post Reply

Return to “Linux”