Spring Lobby crashes - Page 2

Spring Lobby crashes

Discuss everything related to running Spring on your chosen distribution of Linux.

Moderator: Moderators

User avatar
sillynanny
Posts: 125
Joined: 20 Jun 2008, 14:26

Re: Spring Lobby crashes

Post by sillynanny » 06 Oct 2011, 12:07

Lol forboding you are so much fail.
Forboding Angel wrote:Apparently you aren't aware of who you are talking to. No matter.
Sorry I don't watch much TV.
Forboding Angel wrote: Present Tense
...and I can tell you that springlobby is a buggy piece of shit and has been for many years...
Past Tense
You couldn't go into #main without hearing grumbling about springlobby. I just kept quiet and xkilled when needed. But when I hear people shit on wxwidgets, I have to intervene.
The tense people use when they speak, Forb, reflects Time. The first quote happened in June, and that is why we use the past tense when referring to it days ago. It's not my fault the thread got necroed back to life, but you should pay more attention so you don't look like a retard.
Forboding Angel wrote:Have any of these glorious apps that you have designed with wxwidgets been cross platform? From everything I understand wx is fine for nix, but your precious wxwidgets sucks dick in winbloze, hence many of the issues in SL. Fix one bug and another comes out of nowhere for no goddamn good reason. You might be able to appreciate how exhausting that would be.
All of the apps I have designed in wxwidgets are cross platform. I mean, it's hard to make them platform specific using wxwidgets. You understand little if you think wxwidgets is good for nix only. Wxwidgets (which is not mine, btw, I only use it) works perfectly in Windows. If you understood what wxwidgets even is, you would know it must translate all that it does to the OS specific API. Naturally, different implementations lead to different bug manifestations, but I have never found anything whatsoever that did not work in both windows and linux. More than that, the windows version of a wxwidgets app will run in linux with wine, perfectly, which is hillarious even if not necessary.

Basically, bad developers blame the tools. Man up.

Now if you think wxwidgets will make a noob into a cross-platform programmer, then you will find why you must mind string encoding, object destruction and other walls you might be banging your head in to.
Forboding Angel wrote: However, that said, SL is pretty solid really. I haven't had sl crash in a very long time. Perhaps you're "Doin' it rong".

In the meantime, stop being a self righteous buffoon, and help develop SL. The fact that it is wxwidgets means that your help can be useful.

SL happens the be made by two guys. Most of the shit around here is one man projects, and replies like yours are not motivating, they just serve to piss everyone off.
Yeah SL is better lately. We even agree on that, and if you bothered to read the dates you wouldn't have made even more of a fool of yourself. That doesn't change the fact that it was buggy for a long long time.
Forboding Angel wrote: Imo, you deserve a tempban for being a dick.

It is possible to dissent and be respectful.
You actually wrote these two sentences in sequence lol.
Forboding Angel wrote: Those of us who actually work with the engine around here get more latitude because we aren't just random pricks off the street with 0 knowledge bitching about something just to bitch.

Talk to Koshi. Maybe you could even help with SASI (even tho SASI is qt, which is vastly superior when you're doing cross platform involving winbloze).
Well, out of arguments, out of appeal to authority, out of sync with facts, out of ban requests. I hope you will shut up now.
Last edited by sillynanny on 06 Oct 2011, 12:19, edited 1 time in total.
0 x

User avatar
hoijui
Former Engine Dev
Posts: 4342
Joined: 22 Sep 2007, 09:51

Re: Spring Lobby crashes

Post by hoijui » 06 Oct 2011, 12:13

now for real.. it sounds to me like it would be a piece of cake for you to fixup SL. If it were written the GUI framework that i know quite well, i would do it right away.
as it is on git, you do not even have to fear that your work goes unused, cause if it is better, then people will use it (even though i am sure that the SL devs would integrate it into their releases anyway).
0 x

User avatar
sillynanny
Posts: 125
Joined: 20 Jun 2008, 14:26

Re: Spring Lobby crashes

Post by sillynanny » 06 Oct 2011, 12:21

It is never a peace of cake to fix someone else's code. Knowing the tools is just a prerequisite.

I am sorry to disappoint you but I won't be contributing to SL in the short or medium term.
0 x

User avatar
Forboding Angel
Evolution RTS Developer
Posts: 14605
Joined: 17 Nov 2005, 02:43

Re: Spring Lobby crashes

Post by Forboding Angel » 08 Oct 2011, 11:56

You know your shit, why not contribute? You don't have any issue with complaining. From what I'm seeing you could really help bigtime. Why not spend a few hours or even a day if you could afford the time?

Yes I know, getting used to other people's code blows chunks, but Koshi and BrainDamage are competent and good guys, and I imagine you would have little trouble getting used to their coding styles.

You would be doing everyone here a ginormous solid by helping out. I'll even name a unit in Evolution RTS after you if you help BD and koshi out! What's not to like?

Back to the argument at hand, I should clarify a bit of what I was referring to, because in places you got the wrong idea:


Wrt who you are talking to... You mentioned me in a statement talking about how I didn't do anything with the engine or the lobby bla bla bla. If you know who I am, you would be well aware that that isn't the case.

The gui issues in SL stem from SL being wxwidgets (Afaik). In particular, the gui issues in windows. For example, not being able to use screen size percentages for window sizing and that sort of thing. From what I understand, the values must be static as a limitation to SL wrt wxwidgets. Amirong?
^^ That right there is one of the biggest issues in SL btw, particularly on windows ^^

To clarify, even though I didn't say it, I was referring to the gui related issues and bugs with SL on windows that typically don't present on linux (specifically ubuntu and related variants). From re-reading my post I can see how you would think that I was talking about wxwidgets in general. I should have been more specific, but often when I am following a train of thought in writing a long post, details like that get lost.

You were originally being a jerk/dick, can you really deny that? Especially when you're in such a unique position to be able to so drastically help out. As mentioned, BD and Koshi are very cool guys, at the very least having a chat with them would be very much worth the time.

Not gonna bother responding to the insults because tbh, I honestly don't really care (nor do I take them personally).

Synopsis, at least talk to BD and Koshi. Any assistance given to aforementioned people will result in a unit in Evolution RTS being named after you (whatever, it's not much, but it isn't nothing :-) ), and specificity added to what I was trying to say in previous posts. Not necessarily in that order.
0 x

cleanrock
Former Engine Dev
Posts: 115
Joined: 21 Feb 2009, 07:42

Re: Spring Lobby crashes

Post by cleanrock » 09 Oct 2011, 09:51

I started to locate this bug once but gave up pretty quick because this one is a bit tricky i think, its not a crash instead the graphics does not render properly and the amount of code was a bit overwhelming and i have not used wxwidgets much.
In the bug report i asked devs to reproduce the problem (just install springlobby on archlinux), but there was no visible interest.
FYI, I have contributed a perfomance fix for springlobby so fanboys dont start bashing me immediatley :).
0 x

User avatar
Forboding Angel
Evolution RTS Developer
Posts: 14605
Joined: 17 Nov 2005, 02:43

Re: Spring Lobby crashes

Post by Forboding Angel » 09 Oct 2011, 10:57

Heh, I don't think SL actually has any fanbois, which is kinda sad all things considered.
0 x

User avatar
AF
AI Developer
Posts: 20669
Joined: 14 Sep 2004, 11:32

Re: Spring Lobby crashes

Post by AF » 10 Oct 2011, 13:30

For reference, the number one reason behind the proliferation of bugs historically in SpringLobby was not negligence or incapable libraries, it was a lack of manpower.

Braindamage and Koshi were the saviours of the project, and even now Koshi needs help to further SASI.
0 x

Satirik
Lobby Developer
Posts: 1688
Joined: 16 Mar 2007, 18:27

Re: Spring Lobby crashes

Post by Satirik » 10 Oct 2011, 16:10

Forboding Angel wrote:Heh, I don't think SL actually has any fanbois, which is kinda sad all things considered.
SL had fanboys in the old days before it became the main lobby (danuker etc)
Last edited by Satirik on 31 Oct 2011, 13:23, edited 1 time in total.
0 x

Panoramix
Posts: 8
Joined: 31 Oct 2011, 12:28

Re: Spring Lobby crashes

Post by Panoramix » 31 Oct 2011, 12:41

I think I will be looking at SL and contributing, if only because the bugs in it are so very annoying under ubuntu. The latest version is several degrees more stable, but I still have problems.

However, I do play ZK mainly so I may look into getting ZK working via Mono instead. Depends on how much time I have over xmas.
0 x

User avatar
hoijui
Former Engine Dev
Posts: 4342
Joined: 22 Sep 2007, 09:51

Re: Spring Lobby crashes

Post by hoijui » 31 Oct 2011, 15:17

getting zkl working over mono is a task .. like 1001 times larger then fixing all bugs in SL, if i am not mistaken. it is not zkl related, but mono/MS related.
0 x

device
Posts: 7
Joined: 07 Nov 2011, 02:07

Re: Spring Lobby crashes

Post by device » 09 Nov 2011, 16:32

Hi all, I have updated spring to 0.83 and my springlobby stopped to working at all.

Have a look :

http://www.kephost.org/di-JZFA.png

It recognise that the official server has a different version, but thats all. I cant play online, because of this.

Any idea how can I make it work again?

Thanks!
0 x

device
Posts: 7
Joined: 07 Nov 2011, 02:07

Re: Spring Lobby crashes

Post by device » 12 Nov 2011, 00:22

Finally I have solved the problem, but for this I had to mess up my packages a little.

So I had python-wxgtk 2.8.11 on my oneiric ubuntu. I have tried to install 2.8.12 stable what is advertised on the wxgtk official page, but had no effect, lobby was still unusable.

I had to rollback, but oneiric offers no other versions.

I have downloaded this .deb file from here :

http://ubuntu.mirror.cambrium.nl/ubuntu ... 2_i386.deb

and after I have tried to install it via midnight commander it said the dependency is broken. (python etc requires blablabla )

I have used this command :

"dpkg -i --force-all python-wxgtk2.8_2.8.10.1-0ubuntu1.2_i386.deb"

after this, I have downloaded the ~82 version because the official server has not been upgraded yet and my springlobby works again!!!

I have set the wxgtk version to be locked in synaptic , just as well the spring related packages.

Just an interesting thing, I let the package manager to update the wxgtk package to the oneiric related version. I thought that the lobby wont work again, and it does !

Only if I'm right, but I have clicked on the view/reset layout inside the lobby, and after that I could use it again.

After all these, try to click on it before u mess up your packages as well...
0 x

varikonniemi
Posts: 447
Joined: 03 Jul 2011, 11:54

Re: Spring Lobby crashes

Post by varikonniemi » 23 Nov 2011, 12:47

Interesting, since i had all the possible problems you could imagine with springlobby when running natty. However when i upgraded to oneiric springlobby has not acted up one single time!

I only wish i would not have gained desync in every game with the upgrade :D
0 x

abma
Spring Developer
Posts: 3560
Joined: 01 Jun 2009, 00:08

Re: Spring Lobby crashes

Post by abma » 30 Dec 2011, 14:56

spring 85.0 (the non-MT) shouldn't desync on oneiric. works fine here...
0 x

varikonniemi
Posts: 447
Joined: 03 Jul 2011, 11:54

Re: Spring Lobby crashes

Post by varikonniemi » 01 Jan 2012, 03:15

Yeah, 85 works perfectly fine.

The new SL that was released at the same time also seems to have fixed the annoying need to restart the lobby to get downloaded maps working. Good job!
0 x

Post Reply

Return to “Linux”