Spring 95.0 released! - Page 2

Spring 95.0 released!

Discuss Spring news, such as fresh releases and press coverage, here.
Google_Frog
Moderator
Posts: 2436
Joined: 12 Oct 2007, 09:24

Re: Spring 95.0 released!

Post by Google_Frog » 07 Nov 2013, 04:19

Lots of people are complaining about 'lags' and this bug may be the cause.
0 x

xyz
Posts: 152
Joined: 29 Nov 2008, 16:06

Re: Spring 95.0 released!

Post by xyz » 07 Nov 2013, 13:38

Grete job and thank you for all the hard work.

I have tested the linux static built yesterday, and all my maps are rendered in doubles. I mean there is the primary map rendered and then offset-ed to the right and further back the second map is rendered.
Also the KAI does not work.

My os: Fedora 19 64 bit up to date
Hardware: AMD FX8350 16G ram NVidia 9800 GT, with latest drivers from akmods.

I will try to get a screen-shot today when I get home.

Thanks.
0 x

User avatar
jamerlan
Balanced Annihilation Developer
Posts: 683
Joined: 20 Oct 2009, 13:04

Re: Spring 95.0 released!

Post by jamerlan » 07 Nov 2013, 13:49

xyz are you talking about /mapborder ?
0 x

xyz
Posts: 152
Joined: 29 Nov 2008, 16:06

Re: Spring 95.0 released!

Post by xyz » 07 Nov 2013, 14:27

jamerlan wrote:xyz are you talking about /mapborder ?
I didn't do anything to enable/disable this feature. I just downloaded the static build and run it.
I don't think it is the map border as the two maps overlap, and when I scroll, the one on the top moves faster then the one on the bottom.
0 x

User avatar
Silentwings
Moderator
Posts: 3586
Joined: 25 Oct 2008, 00:23

Re: Spring 95.0 released!

Post by Silentwings » 07 Nov 2013, 14:41

xyz: Have you tried with the normal nvidia driver?
0 x

xyz
Posts: 152
Joined: 29 Nov 2008, 16:06

Re: Spring 95.0 released!

Post by xyz » 07 Nov 2013, 15:23

Silentwings wrote:xyz: Have you tried with the normal nvidia driver?
No not yet, but 94 build works fine, unless the drivers got updated last night.
I played the 94 build 2 days ago.
0 x

User avatar
AntiAllez
Posts: 105
Joined: 06 Mar 2012, 18:22

Re: Spring 95.0 released!

Post by AntiAllez » 07 Nov 2013, 16:55

spring 94.1 and 95.0 on same system(os) not compatible?

tried ba with 95 portable with singleplayer, before game starts i see arm/core icon+ commander, after it my com disappears and commander score showing me 0vs1..
0 x

User avatar
Silentwings
Moderator
Posts: 3586
Joined: 25 Oct 2008, 00:23

Re: Spring 95.0 released!

Post by Silentwings » 07 Nov 2013, 17:15

@Antiallez: presumably you tried BA 7.83, which predates 95.0 and is not compatible with it. When 95.0 goes live later there will also be a BA update.
0 x

User avatar
koshi
Lobby Developer
Posts: 1058
Joined: 14 Aug 2007, 16:15

Re: Spring 95.0 released!

Post by koshi » 07 Nov 2013, 17:43

Packages for ubuntu are pending in the staging ppa: https://launchpad.net/~spring/+archive/ ... te=pending

If anybody with the right permissions sees those succeed after 95.0 has become the default, feel free to copy over into the spring proper ppa.
0 x

abma
Spring Developer
Posts: 3548
Joined: 01 Jun 2009, 00:08

Re: Spring 95.0 released!

Post by abma » 07 Nov 2013, 23:41

FYI: sorry, setting version will take a bit, have to test some stuff first!

(will be 5 am gmt+1 or so, so no worries)
0 x

xyz
Posts: 152
Joined: 29 Nov 2008, 16:06

Re: Spring 95.0 released!

Post by xyz » 08 Nov 2013, 00:04

Ok this is odd.
This is how it used to look: http://postimg.org/image/lbdxdzcnp/
After reinstalling 94 and running it, going back to 95 fixed the problem, but now path cache initialization lasts 40s-50s in 95. In 94 the entire load is no longer than 10s.
0 x


abma
Spring Developer
Posts: 3548
Joined: 01 Jun 2009, 00:08

Re: Spring 95.0 released!

Post by abma » 08 Nov 2013, 05:40

the people with the "lag": did you try to disable HPET in Bios?


Also please create a bug report, if you think you have found a bug. In the Forum most reports gets lost! please attach infolog.txt, as it contains important information. thanks!

@The Yak:

threadpool is "included", it replaced OMP.
0 x

User avatar
REVENGE
Posts: 2379
Joined: 24 Aug 2006, 06:13

Re: Spring 95.0 released!

Post by REVENGE » 08 Nov 2013, 07:06

Scrolling seems nice and smooth for me. My FPS takes a big hit if I use UseHighResTimer though.

Also, is the sim paused if the app isn't focused?
0 x

klapmongool
Posts: 843
Joined: 13 Aug 2007, 13:19

Re: Spring 95.0 released!

Post by klapmongool » 08 Nov 2013, 07:47

Nice.

What happened to spring-multithreaded.exe though? I didnt come with the installer.
0 x

User avatar
knorke
Posts: 7971
Joined: 22 Feb 2006, 01:02

Re: Spring 95.0 released!

Post by knorke » 08 Nov 2013, 08:45

http://springrts.com/wiki/Download should be updated with new downloads? (it is locked)
0 x

User avatar
Silentwings
Moderator
Posts: 3586
Joined: 25 Oct 2008, 00:23

Re: Spring 95.0 released!

Post by Silentwings » 08 Nov 2013, 10:33

Awesome job :D

Only issue I know of (not a bug): some keybinds stopped working for some ppl & here is how to fix it http://springrts.com/phpbb/viewtopic.ph ... 54#p549654
Last edited by Silentwings on 08 Nov 2013, 19:27, edited 1 time in total.
0 x

User avatar
jK
Spring Developer
Posts: 2299
Joined: 28 Jun 2007, 07:30

Re: Spring 95.0 released!

Post by jK » 08 Nov 2013, 13:42

wiki formatted changelog: http://springrts.com/wiki/Changelog
0 x

abma
Spring Developer
Posts: 3548
Joined: 01 Jun 2009, 00:08

Re: Spring 95.0 released!

Post by abma » 08 Nov 2013, 17:15

What happened to spring-multithreaded.exe though? I didnt come with the installer.
zerver (the only maintainer) refused to fix the problems it had. maybe see http://springrts.com/phpbb/viewtopic.php?f=22&t=30162 and the bugtracker for some of the details. there are much more threads related to it.
also the "default" spring executable has some multithreading.

@xyz:

did you try to change water mode? (/water in spring)
0 x

User avatar
albator
Posts: 866
Joined: 14 Jan 2009, 14:20

Re: Spring 95.0 released!

Post by albator » 08 Nov 2013, 19:14

Got i5 750, I use to be able to play ffa with thousand of unit with 25fps, with single core now, it starts being unplayable at ~20 min....

Looks like no MT is the end of large game for me.

Otherwise great job !
0 x

Post Reply

Return to “News”