Engine Testing - 94.1.1-826-g7f6f61d (6. Aug 2013)

Engine Testing - 94.1.1-826-g7f6f61d (6. Aug 2013)

Discuss the source code and development of Spring Engine in general from a technical point of view. Patches go here too.

Moderator: Moderators

abma
Spring Developer
Posts: 3552
Joined: 01 Jun 2009, 00:08

Engine Testing - 94.1.1-826-g7f6f61d (6. Aug 2013)

Post by abma » 06 Aug 2013, 00:41

New testing release for preparing 95.0!

mostly bugfixes, very few new features:
- replaced OMP with threadpools (fixes Spring.Restart & lower cpu usage at same performance)
- fixed desync related to CEG
- added parentName for OBJ/3DO/S3O pieces
- switch to boost.signals2
- things i forgot

For details of changes since 94.1 look at the "95.0" section in changelog.txt.

See the Testing Release Wiki page for general info about how to obtain the release, and an archive of all testing releases since the last stable one.

If you find a bugs, please report to Mantis.

Please attach infolog.txt as file, if you crash!

sadly the macosx build still fails, still help needed! http://springrts.com/mantis/view.php?id=3816

Is 94.1.1-826-g7f6f61d better than 94.1? if so, IMO we will make a release when nothing major is found.
0 x

User avatar
Forboding Angel
Evolution RTS Developer
Posts: 14599
Joined: 17 Nov 2005, 02:43

Re: Engine Testing - 94.1.1-826-g7f6f61d (6. Aug 2013)

Post by Forboding Angel » 06 Aug 2013, 07:27

Performance is much better.

In multi, non-bot enemies don't seem to spawn.
0 x

Google_Frog
Moderator
Posts: 2439
Joined: 12 Oct 2007, 09:24

Re: Engine Testing - 94.1.1-826-g7f6f61d (6. Aug 2013)

Post by Google_Frog » 06 Aug 2013, 07:29

I found 3 startup crashes and this http://springrts.com/mantis/view.php?id=3896 still occurs.
0 x

abma
Spring Developer
Posts: 3552
Joined: 01 Jun 2009, 00:08

Re: Engine Testing - 94.1.1-826-g7f6f61d (6. Aug 2013)

Post by abma » 06 Aug 2013, 08:07

Forboding Angel wrote:In multi, non-bot enemies don't seem to spawn.
details (infolog.txt & script.txt)? i can't reproduce this... in validation tests bots are spawned.
0 x

User avatar
jamerlan
Balanced Annihilation Developer
Posts: 683
Joined: 20 Oct 2009, 13:04

Re: Engine Testing - 94.1.1-826-g7f6f61d (6. Aug 2013)

Post by jamerlan » 06 Aug 2013, 11:26

I tested 64 bit linux version with intel gpu.
1) Progress bar during loading was showing ??? without any progress. Maybe BA needs to update it? and it's not a bug?
2) Strange errors in infolog.txt Error: [Watchdog::ClearTimer] Invalid thread 4
3) Recompress MapTiles with ETC1 stage took too much time during loading. Like 10x longer then 94.1 loading.

infolog.txt: http://pastebin.com/MdKa19Ge

When I run spring second time - it showed progress bar. Recompress MapTiles was at 4% and it was here very long time. Then game started. There were no additional steps visible to user from 4% to 100% :-)
After second run I still have these in infolog: [f=0003931] Warning: (in thread: main)
[f=0003931] Error: [Watchdog::ClearTimer] Invalid thread 4
0 x

User avatar
jamerlan
Balanced Annihilation Developer
Posts: 683
Joined: 20 Oct 2009, 13:04

Re: Engine Testing - 94.1.1-826-g7f6f61d (6. Aug 2013)

Post by jamerlan » 06 Aug 2013, 11:36

I deleted spring portable folder and unpacked again to test new spring on nvidia gpu from scratch.

I started spring and there were no progress on progress bar. Only "???". Looks like it don't show progress when you playing first time after install. When I started game second time - all OK with progress bar. And it showed more then 4% of progress so no issues.

On nvidia there were no "Recompress MapTiles with ETC1" so game was started VERY FAST :-D

infolog.txt: http://pastebin.com/HDbP7taK
0 x

User avatar
jamerlan
Balanced Annihilation Developer
Posts: 683
Joined: 20 Oct 2009, 13:04

Re: Engine Testing - 94.1.1-826-g7f6f61d (6. Aug 2013)

Post by jamerlan » 06 Aug 2013, 12:05

Strange thing. I can build t2 arm browlers much faster then t2 fighters. Long pauses between t2 fighters from t2 air factory.
0 x

User avatar
jamerlan
Balanced Annihilation Developer
Posts: 683
Joined: 20 Oct 2009, 13:04

Re: Engine Testing - 94.1.1-826-g7f6f61d (6. Aug 2013)

Post by jamerlan » 06 Aug 2013, 12:11

jamerlan wrote:Strange thing. I can build t2 arm browlers much faster then t2 fighters. Long pauses between t2 fighters from t2 air factory.
same issues with t1 fighters (and maybe other airplanes)
0 x

Manoa
Posts: 79
Joined: 19 May 2008, 18:51

Re: Engine Testing - 94.1.1-826-g7f6f61d (6. Aug 2013)

Post by Manoa » 06 Aug 2013, 13:17

dude I can't start a game with any bots and without any bots, I get to the loading screen after selecting map/mod/AI and everything is frozen and I have to kill the spring process (I see the map and the cursor and the list of players (2 red color), but cursor and keyboard are not responding), I tested this with 2 mods: BA 7.78 Tech Annihilation 2.20.2, same thing.

next problem is minor but should be noted: the loading progress bar misrepresents the current loading status: it seems to believe that the "creating with 2 PF threads" is the last part of the loading process and so once it is finished it stays at 100% and continues to load (loading continues but % stays at 100%)

new update: tested on another machine with a normal video card (nvidia), it works fine on it
Attachments
infolog.txt
check it out dude
(27.46 KiB) Downloaded 6 times
Last edited by Manoa on 07 Aug 2013, 01:10, edited 3 times in total.
0 x

User avatar
Forboding Angel
Evolution RTS Developer
Posts: 14599
Joined: 17 Nov 2005, 02:43

Re: Engine Testing - 94.1.1-826-g7f6f61d (6. Aug 2013)

Post by Forboding Angel » 06 Aug 2013, 13:22

Gunships are completely buggered.
http://springrts.com/mantis/view.php?id=3896

Lots of crash bugs.
0 x

User avatar
Beherith
Moderator
Posts: 4934
Joined: 26 Oct 2007, 16:21

Re: Engine Testing - 94.1.1-826-g7f6f61d (6. Aug 2013)

Post by Beherith » 06 Aug 2013, 13:32

Great stuff in this build!
Thank you everyone.

A few things I noticed:

UIkeys.txt no longer distributed in portable
Most generic keys are missing (ctrl f[2-4] camera, shift-esc quit, etc)
Takes 10s to recover from alt+tab
Windowborderless obeys windowxpos and windowypos yet cannot be repositioned
0 x

User avatar
Silentwings
Moderator
Posts: 3589
Joined: 25 Oct 2008, 00:23

Re: Engine Testing - 94.1.1-826-g7f6f61d (6. Aug 2013)

Post by Silentwings » 06 Aug 2013, 15:32

Nice :) Thanks especially for fixing Spring.Restart!

Something quick I noticed; not sure if its intentional or not. The progress bar on the new loadscreens shows ??? on the first time a new map is used (with -826) but on subsequent loads of the same map it displays %s.
0 x

varikonniemi
Posts: 447
Joined: 03 Jul 2011, 11:54

Re: Engine Testing - 94.1.1-826-g7f6f61d (6. Aug 2013)

Post by varikonniemi » 06 Aug 2013, 16:06

edit: no problem, user (or driver) failure.
0 x

User avatar
jamerlan
Balanced Annihilation Developer
Posts: 683
Joined: 20 Oct 2009, 13:04

Re: Engine Testing - 94.1.1-826-g7f6f61d (6. Aug 2013)

Post by jamerlan » 06 Aug 2013, 17:05

At "Recompress MapTiles with ETC1" stage I wanted to kill spring because I thought that it is frozen. Maybe other people face that issue :-D

Spring is not frozen but really looks like frozen. All you need is to wait a few mins (wait a lot) in case of that issue.
0 x

User avatar
Beherith
Moderator
Posts: 4934
Joined: 26 Oct 2007, 16:21

Re: Engine Testing - 94.1.1-826-g7f6f61d (6. Aug 2013)

Post by Beherith » 06 Aug 2013, 17:47

What is this recompress maptiles?
0 x

User avatar
FLOZi
MC: Legacy & Spring 1944 Developer
Posts: 6109
Joined: 29 Apr 2005, 01:14

Re: Engine Testing - 94.1.1-826-g7f6f61d (6. Aug 2013)

Post by FLOZi » 06 Aug 2013, 18:04

Crash on load:

http://paste.springfiles.com/view/2423390e

Caused by a bad unitdefs_post (error is logged in infolog correctly) but in previous versions this gave a popup error on exit.
0 x

abma
Spring Developer
Posts: 3552
Joined: 01 Jun 2009, 00:08

Re: Engine Testing - 94.1.1-826-g7f6f61d (6. Aug 2013)

Post by abma » 06 Aug 2013, 18:11

Beherith wrote:What is this recompress maptiles?
i guess this says it all:
https://github.com/spring/spring/blob/d ... s.cpp#L156
0 x

User avatar
Beherith
Moderator
Posts: 4934
Joined: 26 Oct 2007, 16:21

Re: Engine Testing - 94.1.1-826-g7f6f61d (6. Aug 2013)

Post by Beherith » 06 Aug 2013, 18:28

Thanks abma!
0 x

User avatar
FLOZi
MC: Legacy & Spring 1944 Developer
Posts: 6109
Joined: 29 Apr 2005, 01:14

Re: Engine Testing - 94.1.1-826-g7f6f61d (6. Aug 2013)

Post by FLOZi » 06 Aug 2013, 18:39

0 x

abma
Spring Developer
Posts: 3552
Joined: 01 Jun 2009, 00:08

Re: Engine Testing - 94.1.1-826-g7f6f61d (6. Aug 2013)

Post by abma » 06 Aug 2013, 18:49

thanks guys! imo most crashes seems to be related to threadpool, we'll try to fix these first...
0 x

Post Reply

Return to “Engine”