Search

Search found 36 matches

by kfriars
16 Mar 2012, 08:51
Forum: Lua Scripts
Topic: gl display lists
Replies: 5
Views: 416

Re: gl display lists

Good catch jK, thank you. No error message in infolog though.

Edit: I was rotating improperly before

Thanks for your help :)
by kfriars
16 Mar 2012, 08:15
Forum: Lua Scripts
Topic: gl display lists
Replies: 5
Views: 416

Re: gl display lists

So, still stumped actually. Found a couple things that were clearly wrong, so this is what i have now. displayLists[source[3]] = gl.CreateList( function() gl.PushMatrix() gl.Translate(x1 - 100*scale/2, 0, z1) gl.Rotate(theta,0,0,0) gl.Scale(scale,1,scale) gl.Texture("LuaUI/Images/OrderTextures/MTO_"...
by kfriars
16 Mar 2012, 07:22
Forum: Lua Scripts
Topic: gl display lists
Replies: 5
Views: 416

Re: gl display lists

Shoulda looked harder... Ther post from user in the thread, http://springrts.com/phpbb/viewtopic.php?f=23&t=14033 has been enlightening.
by kfriars
16 Mar 2012, 06:55
Forum: Lua Scripts
Topic: gl display lists
Replies: 5
Views: 416

gl display lists

So there isnt too much information on this on the web, however I did some research and what I have I think should work, however im not sure if I should be pushing and popping the stack. So what I am trying to do is create a list of display lists and then loop through them in DrawWorldPreUnit() Here ...
by kfriars
14 Mar 2012, 11:22
Forum: Lua Scripts
Topic: Synced/Unsynced Communication
Replies: 16
Views: 2335

Re: Synced/Unsynced Communication

SOLVED.

Has to be in a gadget to have access to spairs.
by kfriars
14 Mar 2012, 10:55
Forum: Lua Scripts
Topic: Synced/Unsynced Communication
Replies: 16
Views: 2335

Re: Synced/Unsynced Communication

Lua is not recognizing spairs. Anything special I need to do here?
by kfriars
09 Mar 2012, 17:13
Forum: AI
Topic: The call to initStatic() returned unsuccessfuly.
Replies: 22
Views: 6374

Re: The call to initStatic() returned unsuccessfuly.

Forgot to mention i also tried with jdk1.6.0_31
by kfriars
09 Mar 2012, 17:05
Forum: AI
Topic: The call to initStatic() returned unsuccessfuly.
Replies: 22
Views: 6374

Re: The call to initStatic() returned unsuccessfuly.

Just downloaded newest jdk and set JAVA_HOME to C:\Program Files (x86)\Java\jdk1.7.0_03\bin and received the same result.
by kfriars
09 Mar 2012, 13:05
Forum: AI
Topic: The call to initStatic() returned unsuccessfuly.
Replies: 22
Views: 6374

Re: The call to initStatic() returned unsuccessfuly.

JAVA_HOME = C:\Program Files (x86)\Java\jre6

interface-log
http://pastebin.com/mbaADuFM

infolog.txt
http://pastebin.com/hmRbwn2W

dir output of C:\Program Files (x86)\Java\jre6
http://pastebin.com/pgxM3FnF
by kfriars
09 Mar 2012, 12:10
Forum: AI
Topic: The call to initStatic() returned unsuccessfuly.
Replies: 22
Views: 6374

Re: The call to initStatic() returned unsuccessfuly.

Hey, So I am having the exact same problem as was being described here and have followed it up to this point. I am on windows 64 bit and after installing the 32bit jre and pointed the JAVA_HOME environment variable to it i am getting the following error in my interface-log "Failed locating the clien...
by kfriars
24 Feb 2012, 02:45
Forum: Engine
Topic: boost link issues/Boost_DIR ?
Replies: 21
Views: 2574

Re: boost link issues/Boost_DIR ?

OMGOMGOMG! Success... after... 4 days.. I know, I'm a noob... but I WIN. lol If you would like me to post complete and detailed instructions / tips and tricks from my adventures (not setting up a buildbot) to cross compile, let me know and I can send them to someone who can edit/review them and if t...
by kfriars
23 Feb 2012, 21:56
Forum: Engine
Topic: boost link issues/Boost_DIR ?
Replies: 21
Views: 2574

Re: boost link issues/Boost_DIR ?

Thanks abma once again I derped / my cmake and local environment is borked... I had just found that on one of the threads right before you posted it, I was looking for a static library for some reason.. SO sad now... 97%. And... [ 97%] Building CXX object test/CMakeFiles/test_BitwiseEnum.dir/engine/...
by kfriars
23 Feb 2012, 19:42
Forum: Engine
Topic: boost link issues/Boost_DIR ?
Replies: 21
Views: 2574

Re: boost link issues/Boost_DIR ?

So for whatever reason cmake was insistent on not finding my DEVIL_IL_LIBRARY so I had to configure then modify the cache.. then reload the cache, then reconfigure, then generate the unix makefiles. All went smooth.. until it tried to find glew's library, which is currently pointing at: //Path to a ...
by kfriars
23 Feb 2012, 18:15
Forum: Engine
Topic: boost link issues/Boost_DIR ?
Replies: 21
Views: 2574

Re: boost link issues/Boost_DIR ?

Thanks for pointing me in the right direction jK. Back on topic... I recompiled mingw with gcc-4.4.4 and I it solved all of the previously defined errors however it still seems to be unable to find my DevIL. In my cmake config i get the following: Found DevIL: /home/kfriars/Spring/Source/spring-xcom...
by kfriars
23 Feb 2012, 17:00
Forum: Engine
Topic: boost link issues/Boost_DIR ?
Replies: 21
Views: 2574

Re: boost link issues/Boost_DIR ?

Just out of curiosity, and I know this is going off topic for this thread now, but why would this not be included? It is a primitive very much along the lines of glDrawGroundCircle and glDrawGroundQuad. Since I will be drawing many lines on the screen it would be better performance-wise to have it i...
by kfriars
23 Feb 2012, 15:43
Forum: Engine
Topic: boost link issues/Boost_DIR ?
Replies: 21
Views: 2574

Re: boost link issues/Boost_DIR ?

They are very small changes (Add the Hook in /rts/lua/LuaOpenGL.cpp, and add one function almost identical to defSurfaceQuad and defSurfaceCircle in /rts/Rendering/GL/glExtra.cpp).. My changes work 100% fine on Linux but I wanted to test them on windows before I made any requests. I will try to comp...
by kfriars
23 Feb 2012, 14:24
Forum: Engine
Topic: boost link issues/Boost_DIR ?
Replies: 21
Views: 2574

Re: boost link issues/Boost_DIR ?

I am developing a mod which is a remake of the board game diplomacy... kind of like risk and needed to add a function to draw lines along the ground (to display territory boundaries), so I followed the example of Spring - Lua's glDrawGroundQuad and glDrawGroundCircle, adding glDrawGroundLine (I am n...
by kfriars
23 Feb 2012, 00:06
Forum: Engine
Topic: boost link issues/Boost_DIR ?
Replies: 21
Views: 2574

Re: boost link issues/Boost_DIR ?

The "tmp-*" folders get removed automatically by the makefile after the component has successfully been built. There is no tmp-gcc folder in the mingw-cross-env-2.21 folder according to ls -la as a result of that. The entire error message is as follows. Creating library file: libunitsync.dll.a /home...
by kfriars
22 Feb 2012, 05:06
Forum: Engine
Topic: boost link issues/Boost_DIR ?
Replies: 21
Views: 2574

Re: boost link issues/Boost_DIR ?

Please excuse my git noobery... You use the "git checkout d6de2bc424ec7bec9ec45e01f7032f66ef9a55d0" command from within the existing cloned folder. So now that I figured that out... It does compile further than last time but now, with the version of mingwlibs you mention it is breaking at: [ 25%] Bu...
by kfriars
22 Feb 2012, 02:37
Forum: Engine
Topic: boost link issues/Boost_DIR ?
Replies: 21
Views: 2574

Re: boost link issues/Boost_DIR ?

git is telling me that is not a git repository.

Go to advanced search