2019-11-17 20:59 CET

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0000733Spring engineGeneralpublic2008-01-03 02:39
ReporterLordMatt 
Assigned ToLordMatt 
PrioritynormalSeverityminorReproducibilityalways
StatusresolvedResolutionfixed 
Product Version 
Target VersionFixed in Version 
Summary0000733: LuaUI Errors whenever spectator sends a chat message
DescriptionIf I watch the attached demo (the original one), I get LuaUI Errors:
LuaUI::RunCallin: error=2, Add Console Line, [String"-------------,,,"]:381: attempt to perform arithmetic on local 'v' (a nil value). This happens whenever I had previously typed a command as team 1 (after starting as team 0 in the original game). My console is managed by the latest version of IceUI.
TagsNo tags attached.
Checked infolog.txt for Errors
Attached Files

-Relationships
+Relationships

-Notes

~0001560

LordMatt (reporter)

This with r5128.

~0001621

el_matarife (reporter)

If this demo still works in the newest SVN we should test it @ 7PM GMT since I'd assume this is 100% reproducible. Not a blocking or major issue but should be on the fix list, time permitting.

~0001658

LordMatt (reporter)

I get these whenever a spectator talks. I'm using IceUI, so it may be an IceUI error, or a LuaUI error caused by IceUI calling a particular function.

~0001664

LordMatt (reporter)

Fixed in IceUI
+Notes

-Issue History
Date Modified Username Field Change
2007-12-26 23:28 LordMatt New Issue
2007-12-26 23:28 LordMatt File Added: demos.tar.bz2
2007-12-26 23:29 LordMatt Note Added: 0001560
2008-01-01 17:15 el_matarife Note Added: 0001621
2008-01-02 20:18 LordMatt Note Added: 0001658
2008-01-02 20:19 LordMatt Summary LuaUI Errors watching demo (happening when commands typed as different team) => LuaUI Errors whenever spectator sends a chat message
2008-01-03 02:35 LordMatt Note Added: 0001664
2008-01-03 02:36 LordMatt Status new => resolved
2008-01-03 02:36 LordMatt Resolution open => fixed
2008-01-03 02:39 LordMatt Assigned To => LordMatt
2008-01-03 02:39 LordMatt Status resolved => feedback
2008-01-03 02:39 LordMatt Resolution fixed => reopened
2008-01-03 02:39 LordMatt Status feedback => resolved
2008-01-03 02:39 LordMatt Resolution reopened => fixed
+Issue History