2019-08-26 00:39 CEST

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0006119Spring engineGeneralpublic2019-01-29 02:03
ReporterFloris 
Assigned ToKloot 
PrioritynormalSeverityminorReproducibilityhave not tried
StatusresolvedResolutionfixed 
Product Version104.0 +git 
Target VersionFixed in Version104.0 +git 
Summary0006119: crash for everybody2
Descriptioni was under the impression this was fixed in -968, am i wrong?
TagsNo tags attached.
Checked infolog.txt for lua Errors
Attached Files

-Relationships
+Relationships

-Notes

~0019669

Floris (reporter)

included demo

~0019670

Floris (reporter)

btw... crashes just after queen spawn

~0019671

Kloot (developer)

it was, but 968 contained another CTD bug which I did not catch in time. afaics all BA/TA autohosts have now jumped to 969 so it only triggered during this game.

btw, it has come to my attention that BA players do not like frequent updates and want a "stable" release. you may need to remind them again this is just part of the quid-pro-quo of using a free product and that engine development can realistically only make progress (or survive, at this point) when code is tested early and often by N people at once. the 104 maintenance builds allowed iteratively eliminating a *whole* lot of issues in far less time than it would have taken previously, and I don't think the old release model (which led to multiple shitstorms over the years) can work anymore.

~0019672

Floris (reporter)

hah, no, I dont have control over hosts, I get what you mean and you've proven to quickly fix problems. But we lack motivation/devs. The players indeed want stable releases. One of the reason ba 9.46 is still going. And the fact the springlobby server rules dont give gamedevs any power... gg. It's the main reason I resigned. Due to bluestone/nixtus opposition about changing this fact.

~0019673

Floris (reporter)

(...well have the ACE hosts manually updating and the darkenergy hosts automaticly, and they want to change that to manually for darkenergy hosts as well)

~0019674

Kloot (developer)

Last edited: 2019-01-29 02:03

View 3 revisions

> we lack motivation/devs

same goes for engine development these days, watching the BA and ZK sagas unfold has drained much of mine.

without going into server politics, I'll just say the recent sanctioning of yet more 103 autohosts and resistance to updates is endangering Spring's future.

~0019680

silentwings (reporter)

The new 103 hosts agreed with me, when I allowed them to set up, that they would update when the lobbyserver enforces 104.

I don't know why it hasn't happened already. Afaik the lobby server code was ready since months ago, but abma hasn't responded to any of my PMs asking when the lobbyserver updates will be set live.

~0019695

MaDDoX (reporter)

As TA Prime has a big focus on using the latest shaders and graphical tech as being (gracefully) developed by Ivand, SanguinarioJoe & others, I can assure we'll update our servers weekly to the latest development release.

None of this would be ever possible without your facilitation and continued effort Kloot, thank you very much.

~0019698

Kloot (developer)

that does help, thanks.

I can't promise all updates will be painless or equally useful, but hopefully we can avoid the alternative.
+Notes

-Issue History
Date Modified Username Field Change
2019-01-20 22:06 Floris New Issue
2019-01-20 22:06 Floris File Added: infolog - Copy (7).txt
2019-01-20 22:06 Floris File Added: 20190120_205740_Asteroid Defense 1_104.0.1-968-gb54c668 maintenance.sdfz
2019-01-20 22:06 Floris Note Added: 0019669
2019-01-20 22:07 Floris Note Added: 0019670
2019-01-20 23:05 Kloot Assigned To => Kloot
2019-01-20 23:05 Kloot Status new => closed
2019-01-20 23:05 Kloot Resolution open => fixed
2019-01-20 23:05 Kloot Fixed in Version => 104.0 +git
2019-01-20 23:05 Kloot Note Added: 0019671
2019-01-20 23:19 Floris Status closed => feedback
2019-01-20 23:19 Floris Resolution fixed => reopened
2019-01-20 23:19 Floris Note Added: 0019672
2019-01-20 23:25 Floris Note Added: 0019673
2019-01-20 23:25 Floris Status feedback => assigned
2019-01-20 23:49 Kloot Note Added: 0019674
2019-01-20 23:51 Kloot Note Edited: 0019674 View Revisions
2019-01-22 23:28 silentwings Note Added: 0019680
2019-01-28 17:37 MaDDoX Note Added: 0019695
2019-01-29 02:01 Kloot Note Added: 0019698
2019-01-29 02:01 Kloot Status assigned => resolved
2019-01-29 02:01 Kloot Resolution reopened => fixed
2019-01-29 02:03 Kloot Note Edited: 0019674 View Revisions
+Issue History