2019-08-21 07:16 CEST

View Issue Details Jump to Notes ] Related Changesets ]
IDProjectCategoryView StatusLast Update
0005941Spring engineLuapublic2018-03-31 14:41
ReporterGoogle_Frog 
Assigned ToKloot 
PrioritynormalSeverityminorReproducibilityalways
StatusresolvedResolutionfixed 
Product Version104.0 +git 
Target VersionFixed in Version 
Summary0005941: AllowUnitCloak is not called for units in transports.
DescriptionI call SetUnitCloak on a unit in a transport, with level 2 or 4, and AllowUnitCloak is not called for the unit.
TagsNo tags attached.
Checked infolog.txt for lua Errors
Attached Files

-Relationships
+Relationships

-Notes

~0018942

Kloot (developer)

Fix e97c30ed8f478eef594c3a3e9e32803f9f73b9ff committed to develop branch: fix 0005941
units can now cloak even while stunned, unless a gadget disallows this, repo: spring changeset id: 9876

~0018943

Kloot (developer)

Fix b30232f9a38b02e0cfc0ec5f2ff0d7c307c37132 committed to maintenance branch: fix 0005941
units can now cloak even while stunned, unless a gadget disallows this, repo: spring changeset id: 9877

~0018950

Google_Frog (reporter)

AllowUnitCloak is now called for transports but the second argument seems to always be identical to the first argument. I can't tell when an enemy is near a unit in a transport.

~0018951

Kloot (developer)

enemyID == unitID is telling you the unit that wants to cloak is *stunned*.

this situation is uncommon enough that scanning for enemies on the gadget side won't break the bank.

~0018955

Google_Frog (reporter)

Ok. There should be a comment in the gadgethandler about that because that behaviour is pretty weird.

~0018956

Google_Frog (reporter)

https://github.com/ZeroK-RTS/Zero-K/commit/274c2bc515a787b3a3d400a26fe0a7f3260878e8

~0018959

Kloot (developer)

maybe, I don't expect such a comment to receive much eye-time.

the behavior may seem weird but it allows gadgets to write "if enemyID then return false end" and make stunned units decloak (which was the default) without any special checks.
+Notes

+Related Changesets

-Issue History
Date Modified Username Field Change
2018-03-27 07:21 Google_Frog New Issue
2018-03-27 18:00 Kloot Changeset attached => spring develop e97c30ed
2018-03-27 18:00 Kloot Note Added: 0018942
2018-03-27 18:00 Kloot Assigned To => Kloot
2018-03-27 18:00 Kloot Status new => resolved
2018-03-27 18:00 Kloot Resolution open => fixed
2018-03-27 18:02 Kloot Changeset attached => spring maintenance b30232f9
2018-03-27 18:02 Kloot Note Added: 0018943
2018-03-30 10:07 Google_Frog Status resolved => feedback
2018-03-30 10:07 Google_Frog Resolution fixed => reopened
2018-03-30 10:07 Google_Frog Note Added: 0018950
2018-03-30 10:38 Kloot Note Added: 0018951
2018-03-30 13:33 Google_Frog Note Added: 0018955
2018-03-30 13:33 Google_Frog Status feedback => assigned
2018-03-30 13:35 Google_Frog Note Added: 0018956
2018-03-31 14:41 Kloot Status assigned => resolved
2018-03-31 14:41 Kloot Resolution reopened => fixed
2018-03-31 14:41 Kloot Note Added: 0018959
+Issue History