2019-08-21 18:29 CEST

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0005849Spring engineGeneralpublic2017-12-29 19:52
ReporterFloris 
Assigned ToKloot 
PrioritynormalSeverityminorReproducibilityalways
StatusassignedResolutionreopened 
Product Version104.0 +git 
Target VersionFixed in Version 
Summary0005849: commandFire = true, manual attack will only fire once and not until enemy unit is destroyed
Description"bool commandFire  default: false
Determines if the weapon will automatically fire on enemy units in range or only when manually ordered to attack."

I put this to true, but when you then manually order to attack a unit, it will only fire once and not repeatedly until that unit is dead, like it used to be doing before.

This is unexpected behavior if you ask me
TagsNo tags attached.
Checked infolog.txt for lua Errors
Attached Files

-Relationships
+Relationships

-Notes

~0018674

silentwings (reporter)

> like it used to be doing before.

My memory of repeatedly fixing the armcybr over the years is that commandfire=true has only ever fired once, regardless of target.

~0018675

Kloot (developer)

That is the correct interpretation and happens to be backed up by old issues related to commandfire like 0003154 and 0002326.

I have seen too many reports based on faulty memories to act on this without stronger evidence.

~0018681

Floris (reporter)

just that wiki doesn't say it does this aswell...

"bool commandFire  default: false 
Determines if the weapon will automatically fire on enemy units in range or only when manually ordered to attack."


Anyway, I added this to fighters air2ground weapon, so you can still manually attack ground targets, but they wont do that by on their own. But its annoying that they wont target until the ground unit is destroyed now.

Plz suggest a way to do this/update wiki/implement this for future

~0018682

sprung (reporter)

https://github.com/spring/spring/blob/ee05619611042365541b9cc46311b8737ddc166e/rts/Sim/Units/CommandAI/CommandAI.cpp#L1667

Try the META modifier?

~0018683

hokomoko (developer)

also maybe try using the noAutoTarget tag instead of commandFire

~0018684

Floris (reporter)

noautotarget is only listed in lua weapondefs but it doesnt work anyway

~0018685

sprung (reporter)

https://github.com/spring/spring/pull/357

~0018698

Forboding Angel (reporter)

I agree with Floris. This behavior is really frustrating, especially if you need to put it on say an lrpc that costs a ton of energy to fire. You don't want it randomly firing on it's own, but you also don't want to have to babysit it when you tell it to kill something.

But there is also another issue. You want the current behavior when targeting a nuke for example. Because you don't want the nuke to act like it's on repeat.

Technically you could use repeat to get the wanted behavior, but that is unintuitive and introduces another whole set of issues.
+Notes

-Issue History
Date Modified Username Field Change
2017-12-01 18:18 Floris New Issue
2017-12-06 15:03 silentwings Note Added: 0018674
2017-12-07 00:55 Kloot Assigned To => Kloot
2017-12-07 00:55 Kloot Status new => closed
2017-12-07 00:55 Kloot Resolution open => no change required
2017-12-07 00:55 Kloot Note Added: 0018675
2017-12-08 14:33 Floris Status closed => feedback
2017-12-08 14:33 Floris Resolution no change required => reopened
2017-12-08 14:33 Floris Note Added: 0018681
2017-12-08 15:35 sprung Note Added: 0018682
2017-12-08 15:46 hokomoko Note Added: 0018683
2017-12-08 16:30 Floris Note Added: 0018684
2017-12-08 16:30 Floris Status feedback => assigned
2017-12-08 16:46 sprung Note Added: 0018685
2017-12-29 19:52 Forboding Angel Note Added: 0018698
+Issue History